aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/qtcreator/Makefile6
-rw-r--r--editors/calligra/Makefile3
-rw-r--r--games/pink-pony/Makefile4
-rw-r--r--graphics/aqsis/Makefile3
-rw-r--r--graphics/cinepaint/Makefile4
-rw-r--r--graphics/exact-image/Makefile4
-rw-r--r--graphics/fyre/Makefile4
-rw-r--r--graphics/gegl/Makefile4
-rw-r--r--graphics/gimp-gmic-plugin/Makefile3
-rw-r--r--graphics/luxrender/Makefile4
-rw-r--r--graphics/nvidia-texture-tools/Makefile4
-rw-r--r--graphics/py-openexr/Makefile3
-rw-r--r--graphics/visionworkbench/Makefile4
-rw-r--r--sysutils/easypbi/Makefile6
-rw-r--r--x11/kde4-runtime/Makefile4
-rw-r--r--x11/kdelibs4/Makefile4
16 files changed, 34 insertions, 30 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 0f50e3b896d9..2fa267176910 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qtcreator
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://download.qt.nokia.com/qtcreator/
DISTNAME= qt-creator-${PORTVERSION}-src
@@ -15,8 +15,8 @@ DISTNAME= qt-creator-${PORTVERSION}-src
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Creator IDE and tools
-LIB_DEPENDS= Imath.6:${PORTSDIR}/graphics/ilmbase \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.11:${PORTSDIR}/graphics/jpeg
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 19a0ec4f01b0..92460f0db7d5 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,6 +2,7 @@
PORTNAME= calligra
PORTVERSION= ${CALLIGRA_VERSION}
+PORTREVSION= 1
CATEGORIES= editors kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${CALLIGRA_BRANCH}/${PORTNAME}-${PORTVERSION}/
@@ -11,7 +12,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= KDE graphic art and office suite
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
boost_thread.4:${PORTSDIR}/devel/boost-libs \
qca.2:${PORTSDIR}/devel/qca \
exiv2.12:${PORTSDIR}/graphics/exiv2 \
diff --git a/games/pink-pony/Makefile b/games/pink-pony/Makefile
index fd6a35800ded..6dcda4164cc9 100644
--- a/games/pink-pony/Makefile
+++ b/games/pink-pony/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pink-pony
PORTVERSION= 1.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE \
http://mirror.amdmi3.ru/distfiles/
@@ -18,7 +18,7 @@ COMMENT= Tron-like multiplayer racing game
LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
protobuf.7:${PORTSDIR}/devel/protobuf \
glfw.0:${PORTSDIR}/graphics/glfw \
- Half.6:${PORTSDIR}/graphics/ilmbase \
+ Half:${PORTSDIR}/graphics/ilmbase \
ftgl.2:${PORTSDIR}/graphics/ftgl \
sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
BUILD_DEPENDS= ${LOCALBASE}/lib/libaudiere.so:${PORTSDIR}/audio/audiere
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index a9a8db4d5f3e..95f2b8455e15 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -8,6 +8,7 @@
PORTNAME= aqsis
PORTVERSION= 1.8.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
@@ -19,7 +20,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
tiff.4:${PORTSDIR}/graphics/tiff \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 687ea4c5a644..8330fe280b90 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cinepaint
PORTVERSION= 0.22
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/CinePaint/CinePaint-${PORTVERSION}-1
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
@@ -45,7 +45,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include/openEXR
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index ae64f17c59da..786ee03f9659 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exact-image
PORTVERSION= 0.8.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5 python
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/ LOCAL/bf
@@ -23,7 +23,7 @@ LIB_DEPENDS= agg.2:${PORTSDIR}/graphics/agg \
png15:${PORTSDIR}/graphics/png \
gif.5:${PORTSDIR}/graphics/giflib \
jasper.4:${PORTSDIR}/graphics/jasper \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
lcms.1:${PORTSDIR}/graphics/lcms \
freetype.9:${PORTSDIR}/print/freetype2 \
expat.6:${PORTSDIR}/textproc/expat2
diff --git a/graphics/fyre/Makefile b/graphics/fyre/Makefile
index d3c5cdb4a011..ee4d573eb3e0 100644
--- a/graphics/fyre/Makefile
+++ b/graphics/fyre/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fyre
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://releases.navi.cx/fyre/
@@ -36,7 +36,7 @@ CFLAGS+= -march=native -O3 -ffast-math -fomit-frame-pointer
.endif
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
.else
CONFIGURE_ARGS+=--disable-openexr
.endif
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 750494dfc7fd..1915cf6c7a1b 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.1.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.1/
@@ -127,7 +127,7 @@ CONFIGURE_ARGS+=--without-lua
.endif
.if !defined(WITHOUT_OPENEXR)
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
.else
CONFIGURE_ARGS+=--without-openexr
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 160423be5ab7..4ea13f98963d 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmic
PORTVERSION= 1.5.2.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/old
@@ -14,7 +15,7 @@ MAINTAINER= rm@FreeBSD.org
COMMENT= GREYC's Magic Image Converter
LIB_DEPENDS= GraphicsMagick++.9:${PORTSDIR}/graphics/GraphicsMagick13 \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
Magick++:${PORTSDIR}/graphics/ImageMagick \
avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
fftw3:${PORTSDIR}/math/fftw3 \
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 97ba697d4feb..b0baa30cd8e9 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -7,7 +7,7 @@
PORTNAME= luxrender
PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://src.luxrender.net/lux/archive/ \
http://freebsd.nsu.ru/distfiles/luxrender/
@@ -24,7 +24,7 @@ BROKEN= does not build with boost-1.48.0
BUILD_DEPENDS= ${LOCALBASE}/lib/libfreeimage.a:${PORTSDIR}/graphics/freeimage
LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
png15:${PORTSDIR}/graphics/png \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
HG_NODEID= 9206b3ba7011
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index b3fca1e5059c..8a6f5c0d0d3e 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nvidia-texture-tools
DISTVERSION= 2.0.8-1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE \
http://mirror.amdmi3.ru/distfiles/
@@ -18,7 +18,7 @@ COMMENT= Texture Tools with support for DirectX 10 texture formats
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+ IlmImf:${PORTSDIR}/graphics/OpenEXR
USE_CMAKE= yes
CMAKE_ARGS= -DNVTT_SHARED=TRUE
diff --git a/graphics/py-openexr/Makefile b/graphics/py-openexr/Makefile
index 7600617c8915..cdd310f4a308 100644
--- a/graphics/py-openexr/Makefile
+++ b/graphics/py-openexr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openexr
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://excamera.com/files/ \
CHEESESHOP
@@ -16,7 +17,7 @@ DISTNAME= OpenEXR-${PORTVERSION}
MAINTAINER= jamesb-bsd@excamera.com
COMMENT= Python module for ILM's OpenEXR image format and library
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR
post-extract:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/setup.py
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 901c06e33675..00acccb94698 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -7,7 +7,7 @@
PORTNAME= visionworkbench
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://ti.arc.nasa.gov/m/project/nasa-vision-workbench/
DISTNAME= VisionWorkbench-${PORTVERSION}
@@ -33,7 +33,7 @@ LIB_DEPENDS+= boost_thread.4:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs
LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
LIB_DEPENDS+= cairomm-1.0.1:${PORTSDIR}/graphics/cairomm
.include <bsd.port.pre.mk>
diff --git a/sysutils/easypbi/Makefile b/sysutils/easypbi/Makefile
index 3fed874f99ee..57c15f9999e3 100644
--- a/sysutils/easypbi/Makefile
+++ b/sysutils/easypbi/Makefile
@@ -7,15 +7,15 @@
PORTNAME= easypbi
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= SF/makeapbi/${PORTNAME}/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= Graphical PBI module and package creator
-LIB_DEPENDS= Imath.6:${PORTSDIR}/graphics/ilmbase \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase \
+ IlmImf:${PORTSDIR}/graphics/OpenEXR \
jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.11:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= ${LOCALBASE}/bin/gksu:${PORTSDIR}/sysutils/gksu \
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 52ccbbaf20bb..90e75f9172de 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kde-runtime
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -17,7 +17,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Basic applications for the KDE system
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
jpeg.11:${PORTSDIR}/graphics/jpeg \
exiv2.12:${PORTSDIR}/graphics/exiv2 \
xine.2:${PORTSDIR}/multimedia/libxine \
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index d451e5d5fe88..6cb825475adb 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -17,7 +17,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Base set of libraries needed by KDE programs
-LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
aspell.16:${PORTSDIR}/textproc/aspell \
jasper.4:${PORTSDIR}/graphics/jasper \
pcre.3:${PORTSDIR}/devel/pcre \