aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--palm/plucker/Makefile1
-rw-r--r--palm/plucker/files/patch-parser::python::PyPlucker::Writer.py20
2 files changed, 21 insertions, 0 deletions
diff --git a/palm/plucker/Makefile b/palm/plucker/Makefile
index c5e1133239dc..321a91d18d03 100644
--- a/palm/plucker/Makefile
+++ b/palm/plucker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= plucker
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= palm www
MASTER_SITES= http://downloads.plkr.org/1.2/
DISTNAME= ${PORTNAME}_bin-${PORTVERSION}
diff --git a/palm/plucker/files/patch-parser::python::PyPlucker::Writer.py b/palm/plucker/files/patch-parser::python::PyPlucker::Writer.py
new file mode 100644
index 000000000000..e45ab1e541aa
--- /dev/null
+++ b/palm/plucker/files/patch-parser::python::PyPlucker::Writer.py
@@ -0,0 +1,20 @@
+--- parser/python/PyPlucker/Writer.py.bak Tue Oct 15 14:47:39 2002
++++ parser/python/PyPlucker/Writer.py Fri Jan 31 15:18:09 2003
+@@ -81,7 +81,7 @@
+ self._current_id = 11
+
+ # make sure record number 2 goes to the 'home' document (why?)
+- url = self._alias_list.get('plucker:/home.html')
++ url = self._alias_list.get('plucker:///home.html')
+ if url:
+ while self._alias_list.has_key(url):
+ url = self._alias_list.get(url)
+@@ -91,7 +91,7 @@
+ else:
+ self._url_to_id_mapping[url] = 2
+ else:
+- doc = self._url_to_doc_mapping.get('plucker:/home.html')
++ doc = self._url_to_doc_mapping.get('plucker:///home.html')
+ if doc:
+ self._doc_to_id_mapping[doc] = 2
+ else:
fe05aaa850def1fcb987abccbb3e58403ad9257'>- login(3), logout(3), and logwtmp(3) were removed in base r202216bdrewery2013-09-031-3/+0 * Do not cache the openpty function this breaks at least heimdal and rancidbapt2013-09-021-1/+2 * Remove 2 lines for structs which were declared in utmp.hantoine2013-08-311-2/+0 * Remove the utmp.h cache added by mistakebapt2013-08-301-1/+0 * - Cache morebdrewery2013-08-301-1/+5 * Note that this must reflect the oldest supported releasebdrewery2013-08-301-0/+1 * Cache more GNU configure tests, obtained from gettext and openssh configure s...bapt2013-08-301-32/+589 * Add some guidance on what not to addbdrewery2013-08-301-0/+9 * Add a few more headers/functionsbdrewery2013-08-301-0/+25 * Sort pathsbdrewery2013-08-301-6/+6 * Sort each groupbdrewery2013-08-301-184/+174 * Cache more functionsbapt2013-08-241-0/+4 * Cache strlcpy and strlcat testsbapt2013-08-241-0/+2 * Remove unwanted changesbapt2013-06-051-1/+1 * Propertly makes config.sub working as expecting on amd64bapt2013-06-051-8/+2 * Actually commit the right config.subbapt2013-06-051-0/+6 * Update to lastest version from upstreambapt2013-06-042-595/+1013 * Eliminate redundancy in this file which also helps avoids typos.bdrewery2013-05-311-372/+372 * Fix typosbdrewery2013-05-311-2/+2 * Revert as it brings too many breakage, it needs more work before getting syncbapt2013-05-242-1021/+592 * Cache more autotools testsbapt2013-05-241-3/+179 * Sync with latest version from upstreambapt2013-05-242-592/+1021 * All supported FreeBSD have net/if.h and net/if_media.h cache them in config.s...bapt2013-04-301-0/+2 * waitid(2) is only in 10bdrewery2013-04-251-1/+2 * Add a global config.site cache.bapt2013-04-231-0/+215 * Add in many popular licenses used by the ports infrastructure. Thesetabthorpe2012-02-2814-0/+3684 * - Include etc/devd in mtree, as referenced in devd.conf(5)pav2010-11-131-1/+3