aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/pear/bsd.pear.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/pear/bsd.pear.mk b/devel/pear/bsd.pear.mk
index 1679dc0eadbd..2afd1a151dcf 100644
--- a/devel/pear/bsd.pear.mk
+++ b/devel/pear/bsd.pear.mk
@@ -194,7 +194,11 @@ do-autogenerate-plist: patch
| ${CUT} -c 3- >> ${PLIST}
@DIRS=`cd ${WRKDIR}/inst/${PREFIX} && ${FIND} . -type d | ${SORT} -r | \
${CUT} -c 3- | ${SED} -e 's,\\$$,\\\\$$,g'`; \
- for d in $${DIRS}; do ${ECHO_CMD} "@dirrmtry $${d}" >> ${PLIST}; done
+ for d in $${DIRS}; do \
+ if [ ! -d ${LOCALBASE}/$${d} ]; then \
+ ${ECHO_CMD} "@dirrmtry $${d}" >> ${PLIST}; \
+ fi; \
+ done
@${ECHO_CMD} "@dirrm ${LPKGREGDIR}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry ${LPKGREGDIR:H}" >> ${PLIST}