aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/fontforge/Makefile7
-rw-r--r--print/fontforge/distinfo8
-rw-r--r--print/fontforge/files/patch-Makefile.dynamic.in20
-rw-r--r--print/fontforge/files/patch-fontforge::Makefile.dynamic.in2
-rw-r--r--print/fontforge/files/patch-fontforge::configure-pfaedit.h17
-rw-r--r--print/fontforge/pkg-plist41
6 files changed, 65 insertions, 30 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index 8616eecbf55b..6ee4057cbf9b 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fontforge
-PORTVERSION= 20041014
+PORTVERSION= 20050117
PORTREVISION= 0
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -31,8 +31,11 @@ USE_GMAKE= yes
USE_XLIB= yes
USE_ICONV= yes
PATCH_STRIP= -l
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if !defined(FONTFORGE_NO_MULTILAYER)
-CONFIGURE_ARGS= --with-multilayer
+CONFIGURE_ARGS= --with-multilayer --with-devicetables --without-freetype-src
+.else
+CONFIGURE_ARGS= --with-devicetables --without-freetype-src
.endif
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CFLAGS="${CFLAGS} \
-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
diff --git a/print/fontforge/distinfo b/print/fontforge/distinfo
index 3f655ffd93d6..a6e60cdd0b49 100644
--- a/print/fontforge/distinfo
+++ b/print/fontforge/distinfo
@@ -1,4 +1,4 @@
-MD5 (fontforge_full-20041014.tgz) = 1fb3aeaa094a7eab4a6752bf373cf20a
-SIZE (fontforge_full-20041014.tgz) = 4288784
-MD5 (fontforge_htdocs-20041014.tgz) = 9280c06218d14054054b226f82873c66
-SIZE (fontforge_htdocs-20041014.tgz) = 2046008
+MD5 (fontforge_full-20050117.tgz) = eb1b17de78b8a211a60f08a3e2a7a548
+SIZE (fontforge_full-20050117.tgz) = 4369023
+MD5 (fontforge_htdocs-20050117.tgz) = 0c4c17ba0389654707322888577f4434
+SIZE (fontforge_htdocs-20050117.tgz) = 2098773
diff --git a/print/fontforge/files/patch-Makefile.dynamic.in b/print/fontforge/files/patch-Makefile.dynamic.in
index 9c8aca62eab7..cbccc523d80c 100644
--- a/print/fontforge/files/patch-Makefile.dynamic.in
+++ b/print/fontforge/files/patch-Makefile.dynamic.in
@@ -1,15 +1,27 @@
---- Makefile.dynamic.in.orig Wed Mar 3 04:23:46 2004
-+++ Makefile.dynamic.in Tue Apr 20 00:17:10 2004
-@@ -53,15 +53,16 @@
+--- Makefile.dynamic.in.orig Sun Jan 2 00:07:09 2005
++++ Makefile.dynamic.in Thu Jan 20 17:27:18 2005
+@@ -47,25 +47,26 @@
+ $(LIBTOOL) $(INSTALL) -c libgunicode.la $(libdir)/libgunicode.la
+ #cp .libs/*.so.*.* $(libdir)
+ $(LIBTOOL) --finish $(libdir)
+- mkdir -p $(libdir)/pkgconfig
+- $(LIBTOOL) $(INSTALL) -c fontforge.pc $(libdir)/pkgconfig
++ mkdir -p ${PREFIX}/libdata/pkgconfig
++ ${BSD_INSTALL_DATA} -c fontforge.pc ${PREFIX}/libdata/pkgconfig
+
+ install: $(sharedir) all install_libs
+ # You may need to be root to do the install
mkdir -p $(bindir)
mkdir -p $(mandir)/man1
mkdir -p $(sharedir)
- $(LIBTOOL) $(INSTALL) -c fontforge/fontforge $(bindir)
- $(LIBTOOL) $(INSTALL) -c fontforge/sfddiff $(bindir)
-- cp fontforge/pfaedit-*.ui $(sharedir)
+ ${BSD_INSTALL_PROGRAM} -c fontforge/.libs/fontforge $(bindir)
+ ${BSD_INSTALL_PROGRAM} -c fontforge/.libs/sfddiff $(bindir)
+ ${BSD_INSTALL_PROGRAM} -c fontforge/.libs/acorn2sfd $(bindir)
+ # -rm -f $(bindir)/pfaedit
+ # (cd $(bindir) ; ln -s fontforge pfaedit)
+- cp fontforge/pfaedit-*.ui $(sharedir)
+ ${BSD_INSTALL_DATA} fontforge/pfaedit-*.ui $(sharedir)
#The next line will fail for most installs. If you have downloaded the cidmaps
# this will install them. If you haven't it won't. You only need the cidmaps
diff --git a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
index bde67c94725c..65b567407fab 100644
--- a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
+++ b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
@@ -5,7 +5,7 @@
ACORNOBJS = acorn2sfd.o sfd.o diffstubs.o psunicodenames.o stamp.o
-_CFLAGS = -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
-+_CFLAGS = -I$(LOCALBASE)/include -I$(LOCALBASE)/include/freetype2 -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
++_CFLAGS = -I$(LOCALBASE)/include -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
@DEFS@ '-DSHAREDIR="$(sharedir)"' -DLIBDIR='"$(libdir)"'
CFLAGS = @CFLAGS@ $(_CFLAGS)
diff --git a/print/fontforge/files/patch-fontforge::configure-pfaedit.h b/print/fontforge/files/patch-fontforge::configure-pfaedit.h
index 29c7d0562b25..4b0099afb969 100644
--- a/print/fontforge/files/patch-fontforge::configure-pfaedit.h
+++ b/print/fontforge/files/patch-fontforge::configure-pfaedit.h
@@ -1,6 +1,15 @@
---- fontforge/configure-pfaedit.h.orig Tue May 13 03:20:08 2003
-+++ fontforge/configure-pfaedit.h Tue May 13 10:24:58 2003
-@@ -31,7 +31,7 @@
+--- fontforge/configure-pfaedit.h.orig Sat Jan 8 11:11:45 2005
++++ fontforge/configure-pfaedit.h Thu Jan 20 16:53:29 2005
+@@ -73,7 +73,7 @@
+ /* Sometimes I want to create a glyph which is a word, and this command */
+ /* makes that easy */
+ /* */
+-/* #define FONTFORGE_CONFIG_PASTEAFTER */
++#define FONTFORGE_CONFIG_PASTEAFTER
+ /* */
+ /* The paste after command pastes the contents of the clipboard into the */
+ /* current glyph, translates that by the advance width of the current glyph */
+@@ -84,7 +84,7 @@
/* don't include code for it by default, but if you do want it simply define */
/* the following macro */
/* */
@@ -9,7 +18,7 @@
/* */
/* The tile path command uses the contents of the clipboard as a tile which is*/
/* applied to any selected paths, replacing them. It could be used to make a */
-@@ -42,7 +42,7 @@
+@@ -190,7 +190,7 @@
/* routine. I'm not sure that it's very useful though. It can be used to do */
/* perspective transformations and such */
/* */
diff --git a/print/fontforge/pkg-plist b/print/fontforge/pkg-plist
index 7bd4602105aa..95e8c1c9abd8 100644
--- a/print/fontforge/pkg-plist
+++ b/print/fontforge/pkg-plist
@@ -9,6 +9,7 @@ lib/libgunicode.a
lib/libgunicode.la
lib/libgunicode.so
lib/libgunicode.so.2
+libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/AA-Comparison.html
%%PORTDOCS%%%%DOCSDIR%%/AmbrosiaFV-bm.png
%%PORTDOCS%%%%DOCSDIR%%/AmbrosiaFV.png
@@ -105,6 +106,7 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/Sxiti3.png
%%PORTDOCS%%%%DOCSDIR%%/TTCvt.png
%%PORTDOCS%%%%DOCSDIR%%/TTPoints.png
+%%PORTDOCS%%%%DOCSDIR%%/TTRaster.png
%%PORTDOCS%%%%DOCSDIR%%/TTRegisters.png
%%PORTDOCS%%%%DOCSDIR%%/TTStack.png
%%PORTDOCS%%%%DOCSDIR%%/TTStorage.png
@@ -124,6 +126,9 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/agetinfo.png
%%PORTDOCS%%%%DOCSDIR%%/agrave_anchored.png
%%PORTDOCS%%%%DOCSDIR%%/ahighest.png
+%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol-base.png
+%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol-mark.png
+%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol.html
%%PORTDOCS%%%%DOCSDIR%%/autokern.png
%%PORTDOCS%%%%DOCSDIR%%/autotrace.html
%%PORTDOCS%%%%DOCSDIR%%/autowidth.html
@@ -255,6 +260,7 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-panose.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-private.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-ps.png
+%%PORTDOCS%%%%DOCSDIR%%/fontinfo-size.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-statemach.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-tex.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-ttfname.png
@@ -300,9 +306,12 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/k6.png
%%PORTDOCS%%%%DOCSDIR%%/kanjichar.png
%%PORTDOCS%%%%DOCSDIR%%/kanjifont.png
+%%PORTDOCS%%%%DOCSDIR%%/kern-We-12.png
+%%PORTDOCS%%%%DOCSDIR%%/kern-We-150.png
%%PORTDOCS%%%%DOCSDIR%%/kernbyclasses.png
%%PORTDOCS%%%%DOCSDIR%%/kerningclass.png
%%PORTDOCS%%%%DOCSDIR%%/kerningclass-kern.png
+%%PORTDOCS%%%%DOCSDIR%%/kernpairclose.png
%%PORTDOCS%%%%DOCSDIR%%/kernpairs.html
%%PORTDOCS%%%%DOCSDIR%%/l1.png
%%PORTDOCS%%%%DOCSDIR%%/l10.png
@@ -350,6 +359,7 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/newfont.png
%%PORTDOCS%%%%DOCSDIR%%/non-linear.png
%%PORTDOCS%%%%DOCSDIR%%/non-standard.html
+%%PORTDOCS%%%%DOCSDIR%%/nvd.html
%%PORTDOCS%%%%DOCSDIR%%/o-baddir.png
%%PORTDOCS%%%%DOCSDIR%%/o1.png
%%PORTDOCS%%%%DOCSDIR%%/o2.png
@@ -387,6 +397,7 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/problems.html
%%PORTDOCS%%%%DOCSDIR%%/quadbezier.gif
%%PORTDOCS%%%%DOCSDIR%%/quadbezier.png
+%%PORTDOCS%%%%DOCSDIR%%/quadraticspline.gif
%%PORTDOCS%%%%DOCSDIR%%/quadraticspline.png
%%PORTDOCS%%%%DOCSDIR%%/quotations.html
%%PORTDOCS%%%%DOCSDIR%%/realindex.html
@@ -457,19 +468,19 @@ lib/libgunicode.so.2
%%PORTDOCS%%%%DOCSDIR%%/xim.html
%%PORTDOCS%%%%DOCSDIR%%/xres.html
%%DOCSDIR%%/LICENSE
-share/fontforge/Adobe-CNS1-4.cidmap
-share/fontforge/Adobe-GB1-4.cidmap
-share/fontforge/Adobe-Identity-0.cidmap
-share/fontforge/Adobe-Japan1-5.cidmap
-share/fontforge/Adobe-Japan2-0.cidmap
-share/fontforge/Adobe-Korea1-2.cidmap
-share/fontforge/pfaedit-de.ui
-share/fontforge/pfaedit-en.ui
-share/fontforge/pfaedit-es.ui
-share/fontforge/pfaedit-fr.ui
-share/fontforge/pfaedit-gr.ui
-share/fontforge/pfaedit-it.ui
-share/fontforge/pfaedit-ja.ui
-share/fontforge/pfaedit-ru.ui
-@dirrm share/fontforge
+%%DATADIR%%/Adobe-CNS1-4.cidmap
+%%DATADIR%%/Adobe-GB1-4.cidmap
+%%DATADIR%%/Adobe-Identity-0.cidmap
+%%DATADIR%%/Adobe-Japan1-6.cidmap
+%%DATADIR%%/Adobe-Japan2-0.cidmap
+%%DATADIR%%/Adobe-Korea1-2.cidmap
+%%DATADIR%%/pfaedit-de.ui
+%%DATADIR%%/pfaedit-en.ui
+%%DATADIR%%/pfaedit-es.ui
+%%DATADIR%%/pfaedit-fr.ui
+%%DATADIR%%/pfaedit-gr.ui
+%%DATADIR%%/pfaedit-it.ui
+%%DATADIR%%/pfaedit-ja.ui
+%%DATADIR%%/pfaedit-ru.ui
+@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%