aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/pike70/scripts/configure.pike2
-rw-r--r--mail/postfix1/scripts/configure.postfix5
-rw-r--r--net-mgmt/netsaint-plugins/scripts/configure3
3 files changed, 4 insertions, 6 deletions
diff --git a/lang/pike70/scripts/configure.pike b/lang/pike70/scripts/configure.pike
index e72e2c0acdfd..f11a223448b4 100644
--- a/lang/pike70/scripts/configure.pike
+++ b/lang/pike70/scripts/configure.pike
@@ -80,7 +80,7 @@ while [ "$1" ]; do
MySQL=1
;;
\"PostgreSQL\")
- echo 'BUILD_DEPENDS+= ${PREFIX}/pgsql/bin/psql:${PORTSDIR}/databases/postgresql7' >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo 'USE_PGSQL= yes' >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
echo 'CONFIGURE_ARGS+= --with-pgsql=${PREFIX}/pgsql' >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
PostgresSQL=1
;;
diff --git a/mail/postfix1/scripts/configure.postfix b/mail/postfix1/scripts/configure.postfix
index a4df9aca1a88..6aa0216b011c 100644
--- a/mail/postfix1/scripts/configure.postfix
+++ b/mail/postfix1/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.38 2003-07-31 12:19:53 nectar Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.39 2005-05-31 08:11:30 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -109,8 +109,7 @@ for i; do
echo "MYSQL_SUFFIX= +mysql"
;;
PgSQL)
- echo "POSTGRESQL_PORT?= databases/postgresql7"
- echo "LIB_DEPENDS+= pq.3:\${PORTSDIR}/\${POSTGRESQL_PORT}"
+ echo "USE_PGSQL= yes"
echo "POSTFIX_CCARGS+= -DHAS_PGSQL -I\${LOCALBASE}/include -I\${LOCALBASE}/pgsql/include"
echo "POSTFIX_AUXLIBS+= -L\${LOCALBASE}/lib -L\${LOCALBASE}/pgsql/lib -lpq -lcrypt"
echo "PGSQL_SUFFIX= +pgsql"
diff --git a/net-mgmt/netsaint-plugins/scripts/configure b/net-mgmt/netsaint-plugins/scripts/configure
index bee638c827ac..e8acc1e40af9 100644
--- a/net-mgmt/netsaint-plugins/scripts/configure
+++ b/net-mgmt/netsaint-plugins/scripts/configure
@@ -81,8 +81,7 @@ while [ "$1" ]; do
SUB_MYSQL=""
;;
\"PostgreSQL\")
- echo "POSTGRESQL_PORT?= databases/postgresql7"
- echo "LIB_DEPENDS+= pq.3:\${PORTSDIR}/\${POSTGRESQL_PORT}"
+ echo "USE_PGSQL= yes"
echo "CONFIGURE_ARGS+= --with-pgsql=\${LOCALBASE}"
SUB_PGSQL=""
;;