aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/atr3d/Makefile2
-rw-r--r--games/atr3d/files/patch-Makefile.am14
2 files changed, 15 insertions, 1 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 0d107f21bd88..6a3e14271e11 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-sound
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${SDL_CONFIG}"
-USE_AUTOTOOLS= automake:14 autoconf:213
+USE_AUTOTOOLS= automake:19 autoconf:259
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
diff --git a/games/atr3d/files/patch-Makefile.am b/games/atr3d/files/patch-Makefile.am
new file mode 100644
index 000000000000..00e07b2a97c6
--- /dev/null
+++ b/games/atr3d/files/patch-Makefile.am
@@ -0,0 +1,14 @@
+--- Makefile.am.orig Wed Mar 14 18:18:08 2007
++++ Makefile.am Wed Mar 14 18:18:45 2007
+@@ -24,9 +24,9 @@
+ endif
+
+ INCLUDES = -I/usr/local/include -I.
+-LDFLAGS = -L/usr/local/lib $(LIBDIRS)
++AM_LDFLAGS = -L/usr/local/lib $(LIBDIRS)
+ LDADD = $(SLIBS) $(MYLIBS)
+-CXXFLAGS = -DDATADIR="\"$(datadir)\"" $(SCXXFLAGS) $(CCXXFLAGS) $(DCXXFLAGS)
++AM_CXXFLAGS = -DDATADIR="\"$(datadir)\"" $(SCXXFLAGS) $(CCXXFLAGS) $(DCXXFLAGS)
+
+ bin_PROGRAMS = atr3d
+ atr3d_SOURCES = asteroid.cpp blit.cpp config.cpp fileutils.cpp game.cpp \