aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/firefox-devel/Makefile4
-rw-r--r--www/firefox-devel/files/mozconfig.in4
-rw-r--r--www/firefox-esr/Makefile4
-rw-r--r--www/firefox-esr/files/mozconfig.in4
-rw-r--r--www/firefox/Makefile4
-rw-r--r--www/firefox/files/mozconfig.in4
-rw-r--r--www/firefox10/Makefile4
-rw-r--r--www/firefox10/files/mozconfig.in4
-rw-r--r--www/firefox15/Makefile4
-rw-r--r--www/firefox15/files/mozconfig.in4
-rw-r--r--www/firefox3-devel/Makefile4
-rw-r--r--www/firefox3-devel/files/mozconfig.in4
-rw-r--r--www/firefox35/Makefile4
-rw-r--r--www/firefox35/files/mozconfig.in4
-rw-r--r--www/firefox36/Makefile4
-rw-r--r--www/firefox36/files/mozconfig.in4
-rw-r--r--www/flock/Makefile4
-rw-r--r--www/flock/files/mozconfig.in4
-rw-r--r--www/mozilla-firebird/Makefile4
-rw-r--r--www/mozilla-firebird/files/mozconfig.in4
-rw-r--r--www/phoenix-devel/Makefile4
-rw-r--r--www/phoenix-devel/files/mozconfig.in4
-rw-r--r--www/phoenix/Makefile4
-rw-r--r--www/phoenix/files/mozconfig.in4
24 files changed, 72 insertions, 24 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox-devel/files/mozconfig.in b/www/firefox-devel/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox-devel/files/mozconfig.in
+++ b/www/firefox-devel/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox-esr/files/mozconfig.in b/www/firefox-esr/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox-esr/files/mozconfig.in
+++ b/www/firefox-esr/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox/files/mozconfig.in b/www/firefox/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox/files/mozconfig.in
+++ b/www/firefox/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox10/files/mozconfig.in b/www/firefox10/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox10/files/mozconfig.in
+++ b/www/firefox10/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox15/files/mozconfig.in b/www/firefox15/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox15/files/mozconfig.in
+++ b/www/firefox15/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox3-devel/files/mozconfig.in b/www/firefox3-devel/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox3-devel/files/mozconfig.in
+++ b/www/firefox3-devel/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox35/files/mozconfig.in b/www/firefox35/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox35/files/mozconfig.in
+++ b/www/firefox35/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox36/files/mozconfig.in b/www/firefox36/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox36/files/mozconfig.in
+++ b/www/firefox36/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/flock/Makefile b/www/flock/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/flock/files/mozconfig.in b/www/flock/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/flock/files/mozconfig.in
+++ b/www/flock/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/mozilla-firebird/Makefile b/www/mozilla-firebird/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/mozilla-firebird/Makefile
+++ b/www/mozilla-firebird/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/mozilla-firebird/files/mozconfig.in b/www/mozilla-firebird/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/mozilla-firebird/files/mozconfig.in
+++ b/www/mozilla-firebird/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/phoenix-devel/Makefile b/www/phoenix-devel/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/phoenix-devel/Makefile
+++ b/www/phoenix-devel/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/phoenix-devel/files/mozconfig.in b/www/phoenix-devel/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/phoenix-devel/files/mozconfig.in
+++ b/www/phoenix-devel/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config
diff --git a/www/phoenix/Makefile b/www/phoenix/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/phoenix/Makefile
+++ b/www/phoenix/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/phoenix/files/mozconfig.in b/www/phoenix/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/phoenix/files/mozconfig.in
+++ b/www/phoenix/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config