aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/xcircuit/Makefile4
-rw-r--r--cad/xcircuit/distinfo4
-rw-r--r--cad/xcircuit/files/patch-Makefile.in2
3 files changed, 6 insertions, 4 deletions
diff --git a/cad/xcircuit/Makefile b/cad/xcircuit/Makefile
index 8d10c1684ee5..3fac852948dc 100644
--- a/cad/xcircuit/Makefile
+++ b/cad/xcircuit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xcircuit
-PORTVERSION= 3.7.33
+PORTVERSION= 3.7.39
PORTEPOCH= 1
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/xcircuit/archive/ \
@@ -32,6 +32,8 @@ CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
AUTOMAKE="${TRUE}"
MAKE_JOBS_SAFE= yes
+DESKTOP_ENTRIES="Xcircuit" "${COMMENT}" "${DATADIR}/pixmaps/xcircuit.gif" \
+ "${PORTNAME}" "" "false"
CFLAGS+= -fPIC
diff --git a/cad/xcircuit/distinfo b/cad/xcircuit/distinfo
index 03741504da6b..9f8b019a40fb 100644
--- a/cad/xcircuit/distinfo
+++ b/cad/xcircuit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xcircuit-3.7.33.tgz) = 49c413c2c2e27f2c61d03e761d4b91ad37416d31f3ca61af6caec48f9cb44fce
-SIZE (xcircuit-3.7.33.tgz) = 1504027
+SHA256 (xcircuit-3.7.39.tgz) = e351dfe0ab8f55b78e4db41ade03b8f27059d01d620d44b6353ad223d84e1af3
+SIZE (xcircuit-3.7.39.tgz) = 1507600
diff --git a/cad/xcircuit/files/patch-Makefile.in b/cad/xcircuit/files/patch-Makefile.in
index e299eb754b2d..874222c517bb 100644
--- a/cad/xcircuit/files/patch-Makefile.in
+++ b/cad/xcircuit/files/patch-Makefile.in
@@ -28,6 +28,6 @@
${xcircuit_OBJECTS} ${xcircuit_LDADD} ${SHLIB_LIB_SPECS} \
- ${LDFLAGS} ${X_EXTRA_LIBS} ${EXTRA_LIBS} -lc ${LIBS} \
+ ${LDFLAGS} ${X_EXTRA_LIBS} ${EXTRA_LIBS} ${LIBS} \
- ${EXTRA_LIB_SPECS}
+ ${LIB_SPECS} ${EXTRA_LIB_SPECS}
xcircexec$(EXEEXT): xcircexec.o