aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/opera/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 37d37fd9cf5c..6ad180137869 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opera
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.scarlet.be/pub/opera/unix/freebsd/${OPERA_VER:S/.//}/${OPERA_REL}/en/static/ \
ftp://ftp.planetmirror.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}/${OPERA_REL}/en/static/ \
@@ -44,6 +45,10 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
NO_FILTER_SHLIBS=yes
+.ifndef(WITHOUT_ASPELL)
+LIB_DEPENDS+= aspell.15:${PORTSDIR}/textproc/aspell
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
@@ -62,6 +67,13 @@ PLIST_SUB+= KDE=""
PLIST_SUB+= KDE="@comment "
.endif
+pre-everything::
+.if !defined(WITHOUT_ASPELL)
+ @${ECHO_CMD} '===> The following options are available for this port:'
+ @${ECHO_CMD} '===>'
+ @${ECHO_CMD} '===> Define WITHOUT_ASPELL to not install aspell.'
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \