aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/Makefile1
-rw-r--r--irc/iroffer-lamm/Makefile37
-rw-r--r--irc/iroffer-lamm/distinfo3
-rw-r--r--irc/iroffer-lamm/pkg-descr8
-rw-r--r--irc/iroffer-lamm/pkg-message21
-rw-r--r--irc/iroffer-lamm/pkg-plist9
6 files changed, 79 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 6ad2b9fb8ce7..effe2f8d3215 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -51,6 +51,7 @@
SUBDIR += ircproxy
SUBDIR += ircservices
SUBDIR += iroffer
+ SUBDIR += iroffer-lamm
SUBDIR += irssi
SUBDIR += irssi-dcc_send_limiter
SUBDIR += irssi-devel
diff --git a/irc/iroffer-lamm/Makefile b/irc/iroffer-lamm/Makefile
new file mode 100644
index 000000000000..008269c256f1
--- /dev/null
+++ b/irc/iroffer-lamm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: iroffer-lamm
+# Date created: 10 Apr 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= iroffer
+PORTVERSION= 1.4.3.1
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= iroffer-lamm
+PKGNAMESUFFIX= -lamm${PKGNAMESUFFIX2}
+DISTNAME= iroffer1.4.b03-lamm.b01
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.ORG
+COMMENT= An IRC "bot" that makes sharing files via DCC extremely easy
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= Configure
+CONFLICTS= iroffer-1.*
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/convertxdccfile ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/WHATSNEW ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/dynip.sh ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/iroffer.cron ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/sample.config ${EXAMPLESDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/irc/iroffer-lamm/distinfo b/irc/iroffer-lamm/distinfo
new file mode 100644
index 000000000000..fe2441f55f22
--- /dev/null
+++ b/irc/iroffer-lamm/distinfo
@@ -0,0 +1,3 @@
+MD5 (iroffer1.4.b03-lamm.b01.tgz) = f06f4a45b522dbec8bcbd54aa55c59c6
+SHA256 (iroffer1.4.b03-lamm.b01.tgz) = b2bcb84eea66032cdc1520f8b61dcc75b647ed1854f8c431a0635a9c39d6ac82
+SIZE (iroffer1.4.b03-lamm.b01.tgz) = 154554
diff --git a/irc/iroffer-lamm/pkg-descr b/irc/iroffer-lamm/pkg-descr
new file mode 100644
index 000000000000..1f00a3644ba5
--- /dev/null
+++ b/irc/iroffer-lamm/pkg-descr
@@ -0,0 +1,8 @@
+iroffer is a fileserver for irc (commonly referred to as a DCC bot). It
+uses the DCC feature of irc to send files to other users. iroffer will
+connect to an irc server and let people request files from it.
+
+This is a fork of Iroffer with extended features.
+It does support mIRC-style DCC Server Protocol.
+
+WWW: http://iroffer-lamm.sourceforge.net/
diff --git a/irc/iroffer-lamm/pkg-message b/irc/iroffer-lamm/pkg-message
new file mode 100644
index 000000000000..827c9c101b63
--- /dev/null
+++ b/irc/iroffer-lamm/pkg-message
@@ -0,0 +1,21 @@
+=========================================================================
+
+Sample configuration and crontab files have been placed in
+${PREFIX}/share/examples/iroffer.
+
+These should be copied to a location of your own choosing, and edited to
+suit your needs.
+
+To run iroffer, just run:
+
+iroffer <name of config file>
+
+You may also set up iroffer to be run automatically from crontab.
+See the file ${PREFIX}/share/examples/iroffer/iroffer.cron for a sample.
+
+For more details on how to use the program see the comments in
+${PREFIX}/share/examples/iroffer/sample.config, as well as the README
+files ${PREFIX}/share/doc/iroffer/README and
+${PREFIX}/share/doc/iroffer/WHATSNEW.
+
+=========================================================================
diff --git a/irc/iroffer-lamm/pkg-plist b/irc/iroffer-lamm/pkg-plist
new file mode 100644
index 000000000000..9b490539f87b
--- /dev/null
+++ b/irc/iroffer-lamm/pkg-plist
@@ -0,0 +1,9 @@
+bin/convertxdccfile
+bin/iroffer
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/WHATSNEW
+%%PORTDOCS%%%%EXAMPLESDIR%%/dynip.sh
+%%PORTDOCS%%%%EXAMPLESDIR%%/iroffer.cron
+%%PORTDOCS%%%%EXAMPLESDIR%%/sample.config
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%