aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/msieve/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 20e216a6212e..3859b5566ed5 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -55,6 +55,12 @@ ALLTGT= x86_64
.endif
ALL_TARGET= ${ALLTGT}${ALLTGT_SUFX}
+.if ${OSVERSION} >= 700042
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile with GCC 4.2
+.endif
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/msieve ${PREFIX}/bin
${MKDIR} ${PREFIX}/include/msieve