aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/psi/Makefile32
-rw-r--r--net-im/psi/distinfo4
-rw-r--r--net-im/psi/files/patch-configure39
3 files changed, 47 insertions, 28 deletions
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index 4b67ae4d28f2..d9a6d42927c2 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: psi
-# Date created: Wed May 1 20:27:23 NZST 2002
-# Whom: jonc@chen.org.nz
-#
+# Created by: Jonathan Chen <jonc@chen.org.nz>
# $FreeBSD$
-#
PORTNAME= psi
-PORTVERSION= 0.14
-PORTREVISION= 3
+PORTVERSION= 0.15
CATEGORIES= net-im
MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
@@ -19,19 +14,20 @@ RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl \
qca-gnupg>=2.0.0.b3:${PORTSDIR}/security/qca-gnupg
HAS_CONFIGURE= yes
+QT_NONSTANDARD= yes
USE_BZIP2= yes
-USE_QT4= corelib dbus gui iconengines imageformats qt3support \
- inputmethods network script svg xml \
+USE_PKGCONFIG= build
+USE_QT4= gui network xml imageformats_run \
qmake_build moc_build rcc_build uic_build
+USE_XORG= xscrnsaver
CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${LOCALBASE} \
- --disable-growl --disable-bundled-qca \
- --verbose
+ --disable-growl --verbose
+CONFIGURE_ENV= QMAKEFLAGS='${QMAKEFLAGS}'
+MAKE_JOBS_SAFE= yes
-MAKE_JOBS_UNSAFE= yes
-
-OPTIONS_DEFINE= ASPELL ENCHANT
-OPTIONS_DEFAULT= ASPELL
+OPTIONS_DEFINE= ASPELL ENCHANT DBUS
+OPTIONS_DEFAULT= ASPELL DBUS
ASPELL_DESC= Use aspell for spell checking
ENCHANT_DESC= Use Enchant for spell checking
@@ -46,6 +42,12 @@ CONFIGURE_ARGS+= --release --no-separate-debug-info
PLIST_SUB+= DEBUG="@comment "
.endif
+.if ${PORT_OPTIONS:MDBUS}
+USE_QT4+= dbus
+.else
+CONFIGURE_ARGS+= --disable-qdbus
+.endif
+
.if ${PORT_OPTIONS:MASPELL}
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-aspell-inc=${LOCALBASE}/include \
diff --git a/net-im/psi/distinfo b/net-im/psi/distinfo
index 28dd670bedeb..ba318c1c2f1d 100644
--- a/net-im/psi/distinfo
+++ b/net-im/psi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (psi-0.14.tar.bz2) = aa014a20d59beb23ce2e853fac3d1d70b4b029591627ae0f0a6a3b9f7150a4c0
-SIZE (psi-0.14.tar.bz2) = 2168801
+SHA256 (psi-0.15.tar.bz2) = 593b5ddd7934af69c245afb0e7290047fd7dedcfd8765baca5a3a024c569c7e6
+SIZE (psi-0.15.tar.bz2) = 1984777
diff --git a/net-im/psi/files/patch-configure b/net-im/psi/files/patch-configure
index 95866a3106f5..0d3374b6ced3 100644
--- a/net-im/psi/files/patch-configure
+++ b/net-im/psi/files/patch-configure
@@ -1,11 +1,28 @@
---- configure.orig Sun Jan 8 05:19:01 2006
-+++ configure Sat Feb 4 14:06:18 2006
-@@ -192,6 +192,8 @@
- shift
- ;;
- --help) show_usage; exit ;;
-+ --with-*)
-+ shift ;;
- *) show_usage; exit ;;
- esac
- done
+--- ./configure.orig 2012-10-04 00:53:03.000000000 +0000
++++ ./configure 2012-10-06 22:30:21.900714143 +0000
+@@ -100,7 +100,7 @@
+ # find a make command
+ if [ -z "$MAKE" ]; then
+ MAKE=
+- for mk in gmake make; do
++ for mk in make gmake; do
+ if $WHICH $mk >/dev/null 2>&1; then
+ MAKE=`$WHICH $mk`
+ break
+@@ -2186,7 +2186,7 @@
+ QDir::setCurrent(dir.path());
+
+ bool ok = false;
+- int r = doCommand(qmake_path, QStringList() << "atest.pro");
++ int r = doCommand(qmake_path, QStringList() << qc_getenv("QMAKEFLAGS") << "atest.pro");
+ if(r == 0)
+ {
+ r = doCommand(maketool, QStringList());
+@@ -2587,6 +2587,7 @@
+ args += "-spec";
+ args += qmakespec;
+ }
++ args += qc_getenv("QMAKEFLAGS");
+ args += proPath;
+ int ret = qc_runprogram(qmake_path, args, 0, true);
+ if(ret != 0)
w44/cgit/freebsd-ports-gnome/commit/finance?h=dependabot/npm_and_yarn/devel/electron6/files/ini-1.3.8&id=e5a11dfcd752f83c8e388fa60254a4b4fe8b8387'>- chase textproc/opensp's libosp version upgradeitetcu2007-01-251-2/+2 * Drop maintainership.lawrance2007-01-231-1/+1 * - Update to 4.01miwi2007-01-113-47/+7 * Finance::Amortization is a simple object oriented interface to an amortizationmiwi2007-01-095-0/+44 * Update to 0.30.tobez2006-12-202-4/+4 * Update to 2.6.22, fixing multiple vulnerabilitieslth2006-12-193-5/+45 * Update the ftp/curl port to 7.16.0.roam2006-12-131-1/+2 * Update to 1.12arved2006-12-112-4/+4 * Remove expired ports:vd2006-12-044-52/+0 * Expense is a very lightweight application to track your expenses,dinoex2006-12-015-0/+63 * Update to 3.2.1.mezz2006-11-283-7/+5 * - Update to 3.08pav2006-11-253-40/+47 * - Chase recent libofx updaterafan2006-11-243-3/+3 * Update to 3.16erwin2006-11-233-5/+4 * - Fix pkg-plist ( http://pointyhat.freebsd.org/errorlogs/i386-errorlogs/e.7.2...miwi2006-11-061-6/+0 * - update to 0.11leeym2006-11-042-6/+5 * - Fix LIB_DEPENDS for g-wrapahze2006-10-191-1/+1 * - Chase g-wrap downgradeahze2006-10-181-2/+2 * Correct the slib-guile dependency, and fix installation.marcus2006-10-181-1/+1 * Chase the GNOME X11BASE to LOCALBASE move, and fix the build with themarcus2006-10-143-9/+32 * - Chase finance/libofx share library version bumprafan2006-10-092-3/+4