aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/py-gtk/Makefile2
-rw-r--r--x11-toolkits/py-gtk2/Makefile2
-rw-r--r--x11-toolkits/py-gtk2/pkg-install16
3 files changed, 4 insertions, 16 deletions
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index 543fe6fc1d7d..b37eaa9f8286 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -33,6 +33,8 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
+CONFLICTS= py*-gtk-2*
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${EG_DST_DIR}
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 3de788e93d5b..0a83317ecc33 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -28,6 +28,8 @@ USE_LIBTOOL= yes
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
+CONFLICTS= py*-gtk-0*
+
#
# Use the same way as the Python port to determine if we want
# threading support.
diff --git a/x11-toolkits/py-gtk2/pkg-install b/x11-toolkits/py-gtk2/pkg-install
deleted file mode 100644
index a26468bf3372..000000000000
--- a/x11-toolkits/py-gtk2/pkg-install
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-if [ -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-PATH=/bin:/usr/bin:/sbin:/usr/sbin:${PATH}
-export PATH
-
-if [ "$2" = "PRE-INSTALL" ]; then
- if pkg_info | grep "^py-gtk-[0-9]"; then
- echo "py-gtk for GTK+ 1.x was detected."
- echo "This packages cannot coexist with py-gtk."
- false
- fi
-fi