aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-divand/Makefile30
-rw-r--r--math/octave-forge-divand/distinfo2
-rw-r--r--math/octave-forge-divand/pkg-descr11
-rw-r--r--math/octave-forge-divand/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index ce7d1e85ea72..068e63c4300e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -291,6 +291,7 @@
SUBDIR += octave-forge-database
SUBDIR += octave-forge-dataframe
SUBDIR += octave-forge-dicom
+ SUBDIR += octave-forge-divand
SUBDIR += octave-forge-econometrics
SUBDIR += octave-forge-engine
SUBDIR += octave-forge-fenv
diff --git a/math/octave-forge-divand/Makefile b/math/octave-forge-divand/Makefile
new file mode 100644
index 000000000000..1343b1daa41d
--- /dev/null
+++ b/math/octave-forge-divand/Makefile
@@ -0,0 +1,30 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-divand
+PORTVERSION= 1.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv2
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/mapping.tar.gz:${PORTSDIR}/math/octave-forge-mapping
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-divand/distinfo b/math/octave-forge-divand/distinfo
new file mode 100644
index 000000000000..82bfac620649
--- /dev/null
+++ b/math/octave-forge-divand/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/divand-1.1.1.tar.gz) = 1496bb37e81aea708b697de53b07837ed1ebe2ddebb44aa52e1d37b200d5de21
+SIZE (octave-forge/divand-1.1.1.tar.gz) = 1227573
diff --git a/math/octave-forge-divand/pkg-descr b/math/octave-forge-divand/pkg-descr
new file mode 100644
index 000000000000..cc6e622cbd18
--- /dev/null
+++ b/math/octave-forge-divand/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is divand.
+
+ Divand performs an n-dimensional variational analysis (interpolation) of
+ arbitrarily located observations.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-divand/pkg-plist b/math/octave-forge-divand/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-divand/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty