aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/lam/Makefile10
-rw-r--r--net/lam/pkg-plist2
2 files changed, 9 insertions, 3 deletions
diff --git a/net/lam/Makefile b/net/lam/Makefile
index 407c44867873..5f361c8aacd6 100644
--- a/net/lam/Makefile
+++ b/net/lam/Makefile
@@ -378,12 +378,18 @@ BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
+.if ${PERL_LEVEL} == "500503"
+PLIST_SUB= WANT_MPIEXEC="@comment "
+.else
+PLIST_SUB= WANT_MPIEXEC=""
+.endif
+
.if ${ARCH} == "i386"
-PLIST_SUB= I386=""
+PLIST_SUB+= I386=""
.else
# Note: to enable TotalView on 64 bits platforms,
# --enable-tv-dll-force should be added to CONFIGURE_ARGS
-PLIST_SUB= I386="@comment "
+PLIST_SUB+= I386="@comment "
.endif
pre-configure:
diff --git a/net/lam/pkg-plist b/net/lam/pkg-plist
index 7d84f0cba06b..002ba6bbe0d4 100644
--- a/net/lam/pkg-plist
+++ b/net/lam/pkg-plist
@@ -18,7 +18,7 @@ bin/lamwipe
bin/mpiCC
bin/mpic++
bin/mpicc
-bin/mpiexec
+%%WANT_MPIEXEC%%bin/mpiexec
bin/mpif77
bin/mpimsg
bin/mpirun