aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/qemu-sbruno/Makefile12
-rw-r--r--emulators/qemu-sbruno/distinfo8
-rw-r--r--emulators/qemu-sbruno/files/qemu_user_static.in10
3 files changed, 18 insertions, 12 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index b49802cfd43d..2d6ee26e0bcc 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.4.50.g20151206
+PORTVERSION= 2.5.50.g20151224
CATEGORIES= emulators
MASTER_SITES= GH \
- LOCAL/nox \
LOCAL/nox:dtc \
- http://people.freebsd.org/~nox/tmp/distfiles/ \
http://people.freebsd.org/~nox/tmp/distfiles/:dtc
PKGNAMESUFFIX?= -sbruno
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -20,7 +18,7 @@ COMMENT?= QEMU CPU Emulator - github bsd-user branch
USE_GITHUB= yes
GH_ACCOUNT= seanbruno
GH_PROJECT= ${PORTNAME}-bsd-user
-GH_TAGNAME= 7397bda
+GH_TAGNAME= e4ece37
HAS_CONFIGURE= yes
USES= gmake pkgconfig bison perl5 python:2,build
USE_PERL5= build
@@ -61,7 +59,7 @@ SUB_LIST= NAME=qemu_user_static
CONFIGURE_ARGS+= --localstatedir=/var
CONFIGURE_ARGS+= --extra-ldflags=-L\"${LOCALBASE}/lib\"
-CONFIGURE_ARGS+= --disable-smartcard-nss --disable-libssh2
+CONFIGURE_ARGS+= --disable-libssh2
PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
.if defined(QEMU_USER_STATIC)
@@ -150,9 +148,7 @@ USES+= gettext
PLIST_SUB+= GTK2=""
.endif
-.if empty(PORT_OPTIONS:MGNUTLS)
-CONFIGURE_ARGS+= --disable-vnc-tls
-.else
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.endif
diff --git a/emulators/qemu-sbruno/distinfo b/emulators/qemu-sbruno/distinfo
index f385ac136394..cf590d45aecc 100644
--- a/emulators/qemu-sbruno/distinfo
+++ b/emulators/qemu-sbruno/distinfo
@@ -1,4 +1,4 @@
-SHA256 (qemu/2.4.50.g20151206/seanbruno-qemu-bsd-user-2.4.50.g20151206-7397bda_GH0.tar.gz) = 1f2bb1e9dfbdcbbc33fdc15ffbb7ed93bdc448b3157c3ed701890c7ecab1d31d
-SIZE (qemu/2.4.50.g20151206/seanbruno-qemu-bsd-user-2.4.50.g20151206-7397bda_GH0.tar.gz) = 11313452
-SHA256 (qemu/2.4.50.g20151206/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
-SIZE (qemu/2.4.50.g20151206/dtc-v1.4.0.tar.gz) = 131893
+SHA256 (qemu/2.5.50.g20151224/seanbruno-qemu-bsd-user-2.5.50.g20151224-e4ece37_GH0.tar.gz) = 437784294acf1393f236bf0cd6b3e22f1fbfb556db04dc21e88e0069c18f3c0c
+SIZE (qemu/2.5.50.g20151224/seanbruno-qemu-bsd-user-2.5.50.g20151224-e4ece37_GH0.tar.gz) = 11703182
+SHA256 (qemu/2.5.50.g20151224/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
+SIZE (qemu/2.5.50.g20151224/dtc-v1.4.0.tar.gz) = 131893
diff --git a/emulators/qemu-sbruno/files/qemu_user_static.in b/emulators/qemu-sbruno/files/qemu_user_static.in
index e86b57e712d8..4fe1949af7d7 100644
--- a/emulators/qemu-sbruno/files/qemu_user_static.in
+++ b/emulators/qemu-sbruno/files/qemu_user_static.in
@@ -34,6 +34,16 @@ list_cmd="${BINMISCCTL} list"
%%NAME%%_start()
{
+ # register arm interpreter styled 'arm'
+ interpreter=${QEMU_DIR}/${QEMU_PREFIX}arm${QEMU_SUFFIX}
+ if [ -x "${interpreter}" ]; then
+ ${BINMISCCTL} add arm --interpreter "${interpreter}" \
+ --magic "\x7f\x45\x4c\x46\x01\x01\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x28\x00" \
+ --mask "\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\xff\xff\xfe\xff\xff\xff" \
+ --size 20 --set-enabled
+ else
+ echo "$0: interpreter ${interpreter} not found, cannot register."
+ fi
# register armv6 interpreter styled 'arm'
interpreter=${QEMU_DIR}/${QEMU_PREFIX}arm${QEMU_SUFFIX}
if [ -x "${interpreter}" ]; then