aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/kdeplasma-addons/Makefile2
-rw-r--r--math/cantor/Makefile2
-rw-r--r--math/libqalculate/Makefile27
-rw-r--r--math/libqalculate/distinfo5
-rw-r--r--math/libqalculate/files/patch-libqalculate.pc.in13
-rw-r--r--math/libqalculate/files/patch-src-Makefile.in12
-rw-r--r--math/libqalculate/files/patch-src-qalc.cc11
-rw-r--r--math/libqalculate/pkg-descr2
-rw-r--r--math/libqalculate/pkg-plist4
-rw-r--r--math/qalculate/Makefile33
-rw-r--r--math/qalculate/distinfo5
-rw-r--r--math/qalculate/files/patch-src-Makefile11
-rw-r--r--math/qalculate/files/patch-src__callbacks.cc58
-rw-r--r--math/qalculate/pkg-descr2
-rw-r--r--math/qalculate/pkg-plist112
-rw-r--r--science/step/Makefile1
-rw-r--r--x11/kde4-workspace/Makefile2
17 files changed, 113 insertions, 189 deletions
diff --git a/deskutils/kdeplasma-addons/Makefile b/deskutils/kdeplasma-addons/Makefile
index b83b679dc0d5..778baa3f6658 100644
--- a/deskutils/kdeplasma-addons/Makefile
+++ b/deskutils/kdeplasma-addons/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kdeplasma-addons
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 487b5870e0ab..8212115ddea7 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index ebca830260ff..205e433d3034 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -2,35 +2,38 @@
# $FreeBSD$
PORTNAME= libqalculate
-PORTVERSION= 0.9.7
-PORTREVISION= 5
+PORTVERSION= 0.9.10
+DISTVERSIONPREFIX= v
CATEGORIES= math
-MASTER_SITES= SF/qalculate/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= jhale@FreeBSD.org
COMMENT= Multi-purpose desktop calculator (backend library)
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libcln.so:math/cln
-USES= pkgconfig pathfix gmake libtool gettext-tools
+USES= autoreconf gmake gettext libtool \
+ localbase pathfix pkgconfig readline:port
USE_GNOME= glib20 intltool libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+PATHFIX_MAKEFILEIN= Makefile.am
+
+USE_GITHUB= yes
+GH_ACCOUNT= Qalculate
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext-runtime
-
.include <bsd.port.options.mk>
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.am
+
post-patch:
-.if !${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|po ||g' ${WRKSRC}/Makefile.in
-.endif
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|docs||g' ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
index cf4cdfdb6358..07b73de5d346 100644
--- a/math/libqalculate/distinfo
+++ b/math/libqalculate/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libqalculate-0.9.7.tar.gz) = 9a6d97ce3339d104358294242c3ecd5e312446721e93499ff70acc1604607955
-SIZE (libqalculate-0.9.7.tar.gz) = 1256271
+TIMESTAMP = 1476486857
+SHA256 (Qalculate-libqalculate-v0.9.10_GH0.tar.gz) = f19f13c06c11f2e576d4c95b48c87417649f4ad598127e9759316b6e4b601f72
+SIZE (Qalculate-libqalculate-v0.9.10_GH0.tar.gz) = 573204
diff --git a/math/libqalculate/files/patch-libqalculate.pc.in b/math/libqalculate/files/patch-libqalculate.pc.in
new file mode 100644
index 000000000000..d62088e09d4d
--- /dev/null
+++ b/math/libqalculate/files/patch-libqalculate.pc.in
@@ -0,0 +1,13 @@
+--- libqalculate.pc.in.orig 2016-08-25 18:49:39 UTC
++++ libqalculate.pc.in
+@@ -5,7 +5,7 @@ includedir=@includedir@
+
+ Name: libqalculate
+ Description: libqalculate
+-Requires: glib-2.0 libxml-2.0
++Requires: cln glib-2.0 libxml-2.0
+ Version: @VERSION@
+ Libs: -L${libdir} -lqalculate
+-Cflags: -I${includedir}
+\ No newline at end of file
++Cflags: -I${includedir}
diff --git a/math/libqalculate/files/patch-src-Makefile.in b/math/libqalculate/files/patch-src-Makefile.in
deleted file mode 100644
index f05a4d01d6ae..000000000000
--- a/math/libqalculate/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur src/Makefile.in src/Makefile.in
---- src/Makefile.in 2007-06-17 04:45:49.000000000 -0400
-+++ src/Makefile.in 2008-02-02 11:37:48.000000000 -0500
-@@ -117,7 +117,7 @@
- INTLTOOL_XML_RULE = @INTLTOOL_XML_RULE@
- LDFLAGS = @LDFLAGS@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ @CLN_LIBS@
- LIBTOOL = @LIBTOOL@
- LN_QALCULATE = @LN_QALCULATE@
- LN_S = @LN_S@
diff --git a/math/libqalculate/files/patch-src-qalc.cc b/math/libqalculate/files/patch-src-qalc.cc
deleted file mode 100644
index f5e93c171d5b..000000000000
--- a/math/libqalculate/files/patch-src-qalc.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/qalc.cc.orig Fri Jun 3 12:51:31 2005
-+++ src/qalc.cc Fri Jun 3 12:51:45 2005
-@@ -16,7 +16,7 @@
- #include <time.h>
- #include <pthread.h>
- #include <dirent.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include <stdio.h>
- #include <vector>
- #include <glib.h>
diff --git a/math/libqalculate/pkg-descr b/math/libqalculate/pkg-descr
index 45ee2936fc83..b1a9ea63521d 100644
--- a/math/libqalculate/pkg-descr
+++ b/math/libqalculate/pkg-descr
@@ -3,4 +3,4 @@ use but with much power and versatility underneath. Features include
customizable functions, units, arbitrary precision, plotting, and
a user-friendly interface.
-WWW: http://qalculate.sourceforge.net
+WWW: http://qalculate.github.io/
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
index eced8fc57e97..8f7ffd003db3 100644
--- a/math/libqalculate/pkg-plist
+++ b/math/libqalculate/pkg-plist
@@ -14,8 +14,8 @@ include/libqalculate/qalculate.h
include/libqalculate/util.h
lib/libqalculate.a
lib/libqalculate.so
-lib/libqalculate.so.5
-lib/libqalculate.so.5.0.0
+lib/libqalculate.so.6
+lib/libqalculate.so.6.0.0
libdata/pkgconfig/libqalculate.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libqalculate.mo
%%NLS%%share/locale/nl/LC_MESSAGES/libqalculate.mo
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
index 659efdb34d42..41324750b2d4 100644
--- a/math/qalculate/Makefile
+++ b/math/qalculate/Makefile
@@ -2,34 +2,29 @@
# $FreeBSD$
PORTNAME= qalculate
-PORTVERSION= 0.9.7
-PORTREVISION= 4
+PORTVERSION= 0.9.9
+DISTVERSIONPREFIX= v
CATEGORIES= math
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-gtk/${PORTNAME}-gtk-${PORTVERSION}
-DISTNAME= ${PORTNAME}-gtk-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Multi-purpose desktop calculator (Gnome frontend)
+MAINTAINER= jhale@FreeBSD.org
+COMMENT= Multi-purpose desktop calculator (GTK+3 frontend)
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libqalculate.so:math/libqalculate
+LIB_DEPENDS= libcln.so:math/cln \
+ libqalculate.so:math/libqalculate
RUN_DEPENDS= gnuplot:math/gnuplot \
wget:ftp/wget
-USES= gettext gmake
-USE_GNOME= intltool libglade2 libgnome
+USES= autoreconf gettext gmake localbase
+USE_GNOME= cairo gdkpixbuf2 gtk30 intltool libxml2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-INSTALLS_OMF= yes
+DATADIR= share/${GH_PROJECT}
+DOCSDIR= share/doc/${GH_PROJECT}
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^Icon/s|=\(.*\)|=${PREFIX}/share/pixmaps/\1|' \
- ${WRKSRC}/data/qalculate-gtk.desktop.in
- @${REINPLACE_CMD} -e \
- 's/^GMSGFMT = @GMSGFMT@/GMSGFMT = msgfmt/' \
- ${WRKSRC}/po/Makefile.in.in
+USE_GITHUB= yes
+GH_ACCOUNT= Qalculate
+GH_PROJECT= ${PORTNAME}-gtk
.include <bsd.port.mk>
diff --git a/math/qalculate/distinfo b/math/qalculate/distinfo
index 138c4d7761b1..a516bc715743 100644
--- a/math/qalculate/distinfo
+++ b/math/qalculate/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qalculate-gtk-0.9.7.tar.gz) = a4ea8ee2366ac3ad53bb17fd2f76a7bed7211640cf2fdadfcf3b79eb4b37282d
-SIZE (qalculate-gtk-0.9.7.tar.gz) = 1511036
+TIMESTAMP = 1476485110
+SHA256 (Qalculate-qalculate-gtk-v0.9.9_GH0.tar.gz) = 6f62dc3c7a908be196c56bb7ef6841cc94a88f8b9d9df87f8af5791a995f316d
+SIZE (Qalculate-qalculate-gtk-v0.9.9_GH0.tar.gz) = 1686275
diff --git a/math/qalculate/files/patch-src-Makefile b/math/qalculate/files/patch-src-Makefile
deleted file mode 100644
index 326d05c19b85..000000000000
--- a/math/qalculate/files/patch-src-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2008-05-15 13:30:12.000000000 +0200
-+++ src/Makefile.in 2008-05-15 13:30:14.000000000 +0200
-@@ -121,7 +121,7 @@
- LIBGNOME_CFLAGS = @LIBGNOME_CFLAGS@
- LIBGNOME_LIBS = @LIBGNOME_LIBS@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@
-+LIBS = @LIBS@ @CLN_LIBS@
- LIBTOOL = @LIBTOOL@
- LN_QALCULATE = @LN_QALCULATE@
- LN_S = @LN_S@
diff --git a/math/qalculate/files/patch-src__callbacks.cc b/math/qalculate/files/patch-src__callbacks.cc
deleted file mode 100644
index 112a4f9e1e35..000000000000
--- a/math/qalculate/files/patch-src__callbacks.cc
+++ /dev/null
@@ -1,58 +0,0 @@
---- src/callbacks.cc.orig
-+++ src/callbacks.cc
-@@ -346,7 +346,7 @@
- it->sort();
- }
- }
-- bool operator < (tree_struct &s1) const {
-+ bool operator < (const tree_struct &s1) const {
- return item < s1.item;
- }
- };
-@@ -388,12 +388,12 @@
- }
-
- void show_message(const gchar *text, GtkWidget *win) {
-- GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, text);
-+ GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE, "%s", text);
- gtk_dialog_run(GTK_DIALOG(edialog));
- gtk_widget_destroy(edialog);
- }
- bool ask_question(const gchar *text, GtkWidget *win) {
-- GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_YES_NO, text);
-+ GtkWidget *edialog = gtk_message_dialog_new(GTK_WINDOW(win), GTK_DIALOG_DESTROY_WITH_PARENT, GTK_MESSAGE_ERROR, GTK_BUTTONS_YES_NO, "%s", text);
- int question_answer = gtk_dialog_run(GTK_DIALOG(edialog));
- gtk_widget_destroy(edialog);
- return question_answer == GTK_RESPONSE_YES;
-@@ -654,6 +654,7 @@
- GTK_DIALOG_DESTROY_WITH_PARENT,
- GTK_MESSAGE_INFO,
- GTK_BUTTONS_CLOSE,
-+ "%s",
- CALCULATOR->message()->message().c_str());
- gtk_dialog_run(GTK_DIALOG(edialog));
- gtk_widget_destroy(edialog);
-@@ -667,6 +668,7 @@
- GTK_DIALOG_DESTROY_WITH_PARENT,
- GTK_MESSAGE_ERROR,
- GTK_BUTTONS_CLOSE,
-+ "%s",
- str.c_str());
- } else {
- edialog = gtk_message_dialog_new(
-@@ -674,6 +676,7 @@
- GTK_DIALOG_DESTROY_WITH_PARENT,
- GTK_MESSAGE_WARNING,
- GTK_BUTTONS_CLOSE,
-+ "%s",
- str.c_str());
- }
-
-@@ -9405,6 +9408,7 @@
- } else {
- first_time = true;
- }
-+ fclose(file);
- if(show_keypad) show_history = false;
- set_saved_mode();
-
diff --git a/math/qalculate/pkg-descr b/math/qalculate/pkg-descr
index 45ee2936fc83..56069a620bdd 100644
--- a/math/qalculate/pkg-descr
+++ b/math/qalculate/pkg-descr
@@ -3,4 +3,4 @@ use but with much power and versatility underneath. Features include
customizable functions, units, arbitrary precision, plotting, and
a user-friendly interface.
-WWW: http://qalculate.sourceforge.net
+WWW: https://qalculate.github.io/
diff --git a/math/qalculate/pkg-plist b/math/qalculate/pkg-plist
index 91136cf9cc04..d22e12d24214 100644
--- a/math/qalculate/pkg-plist
+++ b/math/qalculate/pkg-plist
@@ -1,59 +1,61 @@
-bin/qalculate
bin/qalculate-gtk
+share/appdata/qalculate-gtk.appdata.xml
share/applications/qalculate-gtk.desktop
-share/gnome/help/qalculate-gtk/C/appendixa.xml
-share/gnome/help/qalculate-gtk/C/appendixb.xml
-share/gnome/help/qalculate-gtk/C/appendixc.xml
-share/gnome/help/qalculate-gtk/C/figures/calculation-history.png
-share/gnome/help/qalculate-gtk/C/figures/calculator-buttons-screen.png
-share/gnome/help/qalculate-gtk/C/figures/calculator-buttons.png
-share/gnome/help/qalculate-gtk/C/figures/completion.png
-share/gnome/help/qalculate-gtk/C/figures/convert-number-bases.png
-share/gnome/help/qalculate-gtk/C/figures/convert-unit.png
-share/gnome/help/qalculate-gtk/C/figures/edit-function.png
-share/gnome/help/qalculate-gtk/C/figures/edit-matrix.png
-share/gnome/help/qalculate-gtk/C/figures/edit-unit.png
-share/gnome/help/qalculate-gtk/C/figures/edit-variable.png
-share/gnome/help/qalculate-gtk/C/figures/function-manager.png
-share/gnome/help/qalculate-gtk/C/figures/gnuplot.png
-share/gnome/help/qalculate-gtk/C/figures/import-csv.png
-share/gnome/help/qalculate-gtk/C/figures/insert-function-screen.png
-share/gnome/help/qalculate-gtk/C/figures/insert-function.png
-share/gnome/help/qalculate-gtk/C/figures/mainwindow.png
-share/gnome/help/qalculate-gtk/C/figures/plot-data.png
-share/gnome/help/qalculate-gtk/C/figures/plot-settings.png
-share/gnome/help/qalculate-gtk/C/figures/rpn-mode.png
-share/gnome/help/qalculate-gtk/C/figures/store-variable.png
-share/gnome/help/qalculate-gtk/C/figures/unit-manager.png
-share/gnome/help/qalculate-gtk/C/figures/variable-manager.png
-share/gnome/help/qalculate-gtk/C/legal.xml
-share/gnome/help/qalculate-gtk/C/qalculate-gtk.xml
-share/omf/qalculate-gtk/qalculate-gtk-C.omf
-share/pixmaps/qalculate.png
-share/qalculate-gtk/glade/about.glade
-share/qalculate-gtk/glade/argumentrules.glade
-share/qalculate-gtk/glade/csvexport.glade
-share/qalculate-gtk/glade/csvimport.glade
-share/qalculate-gtk/glade/datasetedit.glade
-share/qalculate-gtk/glade/datasets.glade
-share/qalculate-gtk/glade/decimals.glade
-share/qalculate-gtk/glade/functionedit.glade
-share/qalculate-gtk/glade/functions.glade
-share/qalculate-gtk/glade/main.glade
-share/qalculate-gtk/glade/matrix.glade
-share/qalculate-gtk/glade/matrixedit.glade
-share/qalculate-gtk/glade/namesedit.glade
-share/qalculate-gtk/glade/nbases.glade
-share/qalculate-gtk/glade/periodictable.glade
-share/qalculate-gtk/glade/plot.glade
-share/qalculate-gtk/glade/precision.glade
-share/qalculate-gtk/glade/preferences.glade
-share/qalculate-gtk/glade/setbase.glade
-share/qalculate-gtk/glade/unit.glade
-share/qalculate-gtk/glade/unitedit.glade
-share/qalculate-gtk/glade/units.glade
-share/qalculate-gtk/glade/unknownedit.glade
-share/qalculate-gtk/glade/variableedit.glade
-share/qalculate-gtk/glade/variables.glade
+%%DOCSDIR%%/html/figures/calculation-history.png
+%%DOCSDIR%%/html/figures/calculator-buttons.png
+%%DOCSDIR%%/html/figures/completion.png
+%%DOCSDIR%%/html/figures/convert-number-bases.png
+%%DOCSDIR%%/html/figures/convert-unit.png
+%%DOCSDIR%%/html/figures/edit-function.png
+%%DOCSDIR%%/html/figures/edit-matrix.png
+%%DOCSDIR%%/html/figures/edit-unit.png
+%%DOCSDIR%%/html/figures/edit-variable.png
+%%DOCSDIR%%/html/figures/function-manager.png
+%%DOCSDIR%%/html/figures/gnuplot.png
+%%DOCSDIR%%/html/figures/import-csv.png
+%%DOCSDIR%%/html/figures/insert-function.png
+%%DOCSDIR%%/html/figures/mainwindow.png
+%%DOCSDIR%%/html/figures/plot-data.png
+%%DOCSDIR%%/html/figures/plot-settings.png
+%%DOCSDIR%%/html/figures/rpn-mode.png
+%%DOCSDIR%%/html/figures/store-variable.png
+%%DOCSDIR%%/html/figures/unit-manager.png
+%%DOCSDIR%%/html/figures/variable-manager.png
+%%DOCSDIR%%/html/index.html
+%%DOCSDIR%%/html/qalculate-definitions-functions.html
+%%DOCSDIR%%/html/qalculate-definitions-units.html
+%%DOCSDIR%%/html/qalculate-definitions-variables.html
+%%DOCSDIR%%/html/qalculate-expressions.html
+%%DOCSDIR%%/html/qalculate-functions.html
+%%DOCSDIR%%/html/qalculate-introduction.html
+%%DOCSDIR%%/html/qalculate-plotting.html
+%%DOCSDIR%%/html/qalculate-result.html
+%%DOCSDIR%%/html/qalculate-units.html
+%%DOCSDIR%%/html/qalculate-user-interface.html
+%%DOCSDIR%%/html/qalculate-variables.html
share/locale/nl/LC_MESSAGES/qalculate-gtk.mo
share/locale/sv/LC_MESSAGES/qalculate-gtk.mo
+share/pixmaps/qalculate.png
+%%DATADIR%%/ui/argumentrules.ui
+%%DATADIR%%/ui/csvexport.ui
+%%DATADIR%%/ui/csvimport.ui
+%%DATADIR%%/ui/datasetedit.ui
+%%DATADIR%%/ui/datasets.ui
+%%DATADIR%%/ui/decimals.ui
+%%DATADIR%%/ui/functionedit.ui
+%%DATADIR%%/ui/functions.ui
+%%DATADIR%%/ui/main.ui
+%%DATADIR%%/ui/matrix.ui
+%%DATADIR%%/ui/matrixedit.ui
+%%DATADIR%%/ui/namesedit.ui
+%%DATADIR%%/ui/nbases.ui
+%%DATADIR%%/ui/periodictable.ui
+%%DATADIR%%/ui/plot.ui
+%%DATADIR%%/ui/precision.ui
+%%DATADIR%%/ui/preferences.ui
+%%DATADIR%%/ui/setbase.ui
+%%DATADIR%%/ui/unitedit.ui
+%%DATADIR%%/ui/units.ui
+%%DATADIR%%/ui/unknownedit.ui
+%%DATADIR%%/ui/variableedit.ui
+%%DATADIR%%/ui/variables.ui
diff --git a/science/step/Makefile b/science/step/Makefile
index 180cd1bc4238..6c3a60489dab 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -2,6 +2,7 @@
PORTNAME= step
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 9fb432fa7d59..607dc0f8a142 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}