aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-tconfpy/Makefile30
-rw-r--r--devel/py-tconfpy/distinfo2
-rw-r--r--devel/py-tconfpy/pkg-descr10
-rw-r--r--devel/py-tconfpy/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 549d459ec78b..8d2712b97291 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1070,6 +1070,7 @@
SUBDIR += py-spark
SUBDIR += py-statgrab
SUBDIR += py-tables
+ SUBDIR += py-tconfpy
SUBDIR += py-twisted
SUBDIR += py-ui
SUBDIR += py-unit
diff --git a/devel/py-tconfpy/Makefile b/devel/py-tconfpy/Makefile
new file mode 100644
index 000000000000..be6ac87767eb
--- /dev/null
+++ b/devel/py-tconfpy/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-tconfpy
+# Date Created: 24 April 2004
+# Whom: tundra
+#
+# $FreeBSD$
+
+PORTNAME= py-tconfpy
+PORTVERSION= 1.185
+CATEGORIES= devel
+MASTER_SITES= http://www.tundraware.com/Software/tconfpy/
+
+MAINTAINER= tconfpy@tundraware.com
+COMMENT= A Python Configuration File Parser
+
+USE_PYTHON= yes
+
+MANCOMPRESSED= yes
+MAN1= test-tc.1
+MAN3= tconfpy.3
+PORTDOCS= READ-1ST.txt WHATSNEW.txt tconfpy-license.txt tconfpy.html tconfpy.pdf tconfpy.ps tconfpy.txt test-tc.html test-tc.pdf test-tc.ps test-tc.txt
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-tconfpy/distinfo b/devel/py-tconfpy/distinfo
new file mode 100644
index 000000000000..8ea085c8b6ef
--- /dev/null
+++ b/devel/py-tconfpy/distinfo
@@ -0,0 +1,2 @@
+MD5 (py-tconfpy-1.185.tar.gz) = 7223e2b460b2cac31f81a0caaa32b6ff
+SIZE (py-tconfpy-1.185.tar.gz) = 404371
diff --git a/devel/py-tconfpy/pkg-descr b/devel/py-tconfpy/pkg-descr
new file mode 100644
index 000000000000..8b40ec2224e3
--- /dev/null
+++ b/devel/py-tconfpy/pkg-descr
@@ -0,0 +1,10 @@
+'tconfpy' is an advanced configuration file parser and validator for
+Python programs. By using 'tconfpy', Python programmers can provide
+their users with an external configuration file for setting program
+options, defining defaults, and so on. 'tconfpy' offloads the
+responsibility for parsing and validating a configuration file from
+the main application. The Python programmer need only deal
+with the results and any errors or warnings generated during the
+parsing process.
+
+WWW: http://www.tundraware.com/Software/tconfpy/
diff --git a/devel/py-tconfpy/pkg-plist b/devel/py-tconfpy/pkg-plist
new file mode 100644
index 000000000000..cb8c97f0ed88
--- /dev/null
+++ b/devel/py-tconfpy/pkg-plist
@@ -0,0 +1,3 @@
+bin/test-tc.py
+%%PYTHON_SITELIBDIR%%/tconfpy.py
+%%PYTHON_SITELIBDIR%%/tconfpy.pyc