aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-fog-cloudatcost/Makefile25
-rw-r--r--net/rubygem-fog-cloudatcost/distinfo2
-rw-r--r--net/rubygem-fog-cloudatcost/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8a2428ff27a2..2af7913a0f1e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1094,6 +1094,7 @@
SUBDIR += rubygem-fog-atmos
SUBDIR += rubygem-fog-aws
SUBDIR += rubygem-fog-brightbox
+ SUBDIR += rubygem-fog-cloudatcost
SUBDIR += rubygem-fog-dynect
SUBDIR += rubygem-fog-ecloud
SUBDIR += rubygem-fog-google
diff --git a/net/rubygem-fog-cloudatcost/Makefile b/net/rubygem-fog-cloudatcost/Makefile
new file mode 100644
index 000000000000..5ac25345c52d
--- /dev/null
+++ b/net/rubygem-fog-cloudatcost/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-cloudatcost
+PORTVERSION= 0.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Module for the 'fog' gem to support CloudAtCost
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-fog-core>=1.36:devel/rubygem-fog-core \
+ rubygem-fog-json>=1.0:devel/rubygem-fog-json \
+ rubygem-fog-xml>=0.1:textproc/rubygem-fog-xml \
+ rubygem-ipaddress>=0.8:net/rubygem-ipaddress
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-fog-cloudatcost/distinfo b/net/rubygem-fog-cloudatcost/distinfo
new file mode 100644
index 000000000000..5fc5fba5094c
--- /dev/null
+++ b/net/rubygem-fog-cloudatcost/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/fog-cloudatcost-0.2.1.gem) = d2bb142047f011024c8f50fe340144c78997b410eeb4fb3e66127bd15cd448e5
+SIZE (rubygem/fog-cloudatcost-0.2.1.gem) = 20480
diff --git a/net/rubygem-fog-cloudatcost/pkg-descr b/net/rubygem-fog-cloudatcost/pkg-descr
new file mode 100644
index 000000000000..7bc978abfa16
--- /dev/null
+++ b/net/rubygem-fog-cloudatcost/pkg-descr
@@ -0,0 +1,3 @@
+Fog::CloudAtCost is a module for the 'fog' gem to support CloudAtCost services.
+
+WWW: https://github.com/fog/fog-cloudatcost