aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-fm/xfe/Makefile8
-rw-r--r--x11-fm/xfe/distinfo4
-rw-r--r--x11-fm/xfe/files/patch-src__main.cpp19
-rw-r--r--x11-fm/xfe/files/patch-xfeutils_cpp39
4 files changed, 46 insertions, 24 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index 604a3a084e95..5b5bae3b31f8 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfe
-PORTVERSION= 1.40
+PORTVERSION= 1.40.1
CATEGORIES= x11-fm
MASTER_SITES= SF
@@ -16,13 +16,15 @@ LIB_DEPENDS= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_CONFIGURE_ENABLE= nls
-USES= desktop-file-utils gettext gmake pathfix
+USES= desktop-file-utils gmake pathfix
USE_XORG= xft
USE_GNOME= intltool
GNU_CONFIGURE= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
diff --git a/x11-fm/xfe/distinfo b/x11-fm/xfe/distinfo
index c9165a0455cf..a98e5d130ea6 100644
--- a/x11-fm/xfe/distinfo
+++ b/x11-fm/xfe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfe-1.40.tar.gz) = 2b476f15beff1a1ce85dd4ce6559bb7ceca78b866c63fb4986456862a36862a8
-SIZE (xfe-1.40.tar.gz) = 2574477
+SHA256 (xfe-1.40.1.tar.gz) = ec3d9495bb329c6199f6265dbfb514ffd3bdb8801e36ccc4e8fac6cea15bcc71
+SIZE (xfe-1.40.1.tar.gz) = 2627754
diff --git a/x11-fm/xfe/files/patch-src__main.cpp b/x11-fm/xfe/files/patch-src__main.cpp
deleted file mode 100644
index 351e4fe12be6..000000000000
--- a/x11-fm/xfe/files/patch-src__main.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/main.cpp.orig
-+++ src/main.cpp
-@@ -270,6 +270,7 @@
- const char *vdrname = "Xfe";
- int i;
- FXbool loadicons;
-+ FXString cmd;
- FXString startfiledir1="";
- FXString startdir2="";
- FXbool iconic=false;
-@@ -307,7 +308,7 @@
- // - if dpkg exists then the system uses deb packages
- // - else if rpm exists, then the system uses rpm packages
- // - else another (unsupported) package manager is used
-- FXString cmd, str;
-+ FXString str;
-
- cmd="dpkg --version";
- str=getCommandOutput(cmd);
diff --git a/x11-fm/xfe/files/patch-xfeutils_cpp b/x11-fm/xfe/files/patch-xfeutils_cpp
new file mode 100644
index 000000000000..286320dba996
--- /dev/null
+++ b/x11-fm/xfe/files/patch-xfeutils_cpp
@@ -0,0 +1,39 @@
+--- src/xfeutils.cpp.orig 2015-09-07 15:32:21 UTC
++++ src/xfeutils.cpp
+@@ -563,36 +563,6 @@ int lstatmt(const char* filename, struct
+ #endif
+
+
+-// Safe strcpy function (Public domain, by C.B. Falconer)
+-// The destination string is always null terminated
+-// Size sz must be equal to strlen(src)+1
+-size_t strlcpy(char* dst, const char* src, size_t sz)
+-{
+- const char *start = src;
+-
+- if (src && sz--)
+- {
+- while ((*dst++ = *src))
+- if (sz--)
+- src++;
+- else
+- {
+- *(--dst) = '\0';
+- break;
+- }
+- }
+- if (src)
+- {
+- while (*src++)
+- continue;
+- return src - start - 1;
+- }
+- else if (sz)
+- *dst = '\0';
+- return 0;
+-}
+-
+-
+ // Safe strcat function (Public domain, by C.B. Falconer)
+ // The destination string is always null terminated
+ size_t strlcat(char* dst, const char* src, size_t sz)