aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/diffmark/Makefile26
-rw-r--r--textproc/diffmark/distinfo3
-rw-r--r--textproc/diffmark/pkg-descr8
-rw-r--r--textproc/diffmark/pkg-plist20
5 files changed, 58 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ad23dd8edceb..7323ecb3d388 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -77,6 +77,7 @@
SUBDIR += dictfmt
SUBDIR += dictionary
SUBDIR += diff-mode.el
+ SUBDIR += diffmark
SUBDIR += diffsplit
SUBDIR += diffstat
SUBDIR += diffutils
diff --git a/textproc/diffmark/Makefile b/textproc/diffmark/Makefile
new file mode 100644
index 000000000000..3442d42eb5fa
--- /dev/null
+++ b/textproc/diffmark/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: diffmark
+# Date created: 05 September 2006
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diffmark
+PORTVERSION= 0.05
+CATEGORIES= textproc
+MASTER_SITES= http://www.mangrove.cz/diffmark/
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= XML diff and merge package
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_LDCONFIG= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --with-libxml2-incldir=${LOCALBASE}/include/libxml2
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/textproc/diffmark/distinfo b/textproc/diffmark/distinfo
new file mode 100644
index 000000000000..5ef45a2af83c
--- /dev/null
+++ b/textproc/diffmark/distinfo
@@ -0,0 +1,3 @@
+MD5 (diffmark-0.05.tar.gz) = 07143fc832a06b57f3bcab75c1a2063f
+SHA256 (diffmark-0.05.tar.gz) = 9687614658a9f76280ec7807046492899d0ed0a08038c4eec190bc1af42e173f
+SIZE (diffmark-0.05.tar.gz) = 330572
diff --git a/textproc/diffmark/pkg-descr b/textproc/diffmark/pkg-descr
new file mode 100644
index 000000000000..653ba4f9bf73
--- /dev/null
+++ b/textproc/diffmark/pkg-descr
@@ -0,0 +1,8 @@
+diffmark is an XML diff and merge package. It consists of a shared C++
+library, libdiffmark, plus two programs wrapping the library into a
+command-line interface: dm and dm-merge. dm takes 2 XML files and
+prints their diff (also an XML document) on its standard output.
+dm-merge takes the first document passed to dm and its output and
+produces the second document.
+
+WWW: http://www.mangrove.cz/diffmark/
diff --git a/textproc/diffmark/pkg-plist b/textproc/diffmark/pkg-plist
new file mode 100644
index 000000000000..d0c175c24faa
--- /dev/null
+++ b/textproc/diffmark/pkg-plist
@@ -0,0 +1,20 @@
+bin/dm
+bin/dm-merge
+include/diffmark/compare.hh
+include/diffmark/compareimpl.hh
+include/diffmark/diff.hh
+include/diffmark/lcs.hh
+include/diffmark/lcsimpl.hh
+include/diffmark/link.hh
+include/diffmark/merge.hh
+include/diffmark/namespacecollector.hh
+include/diffmark/nspace.hh
+include/diffmark/target.hh
+include/diffmark/xbuffer.hh
+include/diffmark/xdoc.hh
+include/diffmark/xutil.hh
+lib/libdiffmark.a
+lib/libdiffmark.la
+lib/libdiffmark.so.2
+lib/libdiffmark.so
+@dirrm include/diffmark