aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/py-mxStack/Makefile6
-rw-r--r--devel/py-mxStack/pkg-plist6
2 files changed, 10 insertions, 2 deletions
diff --git a/devel/py-mxStack/Makefile b/devel/py-mxStack/Makefile
index e5c403099cbf..cc921dcd9472 100644
--- a/devel/py-mxStack/Makefile
+++ b/devel/py-mxStack/Makefile
@@ -32,9 +32,13 @@ post-extract:
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
-post-install:
+do-install:
@${MKDIR} ${STACKDIR}
${INSTALL_DATA} ${WRKDIR}/Stack/*.py ${STACKDIR}
+ @${MKDIR} ${STACKDIR}/mxStack
+.for file in __init__.py mxStack.so
+ ${INSTALL_DATA} ${WRKDIR}/Stack/mxStack/${file} ${STACKDIR}/mxStack
+.endfor
@${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${STACKDIR}
@${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${STACKDIR}
.if !defined(NOPORTDOCS)
diff --git a/devel/py-mxStack/pkg-plist b/devel/py-mxStack/pkg-plist
index 3937806b91b3..39006591adba 100644
--- a/devel/py-mxStack/pkg-plist
+++ b/devel/py-mxStack/pkg-plist
@@ -4,10 +4,14 @@ lib/python1.5/site-packages/Stack/UserStack.pyo
lib/python1.5/site-packages/Stack/__init__.py
lib/python1.5/site-packages/Stack/__init__.pyc
lib/python1.5/site-packages/Stack/__init__.pyo
+lib/python1.5/site-packages/Stack/mxStack/__init__.py
+lib/python1.5/site-packages/Stack/mxStack/__init__.pyc
+lib/python1.5/site-packages/Stack/mxStack/__init__.pyo
+lib/python1.5/site-packages/Stack/mxStack/mxStack.so
+@dirrm lib/python1.5/site-packages/Stack/mxStack
lib/python1.5/site-packages/Stack/stackbench.py
lib/python1.5/site-packages/Stack/stackbench.pyc
lib/python1.5/site-packages/Stack/stackbench.pyo
-lib/python1.5/site-packages/mxStack.so
@dirrm lib/python1.5/site-packages/Stack
share/doc/py-mxStack/mxStack.html
@dirrm share/doc/py-mxStack