aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile10
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/distinfo2
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-comment2
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-plist12
4 files changed, 21 insertions, 5 deletions
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index f5208b2531e7..bd0849f96883 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Spreadsheet-WriteExcel
-PORTVERSION= 0.24
+PORTVERSION= 0.31
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Spreadsheet
@@ -14,6 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@protey.ru
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= Spreadsheet::WriteExcel::Worksheet.3 \
@@ -21,7 +24,10 @@ MAN3= Spreadsheet::WriteExcel::Worksheet.3 \
Spreadsheet::WriteExcel::OLEwriter.3 \
Spreadsheet::WriteExcel::Workbook.3 \
Spreadsheet::WriteExcel::examples::WorkbookBig.3 \
- Spreadsheet::WriteExcel.3 Spreadsheet::WriteExcel::Format.3
+ Spreadsheet::WriteExcel.3 \
+ Spreadsheet::WriteExcel::Format.3 \
+ Spreadsheet::WriteExcel::Formula.3 \
+ Spreadsheet::WriteExcel::examples::Big.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcel/distinfo b/textproc/p5-Spreadsheet-WriteExcel/distinfo
index 4c8df68e51bf..a031b49246fb 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/distinfo
+++ b/textproc/p5-Spreadsheet-WriteExcel/distinfo
@@ -1 +1 @@
-MD5 (Spreadsheet-WriteExcel-0.24.tar.gz) = f5f9773b02044d21aefcf883caedd2e9
+MD5 (Spreadsheet-WriteExcel-0.31.tar.gz) = 7c01b53fdf2a592896a5a166805cc2f4
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-comment b/textproc/p5-Spreadsheet-WriteExcel/pkg-comment
index df38cbf98a01..f5ba18051763 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/pkg-comment
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-comment
@@ -1 +1 @@
-Write formatted text and numbers to a cross-platform Excel binary file.
+Write to a cross-platform Excel binary file
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-plist b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
index 52d23c699c1f..8549553e21ae 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
@@ -2,6 +2,7 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel/.pack
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel.pm
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/BIFFwriter.pm
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Format.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Formula.pm
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/OLEwriter.pm
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Workbook.pm
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/Worksheet.pm
@@ -14,6 +15,7 @@ lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/number_formats1.html
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/number_formats2.html
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/regions.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/simple.gif
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/stats.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/stocks.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/textwrap.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj.html
@@ -24,19 +26,27 @@ lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-04.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/tpj0503-0004-05.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/doc/win32ole.gif
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/Big.pm
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/README.txt
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/WorkbookBig.pm
-lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/big.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/bigfile.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/cgi.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/comments.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/convertA1.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/copyformat.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/csv2xls.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/easter_egg.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/filehandle.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/formats.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/function_locale.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/hyperlink.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/merge1.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/merge2.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/mod_perl.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/ms_time.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/regions.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/simple.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/stats.pl
+lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/stats_ext.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/stocks.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/tab2xls.pl
lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/WriteExcel/examples/textwrap.pl