aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/obs-studio/Makefile2
-rw-r--r--multimedia/obs-studio/files/patch-git_4bdb45a825
-rw-r--r--multimedia/obs-studio/files/patch-git_5983b50625
-rw-r--r--textproc/sigil/Makefile5
-rw-r--r--x11/antimicro/Makefile5
5 files changed, 61 insertions, 1 deletions
diff --git a/multimedia/obs-studio/Makefile b/multimedia/obs-studio/Makefile
index b3319a1c2d2f..e6598b88ed15 100644
--- a/multimedia/obs-studio/Makefile
+++ b/multimedia/obs-studio/Makefile
@@ -27,7 +27,7 @@ USE_GL+= gl
USE_QT5= core dbus gui opengl network svg multimedia \
imageformats buildtools qmake x11extras
CFLAGS+= -fPIC
-LDFLAGS+= -lsysinfo
+LDFLAGS+= ${LOCALBASE}/lib/libsysinfo.so
USES= cmake compiler:c11
CMAKE_ARGS+= -DUNIX_STRUCTURE=1 \
-DOBS_VERSION_OVERRIDE=${PORTVERSION}
diff --git a/multimedia/obs-studio/files/patch-git_4bdb45a8 b/multimedia/obs-studio/files/patch-git_4bdb45a8
new file mode 100644
index 000000000000..72cab0cf7761
--- /dev/null
+++ b/multimedia/obs-studio/files/patch-git_4bdb45a8
@@ -0,0 +1,25 @@
+commit 4bdb45a8acfee805c715ca8ccf3cf74aac1a5223
+Author: fryshorts <leonhard@in-verted.de>
+Date: Sun May 3 17:09:29 2015 +0200
+
+ linux-v4l2: Add include directory to cmake
+
+ Add the include directories found by cmake to the v4l2 plugin.
+ This allows for the plugin to compile when the vl42 headers were
+ found in a directory that is not normally in the search path of the
+ compiler (e.g. /usr/local/include)
+
+--- plugins/linux-v4l2/CMakeLists.txt
++++ plugins/linux-v4l2/CMakeLists.txt
+@@ -24,6 +24,11 @@ else()
+ add_definitions(-DHAVE_UDEV)
+ endif()
+
++include_directories(
++ SYSTEM "${CMAKE_SOURCE_DIR}/libobs"
++ ${LIBV4L2_INCLUDE_DIRS}
++)
++
+ set(linux-v4l2_SOURCES
+ linux-v4l2.c
+ v4l2-input.c
diff --git a/multimedia/obs-studio/files/patch-git_5983b506 b/multimedia/obs-studio/files/patch-git_5983b506
new file mode 100644
index 000000000000..f1e095d42566
--- /dev/null
+++ b/multimedia/obs-studio/files/patch-git_5983b506
@@ -0,0 +1,25 @@
+commit 5983b506e9a692a00987d86a60390028d3ad73ce
+Author: fryshorts <leonhard@in-verted.de>
+Date: Sun May 3 17:01:09 2015 +0200
+
+ linux-pulseaudio: Add include directory to cmake
+
+ Add the include directories found by cmake to the pulseaudio plugin.
+ This allows for the plugin to compile when the pulseaudio headers were
+ found in a directory that is not normally in the search path of the
+ compiler (e.g. /usr/local/include)
+
+--- plugins/linux-pulseaudio/CMakeLists.txt
++++ plugins/linux-pulseaudio/CMakeLists.txt
+@@ -13,7 +13,10 @@ elseif(NOT PULSEAUDIO_FOUND)
+ return()
+ endif()
+
+-include_directories(SYSTEM "${CMAKE_SOURCE_DIR}/libobs")
++include_directories(
++ SYSTEM "${CMAKE_SOURCE_DIR}/libobs"
++ ${PULSEAUDIO_INCLUDE_DIR}
++)
+
+ set(linux-pulseaudio_SOURCES
+ linux-pulseaudio.c
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 9a42b6ab8c58..3febab7bb59d 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -18,6 +18,11 @@ USE_GITHUB= yes
GH_ACCOUNT= Sigil-Ebook
GH_PROJECT= Sigil
+# Upstream uses pkg-config output to pass libhunspell-1.3.so and
+# libpcre16.so to the linker. pkg-config output does not include full
+# paths, so add a workaround to keep the port linking for now.
+LDFLAGS+= -L${LOCALBASE}/lib
+
USES= cmake compiler:c++11-lib desktop-file-utils pkgconfig \
python:3 shebangfix
SHEBANG_FILES= src/Resource_Files/plugin_launchers/python/*.py \
diff --git a/x11/antimicro/Makefile b/x11/antimicro/Makefile
index c697ca266edf..43c791368e29 100644
--- a/x11/antimicro/Makefile
+++ b/x11/antimicro/Makefile
@@ -13,6 +13,11 @@ LICENSE= GPLv3
USE_GITHUB= yes
GH_ACCOUNT= Ryochan7
+# Upstream assumes ${LOCALBASE}/lib is part of the default linker path. Pull
+# request 268 fixes it for X11 libraries, but SDL2 is still using pkg-config
+# output (without full paths).
+LDFLAGS+= ${LOCALBASE}/lib
+
USE_XORG= x11 xtst
USE_QT5= linguisttools_build qmake_build buildtools_build widgets network
USE_SDL= sdl2