aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/py-django19/Makefile17
-rw-r--r--www/py-django19/pkg-descr2
2 files changed, 8 insertions, 11 deletions
diff --git a/www/py-django19/Makefile b/www/py-django19/Makefile
index 260fec8be45f..71757866d6ff 100644
--- a/www/py-django19/Makefile
+++ b/www/py-django19/Makefile
@@ -17,6 +17,7 @@ COMMENT= High-level Python Web Framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_ARCH= yes
USES= cpe python
USE_PYTHON= autoplist distutils
@@ -25,7 +26,7 @@ CPE_VENDOR= djangoproject
DOCSDIR= ${PREFIX}/share/doc/py-django
-OPTIONS_DEFINE= FASTCGI HTMLDOCS
+OPTIONS_DEFINE= DOCS FASTCGI HTMLDOCS
OPTIONS_DEFAULT= SQLITE
OPTIONS_GROUP= DATABASE
@@ -35,6 +36,7 @@ HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
PLIST_FILES= man/man1/django-admin.1.gz
+HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2
MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
@@ -42,27 +44,22 @@ FASTCGI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flup>0:www/py-flup
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MHTMLDOCS}
-. if empty(PORT_OPTIONS:MDOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS} && empty(PORT_OPTIONS:MDOCS)
IGNORE= you cannot build documentation with DOCS option disabled
-. endif
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx
PORTDOCS= *
.endif
-post-build:
-.if ${PORT_OPTIONS:MHTMLDOCS}
+post-build-HTMLDOCS-on:
cd ${WRKSRC}/docs && ${MAKE} html
-.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1
@${ECHO_MSG} ""
@${ECHO_MSG} " * See http://docs.djangoproject.com/ for complete documentation"
@${ECHO_MSG} ""
-.if ${PORT_OPTIONS:MHTMLDOCS}
+
+post-install-HTMLDOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
${CP} -R ${WRKSRC}/docs/_build/html ${STAGEDIR}/${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/www/py-django19/pkg-descr b/www/py-django19/pkg-descr
index 638401f81c0e..0ea493b87ab6 100644
--- a/www/py-django19/pkg-descr
+++ b/www/py-django19/pkg-descr
@@ -7,4 +7,4 @@ intensive deadlines of a newsroom and the stringent requirements of experienced
Web developers. It has convenient niceties for developing content-management
systems, but it's an excellent tool for building any Web site.
-WWW: http://www.djangoproject.com
+WWW: https://www.djangoproject.com/