aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyter_console/Makefile23
-rw-r--r--devel/py-jupyter_console/distinfo3
-rw-r--r--devel/py-jupyter_console/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ce309c744716..3cc499740f52 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4358,6 +4358,7 @@
SUBDIR += py-jsonrpclib
SUBDIR += py-jsonschema
SUBDIR += py-jupyter_client
+ SUBDIR += py-jupyter_console
SUBDIR += py-jupyter_core
SUBDIR += py-kaptan
SUBDIR += py-kayako
diff --git a/devel/py-jupyter_console/Makefile b/devel/py-jupyter_console/Makefile
new file mode 100644
index 000000000000..9613dda8053e
--- /dev/null
+++ b/devel/py-jupyter_console/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= jupyter_console
+PORTVERSION= 5.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= IPython-like terminal frontend for Jupyter kernels in any language
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyter_client>=0:devel/py-jupyter_client \
+ ${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython \
+ ${PYTHON_PKGNAMEPREFIX}ipykernel>=0:devel/py-ipykernel \
+ ${PYTHON_PKGNAMEPREFIX}prompt_toolkit>=1.0.4:devel/py-prompt_toolkit \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_LOCALE= en_US.UTF-8
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyter_console/distinfo b/devel/py-jupyter_console/distinfo
new file mode 100644
index 000000000000..2d63b3b140b8
--- /dev/null
+++ b/devel/py-jupyter_console/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1487847529
+SHA256 (jupyter_console-5.1.0.tar.gz) = d0b4ae4dfe070be1e9d5690fa819328acffb5f37a8ef3baa1c7e3b77b443cfd7
+SIZE (jupyter_console-5.1.0.tar.gz) = 26661
diff --git a/devel/py-jupyter_console/pkg-descr b/devel/py-jupyter_console/pkg-descr
new file mode 100644
index 000000000000..eb4a9bf3ad76
--- /dev/null
+++ b/devel/py-jupyter_console/pkg-descr
@@ -0,0 +1,4 @@
+The Jupyter console is a terminal frontend for kernels using the Jupyter
+protocol.
+
+WWW: https://jupyter-console.readthedocs.io/