aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/Makefile1
-rw-r--r--science/madness/Makefile29
-rw-r--r--science/madness/distinfo3
-rw-r--r--science/madness/files/patch-src_CMakeLists.txt11
-rw-r--r--science/madness/files/patch-src_madness_world_thread.cc22
-rw-r--r--science/madness/files/patch-src_madness_world_worldmem.h11
-rw-r--r--science/madness/pkg-descr14
-rw-r--r--science/madness/pkg-plist190
8 files changed, 281 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 220a4a2ccbf7..381fb914bb6c 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -110,6 +110,7 @@
SUBDIR += libsvm-python
SUBDIR += libxc
SUBDIR += linsmith
+ SUBDIR += madness
SUBDIR += massxpert
SUBDIR += mbdyn
SUBDIR += mcstas
diff --git a/science/madness/Makefile b/science/madness/Makefile
new file mode 100644
index 000000000000..afa4ea349d1d
--- /dev/null
+++ b/science/madness/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= madness
+DISTVERSION= 0.10.1.20180823
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Multiresolution adaptive numeric environment for scientific simulation
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= libsysinfo>0:devel/libsysinfo
+LIB_DEPENDS= libblas.so:math/blas \
+ liblapack.so:math/lapack \
+ libmpich.so:net/mpich2 \
+ libtbb.so:devel/tbb \
+ libtcmalloc.so:devel/google-perftools \
+ libxc.so:science/libxc
+
+USES= cmake:outsource compiler:c++14-lang fortran localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= m-a-d-n-e-s-s
+GH_TAGNAME= ebb3fd7
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DLAPACK_LIBRARIES:STRING="-L${LOCALBASE}/lib -llapack -lblas -L${LOCALBASE}/lib/gcc${GCC_DEFAULT} -lgcc_s"
+
+.include <bsd.port.mk>
diff --git a/science/madness/distinfo b/science/madness/distinfo
new file mode 100644
index 000000000000..498c1ba855fe
--- /dev/null
+++ b/science/madness/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1535353560
+SHA256 (m-a-d-n-e-s-s-madness-0.10.1.20180823-ebb3fd7_GH0.tar.gz) = fe1901c335dfcff9323f6a6fde528a5a10998c21d3c21d727040ece2ffb55118
+SIZE (m-a-d-n-e-s-s-madness-0.10.1.20180823-ebb3fd7_GH0.tar.gz) = 6829265
diff --git a/science/madness/files/patch-src_CMakeLists.txt b/science/madness/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..f61d753ca512
--- /dev/null
+++ b/science/madness/files/patch-src_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/CMakeLists.txt.orig 2018-08-27 06:57:22 UTC
++++ src/CMakeLists.txt
+@@ -2,7 +2,7 @@
+
+ add_subdirectory(madness)
+ add_subdirectory(apps)
+-add_subdirectory(examples)
++#add_subdirectory(examples)
+
+ install(FILES madness.h
+ DESTINATION "${MADNESS_INSTALL_INCLUDEDIR}"
diff --git a/science/madness/files/patch-src_madness_world_thread.cc b/science/madness/files/patch-src_madness_world_thread.cc
new file mode 100644
index 000000000000..fedcbc33bcf1
--- /dev/null
+++ b/science/madness/files/patch-src_madness_world_thread.cc
@@ -0,0 +1,22 @@
+--- src/madness/world/thread.cc.orig 2018-08-24 00:32:22 UTC
++++ src/madness/world/thread.cc
+@@ -44,6 +44,8 @@
+ #include <madness/world/atomicint.h>
+ #include <cstring>
+ #include <fstream>
++#include <sys/param.h>
++#include <sys/cpuset.h>
+
+ #if defined(HAVE_IBMBGQ) and defined(HPM)
+ extern "C" unsigned int HPM_Prof_init_thread(void);
+@@ -248,8 +250,8 @@ namespace madness {
+ }
+ }
+
+-#ifndef ON_A_MAC
+- cpu_set_t mask;
++#if !defined(ON_A_MAC) && !defined(__FreeBSD__) // need to port to FreeBSD
++ cpuset_t mask;
+ CPU_ZERO(&mask);
+ for (int i=lo; i<=hi; ++i) CPU_SET(i,&mask);
+ if (sched_setaffinity(0, sizeof(mask), &mask) == -1) {
diff --git a/science/madness/files/patch-src_madness_world_worldmem.h b/science/madness/files/patch-src_madness_world_worldmem.h
new file mode 100644
index 000000000000..79344a9b64d5
--- /dev/null
+++ b/science/madness/files/patch-src_madness_world_worldmem.h
@@ -0,0 +1,11 @@
+--- src/madness/world/worldmem.h.orig 2018-08-27 07:36:33 UTC
++++ src/madness/world/worldmem.h
+@@ -49,7 +49,7 @@
+ #elif defined(ON_A_MAC)
+ #include <malloc/malloc.h>
+ #elif defined(X86_32)
+-#include <malloc.h>
++#include <stdlib.h>
+ #elif defined(X86_64)
+ #include <sys/types.h>
+ #include <unistd.h>
diff --git a/science/madness/pkg-descr b/science/madness/pkg-descr
new file mode 100644
index 000000000000..c517654a06f4
--- /dev/null
+++ b/science/madness/pkg-descr
@@ -0,0 +1,14 @@
+MADNESS provides a high-level environment for the solution of integral and
+differential equations in many dimensions using adaptive, fast methods with
+guaranteed precision based on multi-resolution analysis and novel separated
+representations. There are three main components to MADNESS. At the lowest
+level is a new petascale parallel programming environment that increases
+programmer productivity and code performance/scalability while maintaining
+backward compatibility with current programming tools such as MPI and Global
+Arrays. The numerical capabilities built upon the parallel tools provide a
+high-level environment for composing and solving numerical problems in many
+(1-6+) dimensions. Finally, built upon the numerical tools are new applications
+with initial focus upon chemistry, atomic and molecular physics, material
+science, and nuclear structure.
+
+WWW: https://github.com/m-a-d-n-e-s-s/madness
diff --git a/science/madness/pkg-plist b/science/madness/pkg-plist
new file mode 100644
index 000000000000..14cb00f3e7be
--- /dev/null
+++ b/science/madness/pkg-plist
@@ -0,0 +1,190 @@
+bin/mcpfit
+bin/moldft
+bin/mraplot
+bin/tdse
+bin/tdse4
+include/chem/AC.h
+include/chem/CC2.h
+include/chem/CCPotentials.h
+include/chem/CCStructures.h
+include/chem/CalculationParameters.h
+include/chem/SCF.h
+include/chem/SCFOperators.h
+include/chem/SCFProtocol.h
+include/chem/TDHF.h
+include/chem/atomutil.h
+include/chem/cheminfo.h
+include/chem/corepotential.h
+include/chem/correlationfactor.h
+include/chem/electronic_correlation_factor.h
+include/chem/gth_pseudopotential.h
+include/chem/molecular_optimizer.h
+include/chem/molecularbasis.h
+include/chem/molecule.h
+include/chem/molopt.h
+include/chem/mp2.h
+include/chem/nemo.h
+include/chem/pcm.h
+include/chem/potentialmanager.h
+include/chem/projector.h
+include/chem/vibanal.h
+include/chem/xcfunctional.h
+include/madness.h
+include/madness/config.h
+include/madness/constants.h
+include/madness/external/muParser/muParser.h
+include/madness/external/muParser/muParserBase.h
+include/madness/external/muParser/muParserBytecode.h
+include/madness/external/muParser/muParserCallback.h
+include/madness/external/muParser/muParserDLL.h
+include/madness/external/muParser/muParserDef.h
+include/madness/external/muParser/muParserError.h
+include/madness/external/muParser/muParserFixes.h
+include/madness/external/muParser/muParserInt.h
+include/madness/external/muParser/muParserStack.h
+include/madness/external/muParser/muParserTest.h
+include/madness/external/muParser/muParserToken.h
+include/madness/external/muParser/muParserTokenReader.h
+include/madness/external/tinyxml/tinystr.h
+include/madness/external/tinyxml/tinyxml.h
+include/madness/fortran_ctypes.h
+include/madness/madness_config.h
+include/madness/misc/cfft.h
+include/madness/misc/interpolation_1d.h
+include/madness/misc/misc.h
+include/madness/misc/phandler.h
+include/madness/misc/ran.h
+include/madness/mra/adquad.h
+include/madness/mra/convolution1d.h
+include/madness/mra/derivative.h
+include/madness/mra/displacements.h
+include/madness/mra/funcdefaults.h
+include/madness/mra/funcimpl.h
+include/madness/mra/funcplot.h
+include/madness/mra/function_common_data.h
+include/madness/mra/function_factory.h
+include/madness/mra/function_interface.h
+include/madness/mra/functypedefs.h
+include/madness/mra/gfit.h
+include/madness/mra/indexit.h
+include/madness/mra/key.h
+include/madness/mra/lbdeux.h
+include/madness/mra/leafop.h
+include/madness/mra/legendre.h
+include/madness/mra/mra.h
+include/madness/mra/mraimpl.h
+include/madness/mra/nonlinsol.h
+include/madness/mra/operator.h
+include/madness/mra/power.h
+include/madness/mra/qmprop.h
+include/madness/mra/sdf_domainmask.h
+include/madness/mra/sdf_shape_3D.h
+include/madness/mra/simplecache.h
+include/madness/mra/twoscale.h
+include/madness/mra/vmra.h
+include/madness/mra/vmra1.h
+include/madness/tensor/aligned.h
+include/madness/tensor/basetensor.h
+include/madness/tensor/cblas.h
+include/madness/tensor/clapack.h
+include/madness/tensor/clapack_fortran.h
+include/madness/tensor/distributed_matrix.h
+include/madness/tensor/elem.h
+include/madness/tensor/gentensor.h
+include/madness/tensor/mxm.h
+include/madness/tensor/slice.h
+include/madness/tensor/solvers.h
+include/madness/tensor/srconf.h
+include/madness/tensor/systolic.h
+include/madness/tensor/tensor.h
+include/madness/tensor/tensor_lapack.h
+include/madness/tensor/tensor_macros.h
+include/madness/tensor/tensor_spec.h
+include/madness/tensor/tensorexcept.h
+include/madness/tensor/tensoriter.h
+include/madness/tensor/tensoriter_spec.h
+include/madness/tensor/tensortrain.h
+include/madness/tensor/type_data.h
+include/madness/tensor/vector_factory.h
+include/madness/tensor/vmath.h
+include/madness/world/MADworld.h
+include/madness/world/archive.h
+include/madness/world/array_addons.h
+include/madness/world/atomicint.h
+include/madness/world/bgq_atomics.h
+include/madness/world/binary_fstream_archive.h
+include/madness/world/binsorter.h
+include/madness/world/buffer_archive.h
+include/madness/world/deferred_cleanup.h
+include/madness/world/dependency_interface.h
+include/madness/world/dist_cache.h
+include/madness/world/distributed_id.h
+include/madness/world/dqueue.h
+include/madness/world/function_traits.h
+include/madness/world/future.h
+include/madness/world/group.h
+include/madness/world/info.h
+include/madness/world/madness_exception.h
+include/madness/world/mem_func_wrapper.h
+include/madness/world/meta.h
+include/madness/world/mpi_archive.h
+include/madness/world/nodefaults.h
+include/madness/world/parallel_archive.h
+include/madness/world/parsec.h
+include/madness/world/posixmem.h
+include/madness/world/print.h
+include/madness/world/print_seq.h
+include/madness/world/range.h
+include/madness/world/safempi.h
+include/madness/world/stack.h
+include/madness/world/stubmpi.h
+include/madness/world/taskfn.h
+include/madness/world/text_fstream_archive.h
+include/madness/world/thread.h
+include/madness/world/timers.h
+include/madness/world/type_traits.h
+include/madness/world/uniqueid.h
+include/madness/world/vector.h
+include/madness/world/vector_archive.h
+include/madness/world/world.h
+include/madness/world/world_object.h
+include/madness/world/world_task_queue.h
+include/madness/world/worldam.h
+include/madness/world/worlddc.h
+include/madness/world/worldgop.h
+include/madness/world/worldhash.h
+include/madness/world/worldhashmap.h
+include/madness/world/worldmem.h
+include/madness/world/worldmpi.h
+include/madness/world/worldmutex.h
+include/madness/world/worldpapi.h
+include/madness/world/worldprofile.h
+include/madness/world/worldptr.h
+include/madness/world/worldref.h
+include/madness/world/worldrmi.h
+include/madness/world/worldtypes.h
+lib/cmake/madness/madness-config-version.cmake
+lib/cmake/madness/madness-config.cmake
+lib/cmake/madness/madness-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/madness/madness-targets.cmake
+lib/cmake/madness/madworld-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/madness/madworld-targets.cmake
+lib/libMADchem.so
+lib/libMADlinalg.so
+lib/libMADmisc.so
+lib/libMADmra.so
+lib/libMADmuparser.so
+lib/libMADtensor.so
+lib/libMADtinyxml.so
+lib/libMADworld.so
+lib/libmadness.so
+libdata/pkgconfig/MADNESS.pc
+%%DATADIR%%/0.10.1/data/6-31g
+%%DATADIR%%/0.10.1/data/autocorr
+%%DATADIR%%/0.10.1/data/coeffs
+%%DATADIR%%/0.10.1/data/gaussleg
+%%DATADIR%%/0.10.1/data/mcp
+%%DATADIR%%/0.10.1/data/mcp2
+%%DATADIR%%/0.10.1/data/mcp_guess
+%%DATADIR%%/0.10.1/data/sto-3g
+%%DATADIR%%/0.10.1/data/sto-6g
e3969469f3685a7d421eb1497faf3076c773306'>Make x11-themes/qtcurve patch applytcberner2017-12-311-2/+2 * Fix plisttcberner2017-12-312-0/+2 * qtcurve-qt5: Add an upstream patch to fix the build with Qt 5.9.rakuco2017-12-311-0/+34 * Update to 0.10.5rezny2017-12-255-11/+62 * Update KDE Frameworks to 5.41tcberner2017-12-155-12/+16 * Update to upstream version 3.1.9riggs2017-12-113-4/+191 * New port: x11-themes/xfce-evolution: Complete Xfce Evolution Gtk2, Gtk3, Qt4,...yuri2017-11-265-0/+1761 * Update KDE Frameworks to 5.40.0tcberner2017-11-169-19/+19 * Fix the context of some patches so that they apply with stricter patch(1)antoine2017-11-101-1/+4 * Collection of high-resolution wallpapers and Qt5 color schemesaraujo2017-11-065-0/+68 * x11-themes/openbox-themes: update to 1.0.2novel2017-11-043-1015/+1346 * Update some of the KDE Frameworks 5 ports with DISTVERSION, LICENSEadridg2017-10-251-2/+5 * Update KDE Frameworks to 5.39tcberner2017-10-185-12/+16 * Minor MATE 1.18 update.kwm2017-10-153-5/+12 * Remove WANT_GNOME and HAVE_GNOME.mat2017-10-122-2/+0 * 1: Update to 2.6.7.vanilla2017-10-062-5/+6 * New port: x11-themes/sddm-freebsd-black-themetcberner2017-09-286-0/+65 * Remove USES=execinfo.mat2017-09-221-1/+1 * Update KDE Frameworks to 5.38.0tcberner2017-09-196-14/+12 * - Add LICENSEamdmi32017-09-172-1/+4 * - Update to 3.91.2.152nivit2017-09-153-4/+32 * - Add LICENSEamdmi32017-09-142-1/+4 * - Add LICENSEamdmi32017-09-131-1/+4 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-116-4/+6 * - Add LICENSEamdmi32017-09-062-1/+4 * Update KDE Frameworks to 5.37.0tcberner2017-08-295-24/+32 * Remove expired ports:rene2017-08-2313-131/+0 * Move all X cursors from ${PREFIX}/lib/X11/icons to ${PREFIX}/share/iconsbapt2017-08-1730-4448/+4458 * - Add NO_ARCHamdmi32017-07-282-1/+2 * - Update to 3.91.1.7nivit2017-07-232-4/+4 * Deprecate ports BROKEN for more than 6 monthsantoine2017-07-223-0/+6 * Adaptive Gtk+ theme based on Material Design Guidelines.nivit2017-07-216-0/+1275 * A wallpaper collection for adapta-project.nivit2017-07-216-0/+62 * Update KDE Frameworks to 5.36.0tcberner2017-07-126-35/+14 * - Add LICENSEamdmi32017-07-052-6/+7 * Update the mate desktop to 1.18.kwm2017-07-0412-26/+309 * Make ninja opt-out in cmake.mktcberner2017-06-262-2/+2 * Update KDE Frameworks to 5.35tcberner2017-06-186-33/+24 * Drop dependency on eigen3 in x11-themes/kdeartwork4tcberner2017-06-172-5/+4 * Don't use FLAVOR as a variable in ports.mat2017-06-134-8/+8 * Fix qt4 ports on armv6.tcberner2017-06-065-4/+5 * - Mark port as architecture neutralpawel2017-06-011-15/+8 * Update x11-themes/adwaita-qt[45] to 1.0 and take maintainership.tcberner2017-05-304-58/+37 * x11-themes/gnome-icons-elementary: Update to 4.1.0woodsb022017-05-293-54/+292 * Revision bump of all ports with USE_GL after consolidation of mesa-libsrezny2017-05-232-0/+2 * Update KDE Frameworks to 5.34.0tcberner2017-05-206-12/+25 * Add new port x11-themes/xfce-icons-elementary.woodsb022017-05-095-0/+13240 * Drop the GH_TAGNAME so the actualy release that we want is downloaded.kwm2017-04-263-1077/+1122 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-2514-10/+14 * Update the gtk+ stack [1]kwm2017-04-2317-465/+464 * Update KDE Frameworks to 5.33.0tcberner2017-04-19