aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libsearpc/Makefile2
-rw-r--r--net-mgmt/seafile-gui/Makefile9
-rw-r--r--net-mgmt/seafile-gui/distinfo5
-rw-r--r--net-mgmt/seafile/Makefile10
-rw-r--r--www/libevhtp/Makefile9
-rw-r--r--www/libevhtp/pkg-plist2
6 files changed, 21 insertions, 16 deletions
diff --git a/devel/libsearpc/Makefile b/devel/libsearpc/Makefile
index 105ee1736a40..d56d91e3a89c 100644
--- a/devel/libsearpc/Makefile
+++ b/devel/libsearpc/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= haiwen
GH_TAGNAME= v3.0-latest
-USES= autoreconf libtool pathfix pkgconfig python:2
+USES= autoreconf gettext libtool pathfix pkgconfig python:2
USE_LDCONFIG= yes
PATHFIX_MAKEFILEIN= Makefile.am
diff --git a/net-mgmt/seafile-gui/Makefile b/net-mgmt/seafile-gui/Makefile
index 956cd19878f6..9494332fba4f 100644
--- a/net-mgmt/seafile-gui/Makefile
+++ b/net-mgmt/seafile-gui/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= seafile-gui
-PORTVERSION= 5.1.1
+PORTVERSION= 5.1.2
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt devel
@@ -16,13 +16,16 @@ LIB_DEPENDS= libglib-2.0.so:devel/glib20 \
libseafile.so:net-mgmt/seafile \
libsqlite3.so:databases/sqlite3 \
libccnet.so:net-mgmt/ccnet \
- libjansson.so:devel/jansson
+ libjansson.so:devel/jansson \
+ libevent.so:devel/libevent2 \
+ libuuid.so:misc/e2fsprogs-libuuid
USE_GITHUB= yes
GH_ACCOUNT= haiwen
GH_PROJECT= seafile-client
+GH_TAGNAME= 1a63e1f
-USES= compiler:c++11-lang cmake pkgconfig shebangfix
+USES= compiler:c++11-lang cmake gettext pkgconfig shebangfix
SHEBANG_FILES= extensions/*.sh scripts/*.sh fsplugin/*.sh \
scripts/*.py
USE_OPENSSL= yes
diff --git a/net-mgmt/seafile-gui/distinfo b/net-mgmt/seafile-gui/distinfo
index f0345d0d6ae3..111eb87f58f3 100644
--- a/net-mgmt/seafile-gui/distinfo
+++ b/net-mgmt/seafile-gui/distinfo
@@ -1,2 +1,3 @@
-SHA256 (haiwen-seafile-client-v5.1.1_GH0.tar.gz) = 0148cbdb97dcd58e6ebec738c8f6bc476192f0b9156f0783199f1213c4d0322f
-SIZE (haiwen-seafile-client-v5.1.1_GH0.tar.gz) = 2123048
+TIMESTAMP = 1465610426
+SHA256 (haiwen-seafile-client-v5.1.2-1a63e1f_GH0.tar.gz) = 1f4935a3a5384db04cf8d4d8209bfc9104f5ae7e33ca7dacd883bfccc7633fbc
+SIZE (haiwen-seafile-client-v5.1.2-1a63e1f_GH0.tar.gz) = 2129747
diff --git a/net-mgmt/seafile/Makefile b/net-mgmt/seafile/Makefile
index fa0411297f3a..458bb0fd117c 100644
--- a/net-mgmt/seafile/Makefile
+++ b/net-mgmt/seafile/Makefile
@@ -18,15 +18,19 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libzdb.so:databases/libzdb \
libcurl.so:ftp/curl \
libinotify.so:devel/libinotify \
- libccnet.so:net-mgmt/ccnet
+ libccnet.so:net-mgmt/ccnet \
+ libevent.so:devel/libevent2 \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libjansson.so:devel/jansson
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
bash:shells/bash
USE_GITHUB= yes
GH_ACCOUNT= haiwen
-USES= autoreconf iconv libarchive libtool mysql pathfix pkgconfig python:-2.7 \
- shebangfix
+USES= autoreconf gettext iconv libarchive libtool mysql pathfix \
+ pkgconfig python:-2.7 shebangfix sqlite
+USE_GNOME= glib20
SHEBANG_FILES= scripts/*.sh scripts/upgrade/*.sh tests/*.py tests/basic/*.sh \
tests/sync-auto-test/*.template *.sh scripts/build/*.py \
scripts/*.py *.py scripts/upgrade/*.py app/seaf-cli \
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
index 5e14f667e642..1de42deeb743 100644
--- a/www/libevhtp/Makefile
+++ b/www/libevhtp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libevhtp
PORTVERSION= 1.2.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= ultima1252@gmail.com
@@ -23,17 +23,14 @@ CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:PATH=include/event2 \
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= SSL THREADS REGEX STATIC DEBUG
-OPTIONS_DEFAULT=SSL THREADS REGEX
+OPTIONS_DEFINE= SSL THREADS STATIC DEBUG
+OPTIONS_DEFAULT=SSL THREADS
OPTIONS_SUB= yes
SSL_CMAKE_ON= -DEVHTP_DISABLE_SSL:STRING=OFF
SSL_CMAKE_OFF= -DEVHTP_DISABLE_SSL:STRING=ON
THREADS_CMAKE_ON= -DEVHTP_DISABLE_EVTHR:STRING=OFF
THREADS_CMAKE_OFF= -DEVHTP_DISABLE_EVTHR:STRING=ON
-REGEX_CMAKE_ON= -DEVHTP_DISABLE_REGEX:STRING=OFF
-REGEX_CMAKE_OFF= -DEVHTP_DISABLE_REGEX:STRING=ON
-REGEX_DESC= Enable regex support
STATIC_CMAKE_ON= -DEVHTP_BUILD_SHARED:STRING=OFF
STATIC_CMAKE_OFF= -DEVHTP_BUILD_SHARED:STRING=ON
diff --git a/www/libevhtp/pkg-plist b/www/libevhtp/pkg-plist
index 33893074e31c..ec47131ac1d1 100644
--- a/www/libevhtp/pkg-plist
+++ b/www/libevhtp/pkg-plist
@@ -4,6 +4,6 @@ include/evhtp/htparse.h
libdata/pkgconfig/evhtp.pc
%%NO_STATIC%%lib/libevhtp.so
%%NO_STATIC%%lib/libevhtp.so.%%PORTVERSION%%
-%%REGEX%%include/evhtp/onigposix.h
+include/evhtp/onigposix.h
%%THREADS%%include/evhtp/evthr.h
%%STATIC%%lib/libevhtp.a