aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--games/Makefile2
-rw-r--r--games/deng/Makefile59
-rw-r--r--games/deng/distinfo2
-rw-r--r--games/deng/files/patch-gl_png.c10
-rw-r--r--games/deng/pkg-plist27
-rw-r--r--games/doomsday/Makefile49
-rw-r--r--games/doomsday/distinfo2
-rw-r--r--games/doomsday/files/patch-doomsday-dep__zlib.pri13
-rw-r--r--games/doomsday/pkg-descr (renamed from games/deng/pkg-descr)0
-rw-r--r--games/doomsday/pkg-message7
-rw-r--r--games/doomsday/pkg-plist87
12 files changed, 160 insertions, 99 deletions
diff --git a/MOVED b/MOVED
index e6d34776a2fe..f939465f894c 100644
--- a/MOVED
+++ b/MOVED
@@ -5376,3 +5376,4 @@ archivers/xz||2014-01-12|Included in base system on all supported releases
lang/python26|lang/python27|2014-01-13|Python 2.6 is now end-of-life, please migrate to lang/python27
sysutils/lavaps||2014-01-14|Abandonware, segfaults
www/mod_authnz_external|www/mod_authnz_external22|2014-01-14|Port was renamed to reflect the supported Apache version
+games/deng|games/doomsday|2014-01-16|Renamed to follow upstream naming
diff --git a/games/Makefile b/games/Makefile
index 5d8335a7f83d..29d41efa733c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -187,7 +187,6 @@
SUBDIR += dcross
SUBDIR += deal
SUBDIR += defendguin
- SUBDIR += deng
SUBDIR += diameter
SUBDIR += digger-vgl
SUBDIR += djgame2
@@ -203,6 +202,7 @@
SUBDIR += doom-hr2
SUBDIR += doom-wolfendoom
SUBDIR += doomlegacy
+ SUBDIR += doomsday
SUBDIR += dopewars
SUBDIR += drcreep
SUBDIR += drm
diff --git a/games/deng/Makefile b/games/deng/Makefile
deleted file mode 100644
index 48528d06b1dd..000000000000
--- a/games/deng/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# Created by: Igor Pokrovsky <ip@doom.homeunix.org>
-# $FreeBSD$
-
-PORTNAME= deng
-PORTVERSION= 1.9.0b6.9
-PORTREVISION= 3
-CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Doomsday%20Engine/1.9.0-beta6.9
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/-beta/}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Enhanced Doom, Heretic, and Hexen source port
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libpng15.so:${PORTSDIR}/graphics/png
-RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
-
-USE_GL= gl glu
-USE_LDCONFIG= yes
-USE_SDL= sdl mixer net
-USE_XORG= x11
-USE_PYTHON= yes
-USES= cmake:outsource
-CMAKE_SOURCE_PATH= ${WRKSRC}/doomsday
-CFLAGS+= -I${LOCALBASE}/include/libpng15
-CMAKE_ARGS+= -DCMAKE_EXE_LINKER_FLAGS:STRING="-Wl,--export-dynamic"
-LDFLAGS+= -lm
-
-OPTIONS_DEFINE= OPENAL DOCS
-OPTIONS_DEFAULT= DOCS
-OPENAL_DESC= Build OpenAL sound plugin
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENAL}
-USES+= openal:al
-CMAKE_ARGS+= -DBUILDOPENAL:BOOL=ON
-PLIST_SUB= OPENAL=""
-.else
-CMAKE_ARGS+= -DBUILDOPENAL:BOOL=OFF
-PLIST_SUB= OPENAL="@comment "
-.endif
-
-post-patch:
- ${REINPLACE_CMD} \
- -e '/CHECK_LIBRARY_EXIST/s/dl//' \
- -e '/TARGET_LINK_LIBRARIES/s/dl//' \
- ${WRKSRC}/doomsday/CMakeLists.txt
-
-post-install:
- ${LN} -s doomsday ${STAGEDIR}${PREFIX}/bin/deng
- ${INSTALL_MAN} ${WRKSRC}/doomsday/engine/doc/doomsday.6 ${STAGEDIR}${MANPREFIX}/man/man6/
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in LICENSE changelog.txt cnsname.txt cvars.txt deddoc.txt dhistory.txt naming.txt network.txt
- ${INSTALL_DATA} ${WRKSRC}/doomsday/engine/doc/${i} ${STAGEDIR}${DOCSDIR}/
-.endfor
-
-.include <bsd.port.mk>
diff --git a/games/deng/distinfo b/games/deng/distinfo
deleted file mode 100644
index d323be9fe162..000000000000
--- a/games/deng/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (deng-1.9.0-beta6.9.tar.gz) = 3553f6a58660916fdedbe0594f5b22dac4738ee6e02b042992d3140d358954af
-SIZE (deng-1.9.0-beta6.9.tar.gz) = 6085833
diff --git a/games/deng/files/patch-gl_png.c b/games/deng/files/patch-gl_png.c
deleted file mode 100644
index 0d0fb58a0f84..000000000000
--- a/games/deng/files/patch-gl_png.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- doomsday/engine/portable/src/gl_png.c.orig 2010-04-07 22:52:50.000000000 +0200
-+++ doomsday/engine/portable/src/gl_png.c 2012-04-29 06:31:36.000000000 +0200
-@@ -32,6 +32,7 @@
- // HEADER FILES ------------------------------------------------------------
-
- #include <png.h>
-+#include <pngpriv.h>
- #include <setjmp.h>
-
- #include "de_base.h"
diff --git a/games/deng/pkg-plist b/games/deng/pkg-plist
deleted file mode 100644
index 3c7b03bed32c..000000000000
--- a/games/deng/pkg-plist
+++ /dev/null
@@ -1,27 +0,0 @@
-bin/deng
-bin/doomsday
-man/man6/doomsday.6.gz
-lib/libdpdehread.so
-lib/libdpwadmapconverter.so
-%%OPENAL%%lib/libdsopenal.so
-lib/libjdoom.so
-lib/libjheretic.so
-lib/libjhexen.so
-%%DATADIR%%/data/doomsday.pk3
-%%DATADIR%%/data/jdoom/jdoom.pk3
-%%DATADIR%%/data/jheretic/jheretic.pk3
-%%DATADIR%%/data/jhexen/jhexen.pk3
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
-%%PORTDOCS%%%%DOCSDIR%%/cnsname.txt
-%%PORTDOCS%%%%DOCSDIR%%/cvars.txt
-%%PORTDOCS%%%%DOCSDIR%%/deddoc.txt
-%%PORTDOCS%%%%DOCSDIR%%/dhistory.txt
-%%PORTDOCS%%%%DOCSDIR%%/naming.txt
-%%PORTDOCS%%%%DOCSDIR%%/network.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/data/jdoom
-@dirrm %%DATADIR%%/data/jhexen
-@dirrm %%DATADIR%%/data/jheretic
-@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%
diff --git a/games/doomsday/Makefile b/games/doomsday/Makefile
new file mode 100644
index 000000000000..a8f08fceb366
--- /dev/null
+++ b/games/doomsday/Makefile
@@ -0,0 +1,49 @@
+# Created by: Igor Pokrovsky <ip@doom.homeunix.org>
+# $FreeBSD$
+
+PORTNAME= doomsday
+PORTVERSION= 1.12.2
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/Doomsday%20Engine/${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Enhanced Doom, Heretic, and Hexen source port
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libpng15.so:${PORTSDIR}/graphics/png
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+
+USE_GL= gl glu
+USE_LDCONFIG= yes
+USE_SDL= sdl mixer net
+USE_XORG= x11
+USE_PYTHON_BUILD= yes
+USES= pkgconfig qmake:outsource
+USE_QT4= corelib network opengl moc_build
+QMAKE_SOURCE_PATH= ${WRKSRC}/doomsday
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+QMAKE_ARGS+= QMAKE_LFLAGS+="-Wl,--export-dynamic" \
+ CONFIG+="deng_notools deng_nosnowberry" \
+ SCRIPT_PYTHON=${PYTHON_CMD}
+LDFLAGS+= -lm
+
+OPTIONS_DEFINE= OPENAL
+OPTIONS_SUB= yes
+
+OPENAL_DESC= Build OpenAL sound plugin
+OPENAL_USES= openal:al
+OPENAL_QMAKE_ON= CONFIG+=deng_openal
+OPENAL_QMAKE_OFF= CONFIG+=deng_noopenal
+
+post-patch:
+ ${REINPLACE_CMD} 's,share/man,man,' \
+ ${PATCH_WRKSRC}/doomsday/client/client.pro \
+ ${PATCH_WRKSRC}/doomsday/server/server.pro
+ ${REINPLACE_CMD} 's,python,${PYTHON_CMD},' \
+ ${PATCH_WRKSRC}/doomsday/config.pri \
+ ${PATCH_WRKSRC}/doomsday/build/build.pro
+
+.include <bsd.port.mk>
diff --git a/games/doomsday/distinfo b/games/doomsday/distinfo
new file mode 100644
index 000000000000..63a539403c45
--- /dev/null
+++ b/games/doomsday/distinfo
@@ -0,0 +1,2 @@
+SHA256 (doomsday-1.12.2.tar.gz) = a021fd1d7540b43075b0906167c45e82fe698105222613097befdeb793363a4e
+SIZE (doomsday-1.12.2.tar.gz) = 13028633
diff --git a/games/doomsday/files/patch-doomsday-dep__zlib.pri b/games/doomsday/files/patch-doomsday-dep__zlib.pri
new file mode 100644
index 000000000000..7cd8706d6dd2
--- /dev/null
+++ b/games/doomsday/files/patch-doomsday-dep__zlib.pri
@@ -0,0 +1,13 @@
+--- doomsday/dep_zlib.pri.orig 2013-11-02 07:38:18.000000000 -0700
++++ doomsday/dep_zlib.pri 2013-12-24 04:55:18.000000000 -0700
+@@ -12,6 +12,10 @@
+ # Mac OS X.
+ LIBS += -lz
+ }
++else:freebsd-* {
++ # FreeBSD
++ LIBS += -lz
++}
+ else {
+ # Generic Unix.
+ QMAKE_CFLAGS += $$system(pkg-config zlib --cflags)
diff --git a/games/deng/pkg-descr b/games/doomsday/pkg-descr
index d4cf5869663b..d4cf5869663b 100644
--- a/games/deng/pkg-descr
+++ b/games/doomsday/pkg-descr
diff --git a/games/doomsday/pkg-message b/games/doomsday/pkg-message
new file mode 100644
index 000000000000..053966e1835e
--- /dev/null
+++ b/games/doomsday/pkg-message
@@ -0,0 +1,7 @@
+========================================================================
+
+If you use an Intel graphics adapter and experience missing or
+corrupted textures during gameplay, try launching doomsday with the
+"-notexcomp" option.
+
+========================================================================
diff --git a/games/doomsday/pkg-plist b/games/doomsday/pkg-plist
new file mode 100644
index 000000000000..db937121ef3a
--- /dev/null
+++ b/games/doomsday/pkg-plist
@@ -0,0 +1,87 @@
+bin/doomsday
+bin/doomsday-server
+%%OPENAL%%lib/doomsday/libaudio_openal.so
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1.2
+%%OPENAL%%lib/doomsday/libaudio_openal.so.1.2.4
+lib/doomsday/libdehread.so
+lib/doomsday/libdehread.so.2
+lib/doomsday/libdehread.so.2.0
+lib/doomsday/libdehread.so.2.0.0
+lib/doomsday/libdoom.so
+lib/doomsday/libdoom.so.1
+lib/doomsday/libdoom.so.1.12
+lib/doomsday/libdoom.so.1.12.2
+lib/doomsday/libdoom64.so
+lib/doomsday/libdoom64.so.1
+lib/doomsday/libdoom64.so.1.12
+lib/doomsday/libdoom64.so.1.12.2
+lib/doomsday/libexample.so
+lib/doomsday/libexample.so.1
+lib/doomsday/libexample.so.1.2
+lib/doomsday/libexample.so.1.2.0
+lib/doomsday/libheretic.so
+lib/doomsday/libheretic.so.1
+lib/doomsday/libheretic.so.1.12
+lib/doomsday/libheretic.so.1.12.2
+lib/doomsday/libhexen.so
+lib/doomsday/libhexen.so.1
+lib/doomsday/libhexen.so.1.12
+lib/doomsday/libhexen.so.1.12.2
+lib/doomsday/libwadmapconverter.so
+lib/doomsday/libwadmapconverter.so.1
+lib/doomsday/libwadmapconverter.so.1.1
+lib/doomsday/libwadmapconverter.so.1.1.0
+lib/libdeng1.so
+lib/libdeng1.so.1
+lib/libdeng1.so.1.12
+lib/libdeng1.so.1.12.2
+lib/libdeng2.so
+lib/libdeng2.so.2
+lib/libdeng2.so.2.0
+lib/libdeng2.so.2.0.0
+lib/libdeng_gui.so
+lib/libdeng_gui.so.1
+lib/libdeng_gui.so.1.12
+lib/libdeng_gui.so.1.12.2
+lib/libdeng_shell.so
+lib/libdeng_shell.so.0
+lib/libdeng_shell.so.0.1
+lib/libdeng_shell.so.0.1.0
+man/man6/doomsday.6.gz
+%%DATADIR%%/data/doomsday.pk3
+%%DATADIR%%/data/fonts/console11.dfn
+%%DATADIR%%/data/fonts/console14.dfn
+%%DATADIR%%/data/fonts/console18.dfn
+%%DATADIR%%/data/fonts/normal12.dfn
+%%DATADIR%%/data/fonts/normal18.dfn
+%%DATADIR%%/data/fonts/normal24.dfn
+%%DATADIR%%/data/fonts/normalbold12.dfn
+%%DATADIR%%/data/fonts/normalbold18.dfn
+%%DATADIR%%/data/fonts/normalbold24.dfn
+%%DATADIR%%/data/fonts/normallight12.dfn
+%%DATADIR%%/data/fonts/normallight18.dfn
+%%DATADIR%%/data/fonts/normallight24.dfn
+%%DATADIR%%/data/graphics/background.pcx
+%%DATADIR%%/data/graphics/loading1.png
+%%DATADIR%%/data/graphics/loading2.png
+%%DATADIR%%/data/graphics/logo.png
+%%DATADIR%%/data/jdoom/libdoom.pk3
+%%DATADIR%%/data/jdoom64/libdoom64.pk3
+%%DATADIR%%/data/jheretic/libheretic.pk3
+%%DATADIR%%/data/jhexen/libhexen.pk3
+%%DATADIR%%/modules/Config.de
+%%DATADIR%%/modules/appconfig.de
+%%DATADIR%%/modules/bootstrap.de
+%%DATADIR%%/modules/gui.de
+%%DATADIR%%/modules/recutil.de
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%/data/jhexen
+@dirrm %%DATADIR%%/data/jheretic
+@dirrm %%DATADIR%%/data/jdoom64
+@dirrm %%DATADIR%%/data/jdoom
+@dirrm %%DATADIR%%/data/graphics
+@dirrm %%DATADIR%%/data/fonts
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm lib/doomsday