aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/c2hs/Makefile23
-rw-r--r--devel/c2hs/distinfo1
-rw-r--r--devel/c2hs/pkg-comment1
-rw-r--r--devel/c2hs/pkg-descr13
-rw-r--r--devel/c2hs/pkg-plist15
-rw-r--r--devel/hs-c2hs/Makefile23
-rw-r--r--devel/hs-c2hs/distinfo1
-rw-r--r--devel/hs-c2hs/pkg-comment1
-rw-r--r--devel/hs-c2hs/pkg-descr13
-rw-r--r--devel/hs-c2hs/pkg-plist15
11 files changed, 107 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 869c37e89547..72a95869675b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -68,6 +68,7 @@
SUBDIR += bugbuddy2
SUBDIR += bugzilla
SUBDIR += byaccj
+ SUBDIR += c2hs
SUBDIR += c2lib
SUBDIR += c2man
SUBDIR += c4
diff --git a/devel/c2hs/Makefile b/devel/c2hs/Makefile
new file mode 100644
index 000000000000..91d90f1c8601
--- /dev/null
+++ b/devel/c2hs/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: c2hs
+# Date created: 23 August 2002
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= c2hs
+PORTVERSION= 0.10.15
+CATEGORIES= devel
+MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
+
+MAINTAINER= obraun@FreeBSD.org
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-add-package
+
+.include <bsd.port.mk>
diff --git a/devel/c2hs/distinfo b/devel/c2hs/distinfo
new file mode 100644
index 000000000000..6ad2a8c7f15b
--- /dev/null
+++ b/devel/c2hs/distinfo
@@ -0,0 +1 @@
+MD5 (c2hs-0.10.15.tar.gz) = 30f8163d43716f775aa633d6e461a24f
diff --git a/devel/c2hs/pkg-comment b/devel/c2hs/pkg-comment
new file mode 100644
index 000000000000..97646c051237
--- /dev/null
+++ b/devel/c2hs/pkg-comment
@@ -0,0 +1 @@
+C->Haskell, an Interface Generator for Haskell
diff --git a/devel/c2hs/pkg-descr b/devel/c2hs/pkg-descr
new file mode 100644
index 000000000000..0dae83c1c040
--- /dev/null
+++ b/devel/c2hs/pkg-descr
@@ -0,0 +1,13 @@
+C->Haskell is an interface generator that simplifies the development of Haskell
+bindings to C libraries. The tool processes existing C header files that
+determine data layout and function signatures on the C side in conjunction with
+Haskell modules that specify Haskell-side type signatures and marshaling
+details. Hooks embedded in the Haskell code signal access to C structures and
+functions -- they are expanded by the interfacing tool in dependence on
+information from the corresponding C header file. Another noteworthy property
+is the lightweight nature of the approach.
+
+WWW: http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
+
+-- Oliver Braun
+obraun@FreeBSD.org
diff --git a/devel/c2hs/pkg-plist b/devel/c2hs/pkg-plist
new file mode 100644
index 000000000000..b4d2d3abb6cd
--- /dev/null
+++ b/devel/c2hs/pkg-plist
@@ -0,0 +1,15 @@
+bin/c2hs
+bin/c2hs-config
+lib/c2hs-0.10.15/ghc5/c2hs.conf
+lib/c2hs-0.10.15/ghc5/import/C2HS.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSBase.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSDeprecated.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSMarsh.hi
+lib/c2hs-0.10.15/ghc5/import/NewStablePtr.hi
+lib/c2hs-0.10.15/ghc5/import/NewStorable.hi
+lib/c2hs-0.10.15/ghc5/libc2hs.a
+@dirrm lib/c2hs-0.10.15/ghc5/import
+@dirrm lib/c2hs-0.10.15/ghc5
+@dirrm lib/c2hs-0.10.15
+@exec %D/bin/c2hs-config --package-conf | %D/bin/ghc-pkg -a
+@unexec %D/bin/ghc-pkg -r c2hs
diff --git a/devel/hs-c2hs/Makefile b/devel/hs-c2hs/Makefile
new file mode 100644
index 000000000000..91d90f1c8601
--- /dev/null
+++ b/devel/hs-c2hs/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: c2hs
+# Date created: 23 August 2002
+# Whom: Oliver Braun <obraun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= c2hs
+PORTVERSION= 0.10.15
+CATEGORIES= devel
+MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
+
+MAINTAINER= obraun@FreeBSD.org
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-add-package
+
+.include <bsd.port.mk>
diff --git a/devel/hs-c2hs/distinfo b/devel/hs-c2hs/distinfo
new file mode 100644
index 000000000000..6ad2a8c7f15b
--- /dev/null
+++ b/devel/hs-c2hs/distinfo
@@ -0,0 +1 @@
+MD5 (c2hs-0.10.15.tar.gz) = 30f8163d43716f775aa633d6e461a24f
diff --git a/devel/hs-c2hs/pkg-comment b/devel/hs-c2hs/pkg-comment
new file mode 100644
index 000000000000..97646c051237
--- /dev/null
+++ b/devel/hs-c2hs/pkg-comment
@@ -0,0 +1 @@
+C->Haskell, an Interface Generator for Haskell
diff --git a/devel/hs-c2hs/pkg-descr b/devel/hs-c2hs/pkg-descr
new file mode 100644
index 000000000000..0dae83c1c040
--- /dev/null
+++ b/devel/hs-c2hs/pkg-descr
@@ -0,0 +1,13 @@
+C->Haskell is an interface generator that simplifies the development of Haskell
+bindings to C libraries. The tool processes existing C header files that
+determine data layout and function signatures on the C side in conjunction with
+Haskell modules that specify Haskell-side type signatures and marshaling
+details. Hooks embedded in the Haskell code signal access to C structures and
+functions -- they are expanded by the interfacing tool in dependence on
+information from the corresponding C header file. Another noteworthy property
+is the lightweight nature of the approach.
+
+WWW: http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
+
+-- Oliver Braun
+obraun@FreeBSD.org
diff --git a/devel/hs-c2hs/pkg-plist b/devel/hs-c2hs/pkg-plist
new file mode 100644
index 000000000000..b4d2d3abb6cd
--- /dev/null
+++ b/devel/hs-c2hs/pkg-plist
@@ -0,0 +1,15 @@
+bin/c2hs
+bin/c2hs-config
+lib/c2hs-0.10.15/ghc5/c2hs.conf
+lib/c2hs-0.10.15/ghc5/import/C2HS.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSBase.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSDeprecated.hi
+lib/c2hs-0.10.15/ghc5/import/C2HSMarsh.hi
+lib/c2hs-0.10.15/ghc5/import/NewStablePtr.hi
+lib/c2hs-0.10.15/ghc5/import/NewStorable.hi
+lib/c2hs-0.10.15/ghc5/libc2hs.a
+@dirrm lib/c2hs-0.10.15/ghc5/import
+@dirrm lib/c2hs-0.10.15/ghc5
+@dirrm lib/c2hs-0.10.15
+@exec %D/bin/c2hs-config --package-conf | %D/bin/ghc-pkg -a
+@unexec %D/bin/ghc-pkg -r c2hs