aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/valknut/Makefile13
-rw-r--r--net-p2p/valknut/distinfo2
-rw-r--r--net/dcgui/Makefile13
-rw-r--r--net/dcgui/distinfo2
-rw-r--r--net/valknut/Makefile13
-rw-r--r--net/valknut/distinfo2
6 files changed, 30 insertions, 15 deletions
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index c874814e659e..2a9a39e746e9 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dcgui
-PORTVERSION= 0.1.9
+PORTVERSION= 0.1.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
@@ -15,7 +15,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
http://dc.ketelhot.de/files/dcgui/unstable/source/
MASTER_SITE_SUBDIR= dc-gui
-DISTNAME= dcgui-0.1beta9
+DISTNAME= dcgui-0.1beta11
MAINTAINER= e96sv@yahoo.se
@@ -29,10 +29,15 @@ USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
- --with-xml-prefix=${LOCALBASE}
+ --with-xml-prefix=${LOCALBASE} \
+ --program-prefix=
post-patch:
- @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@' \
+# Fix libxml2 test
+# And, do not add optimizations because it might break some ARCHs, e.g.,
+# alpha
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@; \
+ s@-O2@@' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/net-p2p/valknut/distinfo b/net-p2p/valknut/distinfo
index cc800aa0ad97..c062f4c25cc4 100644
--- a/net-p2p/valknut/distinfo
+++ b/net-p2p/valknut/distinfo
@@ -1 +1 @@
-MD5 (dcgui-0.1beta9.tar.bz2) = 33277a01afbe38d8824042c7c8c357cd
+MD5 (dcgui-0.1beta11.tar.bz2) = 0487c67a4a205fb1846df19d611b1aee
diff --git a/net/dcgui/Makefile b/net/dcgui/Makefile
index c874814e659e..2a9a39e746e9 100644
--- a/net/dcgui/Makefile
+++ b/net/dcgui/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dcgui
-PORTVERSION= 0.1.9
+PORTVERSION= 0.1.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
@@ -15,7 +15,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
http://dc.ketelhot.de/files/dcgui/unstable/source/
MASTER_SITE_SUBDIR= dc-gui
-DISTNAME= dcgui-0.1beta9
+DISTNAME= dcgui-0.1beta11
MAINTAINER= e96sv@yahoo.se
@@ -29,10 +29,15 @@ USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
- --with-xml-prefix=${LOCALBASE}
+ --with-xml-prefix=${LOCALBASE} \
+ --program-prefix=
post-patch:
- @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@' \
+# Fix libxml2 test
+# And, do not add optimizations because it might break some ARCHs, e.g.,
+# alpha
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@; \
+ s@-O2@@' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/net/dcgui/distinfo b/net/dcgui/distinfo
index cc800aa0ad97..c062f4c25cc4 100644
--- a/net/dcgui/distinfo
+++ b/net/dcgui/distinfo
@@ -1 +1 @@
-MD5 (dcgui-0.1beta9.tar.bz2) = 33277a01afbe38d8824042c7c8c357cd
+MD5 (dcgui-0.1beta11.tar.bz2) = 0487c67a4a205fb1846df19d611b1aee
diff --git a/net/valknut/Makefile b/net/valknut/Makefile
index c874814e659e..2a9a39e746e9 100644
--- a/net/valknut/Makefile
+++ b/net/valknut/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dcgui
-PORTVERSION= 0.1.9
+PORTVERSION= 0.1.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
@@ -15,7 +15,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
http://dc.ketelhot.de/files/dcgui/unstable/source/
MASTER_SITE_SUBDIR= dc-gui
-DISTNAME= dcgui-0.1beta9
+DISTNAME= dcgui-0.1beta11
MAINTAINER= e96sv@yahoo.se
@@ -29,10 +29,15 @@ USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
- --with-xml-prefix=${LOCALBASE}
+ --with-xml-prefix=${LOCALBASE} \
+ --program-prefix=
post-patch:
- @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@' \
+# Fix libxml2 test
+# And, do not add optimizations because it might break some ARCHs, e.g.,
+# alpha
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@; \
+ s@-O2@@' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/net/valknut/distinfo b/net/valknut/distinfo
index cc800aa0ad97..c062f4c25cc4 100644
--- a/net/valknut/distinfo
+++ b/net/valknut/distinfo
@@ -1 +1 @@
-MD5 (dcgui-0.1beta9.tar.bz2) = 33277a01afbe38d8824042c7c8c357cd
+MD5 (dcgui-0.1beta11.tar.bz2) = 0487c67a4a205fb1846df19d611b1aee