aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/rmilter/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/mail/rmilter/Makefile b/mail/rmilter/Makefile
index 355134b8efa2..48889142f865 100644
--- a/mail/rmilter/Makefile
+++ b/mail/rmilter/Makefile
@@ -31,14 +31,8 @@ CONFIGURE_ARGS+= --enable-debug
CONFIGURE_ARGS+= --enable-sendmail
.endif
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
-
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-IGNORE= using libspf2 requires a thread safe resolver
-.else
-LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
-.endif
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre \
+ spf2.3:${PORTSDIR}/mail/libspf2
CFLAGS+= ${PTHREAD_CFLAGS}
LIBS+= ${PTHREAD_LIBS}
@@ -53,4 +47,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/rmilter.conf.sample ${PREFIX}/etc/
${INSTALL_MAN} ${WRKSRC}/rmilter.8 ${MAN8PREFIX}/man/man8/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>