aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/openhantek/Makefile2
-rw-r--r--misc/openhantek/distinfo6
-rw-r--r--misc/openhantek/files/patch-openhantek_src_usb_uploadFirmware.cpp12
3 files changed, 4 insertions, 16 deletions
diff --git a/misc/openhantek/Makefile b/misc/openhantek/Makefile
index 2f11f7f14854..3e8cf382dce2 100644
--- a/misc/openhantek/Makefile
+++ b/misc/openhantek/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= openhantek
-DISTVERSION= 3.0.0
+DISTVERSION= 3.0.1
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/openhantek/distinfo b/misc/openhantek/distinfo
index 43bf64592aea..9b255443fca2 100644
--- a/misc/openhantek/distinfo
+++ b/misc/openhantek/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1574309115
-SHA256 (OpenHantek-OpenHantek6022-3.0.0_GH0.tar.gz) = 7c756a6d3861b08a48a15fe14f633018c7ce8fba2f6a4961d5b403144f71f9e9
-SIZE (OpenHantek-OpenHantek6022-3.0.0_GH0.tar.gz) = 19666574
+TIMESTAMP = 1576305230
+SHA256 (OpenHantek-OpenHantek6022-3.0.1_GH0.tar.gz) = 6f0cf2a93393a06ae5df4617d4346871bb49b07feedb6a94e44fc726e2c453ad
+SIZE (OpenHantek-OpenHantek6022-3.0.1_GH0.tar.gz) = 20149936
diff --git a/misc/openhantek/files/patch-openhantek_src_usb_uploadFirmware.cpp b/misc/openhantek/files/patch-openhantek_src_usb_uploadFirmware.cpp
deleted file mode 100644
index 35d738bbc457..000000000000
--- a/misc/openhantek/files/patch-openhantek_src_usb_uploadFirmware.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- openhantek/src/usb/uploadFirmware.cpp.orig 2019-11-21 06:06:23 UTC
-+++ openhantek/src/usb/uploadFirmware.cpp
-@@ -39,7 +39,9 @@ bool UploadFirmware::startUpload(USBDevice *device) {
- temp_firmware_path->open();
-
- /* We need to claim the first interface */
-+#if !defined(__FreeBSD__)
- libusb_set_auto_detach_kernel_driver(handle, 1);
-+#endif
- int status = libusb_claim_interface(handle, 0);
- if (status != LIBUSB_SUCCESS) {
- errorMessage = TR("libusb_claim_interface() failed: %1").arg(libusb_error_name(status));