aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-DataCash/Makefile26
-rw-r--r--misc/p5-DataCash/distinfo1
-rw-r--r--misc/p5-DataCash/pkg-comment1
-rw-r--r--misc/p5-DataCash/pkg-descr3
-rw-r--r--misc/p5-DataCash/pkg-plist9
6 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 58583f2c5eb1..d728e3f19890 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -126,6 +126,7 @@
SUBDIR += orville-write
SUBDIR += p5-Array-PrintCols
SUBDIR += p5-Business-CreditCard
+ SUBDIR += p5-DataCash
SUBDIR += p5-File-CounterFile
SUBDIR += p5-Finance-Quote
SUBDIR += p5-Geo-Weather
diff --git a/misc/p5-DataCash/Makefile b/misc/p5-DataCash/Makefile
new file mode 100644
index 000000000000..bab618be015c
--- /dev/null
+++ b/misc/p5-DataCash/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: DataCash-External
+# Date created: 10 August 2001
+# Whom: Mark Murray <markm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DataCash-External
+PORTVERSION= 2.9.0
+CATEGORIES= misc perl5
+MASTER_SITES= http://www.datacash.com/stronghold/perl/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markm@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Text/CSV.pm:${PORTSDIR}/devel/p5-Text-CSV
+
+PERL_CONFIGURE= yes
+
+MAN3= CCCheck.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/misc/p5-DataCash/distinfo b/misc/p5-DataCash/distinfo
new file mode 100644
index 000000000000..e77b77cd736b
--- /dev/null
+++ b/misc/p5-DataCash/distinfo
@@ -0,0 +1 @@
+MD5 (DataCash-External-2.9.0.tar.gz) = d78c1a8987c31716bf043b55ccc84855
diff --git a/misc/p5-DataCash/pkg-comment b/misc/p5-DataCash/pkg-comment
new file mode 100644
index 000000000000..7056e4e7eec1
--- /dev/null
+++ b/misc/p5-DataCash/pkg-comment
@@ -0,0 +1 @@
+Online credit card transactions
diff --git a/misc/p5-DataCash/pkg-descr b/misc/p5-DataCash/pkg-descr
new file mode 100644
index 000000000000..27b124240ed4
--- /dev/null
+++ b/misc/p5-DataCash/pkg-descr
@@ -0,0 +1,3 @@
+Online credit card transactions
+
+WWW: http://www.datacash.com
diff --git a/misc/p5-DataCash/pkg-plist b/misc/p5-DataCash/pkg-plist
new file mode 100644
index 000000000000..ed659bd39591
--- /dev/null
+++ b/misc/p5-DataCash/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DataCash/External/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/CCCheck.pm
+lib/perl5/site_perl/%%PERL_VER%%/CCCheck/visa.db
+lib/perl5/site_perl/%%PERL_VER%%/CCCheck/mastercard.db
+lib/perl5/site_perl/%%PERL_VER%%/DataCash/datacash.pl
+@dirrm lib/perl5/site_perl/5.6.0/mach/auto/DataCash/External
+@dirrm lib/perl5/site_perl/5.6.0/mach/auto/DataCash
+@dirrm lib/perl5/site_perl/5.6.0/CCCheck
+@dirrm lib/perl5/site_perl/5.6.0/DataCash