aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--cad/Makefile1
-rw-r--r--cad/leocad/Makefile34
-rw-r--r--cad/leocad/distinfo3
-rw-r--r--cad/leocad/files/patch-common_lc__application.cpp16
-rw-r--r--cad/leocad/files/patch-leocad.pro11
-rw-r--r--cad/leocad/pkg-descr14
7 files changed, 79 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 8a1d76b54e4d..c4d21371f418 100644
--- a/MOVED
+++ b/MOVED
@@ -11700,7 +11700,6 @@ audio/qmpdclient||2019-03-16|Has expired: Qt4 has been EOL since december 2015
audio/skype-call-recorder||2019-03-16|Has expired: Qt4 has been EOL since december 2015
biology/clustalx||2019-03-16|Has expired: Qt4 has been EOL since december 2015
cad/layouteditor||2019-03-16|Has expired: Qt4 has been EOL since december 2015
-cad/leocad||2019-03-16|Has expired: Qt4 has been EOL since december 2015
cad/meshlab||2019-03-16|Has expired: Qt4 has been EOL since december 2015
cad/qfsm||2019-03-16|Has expired: Qt4 has been EOL since december 2015
cad/qucs||2019-03-16|Has expired: Qt4 has been EOL since december 2015
diff --git a/cad/Makefile b/cad/Makefile
index 8cbf6effeaa8..d69de80bfeef 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -55,6 +55,7 @@
SUBDIR += kicad-library-templates-devel
SUBDIR += klayout
SUBDIR += ldraw
+ SUBDIR += leocad
SUBDIR += lepton-eda
SUBDIR += libopencad
SUBDIR += librecad
diff --git a/cad/leocad/Makefile b/cad/leocad/Makefile
new file mode 100644
index 000000000000..5aaa81a8b764
--- /dev/null
+++ b/cad/leocad/Makefile
@@ -0,0 +1,34 @@
+# Created by: David Yeske <dyeske@gmail.com>
+# $FreeBSD$
+
+PORTNAME= leocad
+DISTVERSIONPREFIX= v
+DISTVERSION= 18.02.20190517
+CATEGORIES= cad
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Qt-based GDS2 Viewer
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/docs/COPYING.txt
+
+RUN_DEPENDS= ldraw>0:cad/ldraw
+
+USES= compiler:c++11-lang desktop-file-utils gl qmake qt:5 shared-mime-info
+USE_GITHUB= yes
+GH_ACCOUNT= leozide
+GH_TAGNAME= f392e3c
+USE_QT= core gui concurrent network opengl printsupport widgets xml buildtools_build linguisttools_build
+USE_GL= gl
+
+QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} MAN_DIR=${PREFIX}/man/man1 LDRAW_LIBRARY_PATH=${PREFIX}/share/ldraw
+
+PLIST_FILES= bin/leocad \
+ share/applications/leocad.desktop \
+ share/icons/hicolor/scalable/mimetypes/application-vnd.leocad.svg \
+ man/man1/leocad.1.gz \
+ share/metainfo/leocad.appdata.xml \
+ share/mime/packages/leocad.xml \
+ share/pixmaps/leocad.png
+
+.include <bsd.port.mk>
diff --git a/cad/leocad/distinfo b/cad/leocad/distinfo
new file mode 100644
index 000000000000..976b5fc31b33
--- /dev/null
+++ b/cad/leocad/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558142272
+SHA256 (leozide-leocad-v18.02.20190517-f392e3c_GH0.tar.gz) = 7b22858cbed34914b0100be7e3bfb4bd34e069dd7b57a99854482ffbefc1db0a
+SIZE (leozide-leocad-v18.02.20190517-f392e3c_GH0.tar.gz) = 5289474
diff --git a/cad/leocad/files/patch-common_lc__application.cpp b/cad/leocad/files/patch-common_lc__application.cpp
new file mode 100644
index 000000000000..be2c2ef04f32
--- /dev/null
+++ b/cad/leocad/files/patch-common_lc__application.cpp
@@ -0,0 +1,16 @@
+Remove the embedded build date and fix build with Clang 6
+
+common/lc_application.cpp:209:23: error: no matching literal operator for call to 'operator""__DATE__' with arguments of types 'const char *' and 'unsigned int', and no matching literal operator template
+ printf("Compiled "__DATE__"\n");
+ ^
+
+--- common/lc_application.cpp.orig 2019-05-17 23:24:38 UTC
++++ common/lc_application.cpp
+@@ -375,7 +375,6 @@ bool lcApplication::Initialize(QList<QPair<QString, bo
+ printf("LeoCAD Version " LC_VERSION_TEXT "\n");
+ #endif
+ printf("LeoCAD Version " LC_VERSION_TEXT "\n");
+- printf("Compiled " __DATE__ "\n");
+
+ ShowWindow = false;
+ return true;
diff --git a/cad/leocad/files/patch-leocad.pro b/cad/leocad/files/patch-leocad.pro
new file mode 100644
index 000000000000..c79bf140bf0e
--- /dev/null
+++ b/cad/leocad/files/patch-leocad.pro
@@ -0,0 +1,11 @@
+--- leocad.pro.orig 2019-05-18 01:23:33 UTC
++++ leocad.pro
+@@ -108,7 +108,7 @@ unix:!macx {
+
+ target.path = $$BIN_DIR
+ docs.path = $$DOCS_DIR
+- docs.files = docs/README.txt docs/CREDITS.txt docs/COPYING.txt
++ docs.files =
+ man.path = $$MAN_DIR
+ man.files = docs/leocad.1
+ desktop.path = $$DESKTOP_DIR
diff --git a/cad/leocad/pkg-descr b/cad/leocad/pkg-descr
new file mode 100644
index 000000000000..d983c059f6f2
--- /dev/null
+++ b/cad/leocad/pkg-descr
@@ -0,0 +1,14 @@
+LeoCAD is a CAD program that can be used to create virtual LEGO models.
+
+LeoCAD has an intuitive interface that is designed to allow new users to start
+creating new models without having to spend too much time learning the
+application.
+
+LeoCAD is fully compatible with the LDraw Standard and related tools, and it
+reads and writes LDR and MPD files so that you can share and download models
+from the Internet.
+
+It currently features several thousand different pieces created by the LDraw
+community.
+
+WWW: https://www.leocad.org/