aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/bless/Makefile1
-rw-r--r--mail/gmime2-sharp/Makefile6
-rw-r--r--multimedia/gnome-subtitles/Makefile10
-rw-r--r--net/avahi-sharp/Makefile4
-rw-r--r--www/gecko-sharp20/Makefile3
-rw-r--r--www/xsp/Makefile6
-rw-r--r--x11-toolkits/gnome-desktop-sharp20/Makefile3
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp10/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile7
10 files changed, 14 insertions, 32 deletions
diff --git a/editors/bless/Makefile b/editors/bless/Makefile
index a255bd8cf205..e0c855e08230 100644
--- a/editors/bless/Makefile
+++ b/editors/bless/Makefile
@@ -31,5 +31,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/mail/gmime2-sharp/Makefile b/mail/gmime2-sharp/Makefile
index 7ce3e2657fd5..4cb4321ecd6d 100644
--- a/mail/gmime2-sharp/Makefile
+++ b/mail/gmime2-sharp/Makefile
@@ -10,7 +10,7 @@ COMMENT= Mono bindings for gmime
IGNORE= try to install weaked-named assembly into the GAC.
-LIB_DEPENDS= gmime-2.0.4:${PORTSDIR}/mail/gmime2
+LIB_DEPENDS= libgmime-2.0.so:${PORTSDIR}/mail/gmime2
MASTERDIR= ${.CURDIR}/../gmime2
BUILD_WRKSRC= ${WRKSRC}/mono
@@ -18,7 +18,8 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USE_GNOME= gnomehack glib20 gtksharp20
+USES= mono pathfix
+USE_GNOME= glib20 gtksharp20
CONFIGURE_ARGS= --enable-mono=yes
LATEST_LINK= gmime2-sharp
@@ -32,5 +33,4 @@ pre-configure:
@${REINPLACE_CMD} -e 's|.@GMIME_VERSION@||g' \
${WRKSRC}/mono/gmime-sharp.dll.config.in
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gnome-subtitles/Makefile b/multimedia/gnome-subtitles/Makefile
index 16838d6144af..b25dbd51d593 100644
--- a/multimedia/gnome-subtitles/Makefile
+++ b/multimedia/gnome-subtitles/Makefile
@@ -12,12 +12,10 @@ COMMENT= Subtitle editor with video preview
LICENSE= GPLv2
-LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
- gtkspell.0:${PORTSDIR}/textproc/gtkspell
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
+ libgtkspell.so:${PORTSDIR}/textproc/gtkspell
-USES= gmake pkgconfig
+USES= gmake mono pkgconfig
USE_GNOME= gnomeprefix gtksharp20 gnomesharp20 gnomedocutils
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
@@ -45,6 +43,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.post.mk>
diff --git a/net/avahi-sharp/Makefile b/net/avahi-sharp/Makefile
index 0b11458cacd3..d867b5312df4 100644
--- a/net/avahi-sharp/Makefile
+++ b/net/avahi-sharp/Makefile
@@ -9,9 +9,8 @@ MAINTAINER= mono@FreeBSD.org
COMMENT= Mono bindings for Avahi service discovery
LIB_DEPENDS= libavahi-core.so:${PORTSDIR}/net/avahi-app
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+USES= mono
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-sharp
INSTALL_WRKSRC= ${BUILD_WRKSRC}
@@ -28,5 +27,4 @@ post-patch:
${BUILD_WRKSRC}/avahi-sharp.dll.config.in
@${CP} ${WRKSRC}/avahi-sharp/avahi-sharp.dll.config.in ${WRKSRC}/avahi-sharp/avahi-sharp.dll.config
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include "${MASTERDIR}/Makefile"
diff --git a/www/gecko-sharp20/Makefile b/www/gecko-sharp20/Makefile
index 5b9ae4cefb3e..e7315c134043 100644
--- a/www/gecko-sharp20/Makefile
+++ b/www/gecko-sharp20/Makefile
@@ -13,8 +13,7 @@ MAINTAINER= mono@FreeBSD.org
COMMENT= Mono bindings to embed Mozilla
USE_GNOME= gtksharp20
-USES= gmake pathfix pkgconfig gecko tar:bzip2
+USES= gmake mono pathfix pkgconfig gecko tar:bzip2
GNU_CONFIGURE= yes
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/www/xsp/Makefile b/www/xsp/Makefile
index cae42e2f1764..72c93439e52d 100644
--- a/www/xsp/Makefile
+++ b/www/xsp/Makefile
@@ -9,13 +9,10 @@ MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
MAINTAINER= mono@FreeBSD.org
COMMENT= Mono based web server
-BUILD_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono
-
MAKE_JOBS_UNSAFE= yes
USE_SQLITE= 3
-USES= pathfix pkgconfig gmake tar:bzip2
+USES= mono pathfix pkgconfig gmake tar:bzip2
GNU_CONFIGURE= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -23,5 +20,4 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION}
pre-install:
${MKDIR} ${STAGEDIR}${XSP_DOCROOT}
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome-desktop-sharp20/Makefile b/x11-toolkits/gnome-desktop-sharp20/Makefile
index 34e43a422053..e09caddb0447 100644
--- a/x11-toolkits/gnome-desktop-sharp20/Makefile
+++ b/x11-toolkits/gnome-desktop-sharp20/Makefile
@@ -13,7 +13,7 @@ COMMENT= GNOME desktop interfaces for the .NET runtime
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-USES= gmake perl5 pathfix pkgconfig tar:bzip2
+USES= gmake mono perl5 pathfix pkgconfig tar:bzip2
USE_PERL5= run
USE_GNOME= gnomepanel gtkhtml3 gtksharp20 gnomesharp20 librsvg2 vte \
libgnomeprintui gtksourceview2 gnomepanel libwnck
@@ -22,5 +22,4 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -e \
's|^#!/usr/bin/perl|#!${PERL}|'
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index 54394acc3067..ff4bcd2b0048 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -12,7 +12,7 @@ COMMENT= GNOME interfaces for the .NET runtime
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake libtool:keepla pathfix perl5 pkgconfig tar:bzip2
+USES= gmake libtool:keepla mono pathfix perl5 pkgconfig tar:bzip2
USE_PERL5= run
USE_GNOME= gnomepanel gtksharp20 librsvg2 vte libgnomeprintui libgnomeui
MAKE_JOBS_UNSAFE= yes
@@ -22,5 +22,4 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -e \
's|^#!/usr/bin/perl|#!${PERL}|'
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-sharp10/Makefile b/x11-toolkits/gtk-sharp10/Makefile
index b0b31e87a5bb..6b698b2a0c94 100644
--- a/x11-toolkits/gtk-sharp10/Makefile
+++ b/x11-toolkits/gtk-sharp10/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
LATEST_LINK= gtk-sharp10
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake pathfix perl5 pkgconfig
+USES= gmake mono pathfix perl5 pkgconfig
USE_PERL5= run
USE_GNOME= gtkhtml3 vte librsvg2 libgnomecanvas \
libgnomeprintui libglade2 libgnomeui
@@ -33,5 +33,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/glib/glue/slist.c ${WRKSRC}/glib/glue/list.c
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
index 0529600e786a..5b06a79ef5dd 100644
--- a/x11-toolkits/gtk-sharp20/Makefile
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -11,14 +11,12 @@ PKGNAMESUFFIX= 20
MAINTAINER= mono@FreeBSD.org
COMMENT= GTK+ and GNOME interfaces for the .NET runtime
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono \
- p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= gtk20 libglade2
-USES= gmake libtool:keepla pathfix perl5 pkgconfig shebangfix tar:bzip2
+USES= gmake libtool:keepla mono pathfix perl5 pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= parser/*.pl
USE_PERL5= run
MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
@@ -27,5 +25,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/glib/glue/*.c
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>