aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/hotcrp/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/hotcrp/Makefile b/www/hotcrp/Makefile
index 06f3fa23aaec..7164eb76da2f 100644
--- a/www/hotcrp/Makefile
+++ b/www/hotcrp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hotcrp
PORTVERSION= 2.45
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.cs.ucla.edu/~kohler/hotcrp/
@@ -16,14 +17,16 @@ COMMENT= A web based conference management software
RUN_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
pdftohtml:${PORTSDIR}/textproc/pdftohtml
-USE_PHP= mysql gd
+
+USE_PHP= mysql gd session ctype
+USE_MYSQL= server
PEARDIR= ${PREFIX}/share/pear
WWWDOCROOT?= www
NO_BUILD= yes
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -31,7 +34,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
do-install:
${MKDIR} ${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
post-install:
@${CAT} ${PKGMESSAGE}