aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/tintfu/Makefile38
-rw-r--r--graphics/tintfu/distinfo2
-rw-r--r--graphics/tintfu/files/tintfu3
-rw-r--r--graphics/tintfu/pkg-descr10
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5b148b41dcfb..d0378b4def3b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -428,6 +428,7 @@
SUBDIR += tiff
SUBDIR += tiff2png
SUBDIR += tifmerge
+ SUBDIR += tintfu
SUBDIR += togl
SUBDIR += truevision
SUBDIR += tulip
diff --git a/graphics/tintfu/Makefile b/graphics/tintfu/Makefile
new file mode 100644
index 000000000000..b1556ad09588
--- /dev/null
+++ b/graphics/tintfu/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: tintfu
+# Date created: Nov 10, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tintfu
+PORTVERSION= 0.0.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A GraphViz .dot file editor
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= .
+NO_BUILD= yes
+USE_JAVA= 1.3+
+
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/${DISTNAME}.jar \
+ bin/tintfu
+
+post-patch:
+ @${SED} -e 's,%%JAVAJARDIR%%,${JAVAJARDIR},' \
+ -e 's,%%DISTNAME%%,${DISTNAME},' ${FILESDIR}/tintfu > ${WRKSRC}/tintfu
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/tintfu/distinfo b/graphics/tintfu/distinfo
new file mode 100644
index 000000000000..2de061f9bc7a
--- /dev/null
+++ b/graphics/tintfu/distinfo
@@ -0,0 +1,2 @@
+MD5 (tintfu_0_0_4.jar) = 08693e2e18224894ae00ffcd51dcf898
+SIZE (tintfu_0_0_4.jar) = 80475
diff --git a/graphics/tintfu/files/tintfu b/graphics/tintfu/files/tintfu
new file mode 100644
index 000000000000..0ecf470deb9b
--- /dev/null
+++ b/graphics/tintfu/files/tintfu
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%JAVAJARDIR%%/%%DISTNAME%%.jar
diff --git a/graphics/tintfu/pkg-descr b/graphics/tintfu/pkg-descr
new file mode 100644
index 000000000000..f07d7e2f63fb
--- /dev/null
+++ b/graphics/tintfu/pkg-descr
@@ -0,0 +1,10 @@
+This is an editor for GraphViz, an excellent program imho for both quickly
+creating a graphical overview of some collection of related components as
+well as drawing graphs for systems which are too complex to manage using
+conventional drawing programs.
+
+TINTFU can parse DOT files and render a preview of them in a side pane, while
+allowing each and every attribute of Graphs, SubGraphs and Nodes to be edited.
+The results of such changes are immediately updated in the preview pane.
+
+WWW: http://tintfu.sourceforge.net/