aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED3
-rw-r--r--archivers/quazip/Makefile22
-rw-r--r--astro/marble/Makefile3
-rw-r--r--astro/merkaartor/Makefile4
-rw-r--r--astro/qmapshack/Makefile3
-rw-r--r--cad/qcad/Makefile4
-rw-r--r--editors/texstudio/Makefile4
-rw-r--r--emulators/mupen64plus-qt/Makefile4
-rw-r--r--graphics/tulip/Makefile6
9 files changed, 21 insertions, 32 deletions
diff --git a/MOVED b/MOVED
index f3b0728982ea..427825a5a76f 100644
--- a/MOVED
+++ b/MOVED
@@ -10016,7 +10016,6 @@ www/phpmp||2018-03-08|Has expired: Unmaintained, all www files wrongly belongs t
www/lionwiki||2018-03-08|Has expired: Unmaintained, all www files wrongly belongs to www user
databases/php-memcached|databases/pecl-memcached|2018-03-10|Remove duplicate port, use databases/pecl-memcached instead
emulators/i386-wine-staging|emulators/i386-wine-devel|2018-03-10|Broken for months, abandoned upstream
-archivers/quazip-qt5|archivers/quazip@qt5|2018-03-11|Moved to a flavoured version
devel/go-json-rest||2018-03-11|Go libraries aren't allowed (GH/ant0ine/go-json-rest)
devel/libdbusmenu-qt5|devel/libdbusmenu-qt@qt5|2018-03-12|Moved to a flavoured version
finance/electrum2|finance/electrum|2018-03-13|Has expired: Vulnerable legacy port, please use finance/electrum instead
@@ -11678,3 +11677,5 @@ graphics/fracplanet@qt4||2019-03-16|Qt4 deprecation
graphics/fracplanet@qt5|graphics/fracplanet|2019-03-16|Flavor has been removed
graphics/photivo@qt4||2019-03-16|Qt4 deprecation
graphics/photivo@qt5|graphics/photivo|2019-03-16|Flavor has been removed
+archivers/quazip@qt4||2019-03-16|Qt4 deprecation
+archivers/quazip@qt5|archivers/quazip|2019-03-16|Flavor has been removed
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index 9c3798320c18..db465ecda24f 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -3,36 +3,22 @@
PORTNAME= quazip
DISTVERSION= 0.7.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= archivers
-PKGNAMESUFFIX= -${FLAVOR}
+PKGNAMESUFFIX= -qt5
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
LICENSE= LGPL21
-FLAVORS= qt5 qt4
-FLAVOR?= ${FLAVORS:[1]}
-
-USES= cmake
+USES= cmake compiler:c++11-lang qt:5
USE_GITHUB= yes
GH_ACCOUNT= stachenov
USE_LDCONFIG= yes
-
-. if ${FLAVOR} == qt4
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE=2019-03-15
-USES+= qt:4
-USE_QT= corelib moc_build network_build qmake_build rcc_build uic_build
-CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=TRUE
-. else
-USES+= compiler:c++11-lang qt:5
USE_QT= core buildtools_build qmake_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=FALSE
-QTVER_SUFFIX= 5
-. endif
-PLIST_SUB= QTVER_SUFFIX="${QTVER_SUFFIX}"
+PLIST_SUB= QTVER_SUFFIX=5
.include <bsd.port.mk>
diff --git a/astro/marble/Makefile b/astro/marble/Makefile
index 01a5a76f1d06..fd351a65a5d7 100644
--- a/astro/marble/Makefile
+++ b/astro/marble/Makefile
@@ -2,6 +2,7 @@
PORTNAME= marble
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= astro kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ COMMENT= Virtual globe and world atlas for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-LIB_DEPENDS= libquazip5.so:archivers/quazip@qt5
+LIB_DEPENDS= libquazip5.so:archivers/quazip
USES= cmake compiler:c++11-lang desktop-file-utils gettext \
kde:5 qt:5 tar:xz
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 036ebd723c69..b0d281c88767 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= merkaartor
PORTVERSION= 0.18.2
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= astro
MAINTAINER= dev2@heesakkers.info
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip@qt5
+ libquazip5.so:archivers/quazip
USES= compiler:c++11-lang pkgconfig qmake qt:5 sqlite:3
USE_GITHUB= yes
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index c80a3b854960..9fa123254309 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qmapshack
PORTVERSION= 1.12.3
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgdal.so:graphics/gdal \
libproj.so:graphics/proj \
- libquazip5.so:archivers/quazip@qt5 \
+ libquazip5.so:archivers/quazip \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 9995051ee905..98953867be5d 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -4,7 +4,7 @@
PORTNAME= qcad
PORTVERSION= 3.21.3.15
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
DIST_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= bash:shells/bash \
${LOCALBASE}/lib/libopenNURBS.a:graphics/opennurbs
-LIB_DEPENDS= libquazip5.so:archivers/quazip@qt5
+LIB_DEPENDS= libquazip5.so:archivers/quazip
MAKE_JOBS_UNSAFE=yes
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index f3ef30379dfc..9326f73802a6 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texstudio
DISTVERSION= 2.12.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= editors
MAINTAINER= rigoletto@FreeBSD.org
@@ -16,7 +16,7 @@ BROKEN_armv6= fails to compile: error: no member named mc_eip in __mcontext
LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
libpoppler.so:graphics/poppler \
libpoppler-qt5.so:graphics/poppler-qt5 \
- libquazip5.so:archivers/quazip@qt5
+ libquazip5.so:archivers/quazip
USES= compiler:c++11-lang desktop-file-utils dos2unix \
ghostscript:run gl pkgconfig qmake qt:5
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index 914bb713e746..f20da7f972e2 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mupen64plus-qt
DISTVERSION= 1.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MAINTAINER= maintainer@hasting.email
@@ -10,7 +10,7 @@ COMMENT= Basic launcher for Mupen64Plus
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libquazip5.so:archivers/quazip@qt5
+LIB_DEPENDS= libquazip5.so:archivers/quazip
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:emulators/mupen64plus-audio-sdl \
${LOCALBASE}/lib/mupen64plus/mupen64plus-input-sdl.so:emulators/mupen64plus-input-sdl \
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 8b115450c291..c4e8fb7dd115 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tulip
PORTVERSION= 4.10.0
-PORTREVISION= 8
+PORTREVISION= 9
DISTVERSIONSUFFIX= _src
CATEGORIES= graphics
MASTER_SITES= SF/auber/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,8 +13,8 @@ COMMENT= System dedicated to the visualization of huge graphs
LICENSE= LGPL3
-LIB_DEPENDS= libquazip.so:archivers/quazip@qt4 \
- libpng.so:graphics/png \
+BROKEN= Missing libquazip.so:archivers/quazip@qt4
+LIB_DEPENDS= libpng.so:graphics/png \
libOGDF.so:math/ogdf \
libfreetype.so:print/freetype2