aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-python-lsp-jsonrpc/Makefile22
-rw-r--r--textproc/py-python-lsp-jsonrpc/distinfo3
-rw-r--r--textproc/py-python-lsp-jsonrpc/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9e7aae2a8411..f25214c4e7f6 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1383,6 +1383,7 @@
SUBDIR += py-python-docx
SUBDIR += py-python-gettext
SUBDIR += py-python-language-server
+ SUBDIR += py-python-lsp-jsonrpc
SUBDIR += py-python-slugify
SUBDIR += py-python-xmp-toolkit
SUBDIR += py-pytidylib
diff --git a/textproc/py-python-lsp-jsonrpc/Makefile b/textproc/py-python-lsp-jsonrpc/Makefile
new file mode 100644
index 000000000000..3d9a0f4b5aef
--- /dev/null
+++ b/textproc/py-python-lsp-jsonrpc/Makefile
@@ -0,0 +1,22 @@
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
+
+PORTNAME= python-lsp-jsonrpc
+PORTVERSION= 1.0.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rhurlin@FreeBSD.org
+COMMENT= Python JSON RPC Server
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ujson>0:devel/py-ujson@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-python-lsp-jsonrpc/distinfo b/textproc/py-python-lsp-jsonrpc/distinfo
new file mode 100644
index 000000000000..82dac3665901
--- /dev/null
+++ b/textproc/py-python-lsp-jsonrpc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619806307
+SHA256 (python-lsp-jsonrpc-1.0.0.tar.gz) = 7bec170733db628d3506ea3a5288ff76aa33c70215ed223abdb0d95e957660bd
+SIZE (python-lsp-jsonrpc-1.0.0.tar.gz) = 10011
diff --git a/textproc/py-python-lsp-jsonrpc/pkg-descr b/textproc/py-python-lsp-jsonrpc/pkg-descr
new file mode 100644
index 000000000000..c37571f7569d
--- /dev/null
+++ b/textproc/py-python-lsp-jsonrpc/pkg-descr
@@ -0,0 +1,5 @@
+A Python 3.6+ server implementation of the JSON RPC 2.0
+protocol. This library has been pulled out of the Python
+LSP Server project.
+
+WWW: https://github.com/python-lsp/python-lsp-jsonrpc