aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/shimmer/Makefile35
-rw-r--r--security/shimmer/distinfo3
-rw-r--r--security/shimmer/pkg-descr5
4 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index dd1381393e6e..f67e093fdb30 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -680,6 +680,7 @@
SUBDIR += sguil-server
SUBDIR += sha
SUBDIR += shibboleth-sp
+ SUBDIR += shimmer
SUBDIR += shishi
SUBDIR += shttpscanner
SUBDIR += sig2dot
diff --git a/security/shimmer/Makefile b/security/shimmer/Makefile
new file mode 100644
index 000000000000..75c090c86020
--- /dev/null
+++ b/security/shimmer/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: shimmer
+# Date created: 2008-01-09
+# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shimmer
+PORTVERSION= 0.1.0
+CATEGORIES= security
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= lippemail@gmail.com
+COMMENT= Perl implementation that hides a valuable port on your server
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/shimmer \
+ bin/shimmerd \
+ etc/shimmer.conf
+
+do-install:
+.if !defined(WITHOUT_CLIENT)
+ ${INSTALL_SCRIPT} ${WRKSRC}/shimmer ${PREFIX}/bin/shimmer
+.endif
+.if !defined(WITHOUT_SERVER)
+ ${INSTALL_SCRIPT} ${WRKSRC}/shimmerd ${PREFIX}/bin/shimmerd
+ ${INSTALL_DATA} ${WRKSRC}/shimmer.conf ${PREFIX}/etc/shimmer.conf
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/shimmer/distinfo b/security/shimmer/distinfo
new file mode 100644
index 000000000000..27fc6c816992
--- /dev/null
+++ b/security/shimmer/distinfo
@@ -0,0 +1,3 @@
+MD5 (shimmer.tar.gz) = 9b754321fa9ffa990f4307c2e7ad85e6
+SHA256 (shimmer.tar.gz) = d9ed67b8d15104beee36bbd3e3514bb98a81d6c1b1388ce4b4362a84ecd09ee3
+SIZE (shimmer.tar.gz) = 7488
diff --git a/security/shimmer/pkg-descr b/security/shimmer/pkg-descr
new file mode 100644
index 000000000000..e8fa3791ac3e
--- /dev/null
+++ b/security/shimmer/pkg-descr
@@ -0,0 +1,5 @@
+shimmer is a pair of small programs (a client and a server) that provide an
+alternative to port knocking program such as tumbler and are used to hide a
+valuable port (such as a hidden web server or SSH) on a public IP address.
+
+WWW: http:/shimmer.sourceforge.net/