aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/ncid/Makefile6
-rw-r--r--comms/ncid/distinfo6
-rw-r--r--comms/ncid/files/patch-Makefile11
-rw-r--r--comms/ncid/files/patch-ncidd.c46
-rw-r--r--comms/ncid/files/patch-scripts_Makefile17
-rw-r--r--comms/ncid/files/patch-tools_Makefile17
-rw-r--r--comms/ncid/pkg-descr3
-rw-r--r--comms/ncid/pkg-plist16
8 files changed, 30 insertions, 92 deletions
diff --git a/comms/ncid/Makefile b/comms/ncid/Makefile
index dd4fad8d7274..ad5eeef70ba3 100644
--- a/comms/ncid/Makefile
+++ b/comms/ncid/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ncid
-PORTVERSION= 0.50
+PORTVERSION= 0.67
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,8 +20,8 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= ncid.1 ncidscripts.1 ncidtools.1
-MAN5= ncidd.conf.5
-MAN8= ncidd.8
+MAN5= ncid.conf.5 ncidd.alias.5 ncidd.conf.5 ncidscript.conf.5
+MAN8= ncidd.8 ncidsip.8
USE_GMAKE= yes
ALL_TARGET= freebsd
diff --git a/comms/ncid/distinfo b/comms/ncid/distinfo
index c179a23f1f22..ec77b9218fb4 100644
--- a/comms/ncid/distinfo
+++ b/comms/ncid/distinfo
@@ -1,3 +1,3 @@
-MD5 (ncid-0.50.tar.gz) = 7b6e0ec1eb019dbb086d2a55e9e50d5e
-SHA256 (ncid-0.50.tar.gz) = 8cb6daa3801d39c147a2b37df650452d7924aa3dc422ceb87b9481223fc94fd2
-SIZE (ncid-0.50.tar.gz) = 105852
+MD5 (ncid-0.67.tar.gz) = b49d6ca63a7740a286548000f6a895e4
+SHA256 (ncid-0.67.tar.gz) = 1478cc2eeaac899d35db8686b85e9f3124f8b841981e5bd3170a33bf4bdceeaf
+SIZE (ncid-0.67.tar.gz) = 251917
diff --git a/comms/ncid/files/patch-Makefile b/comms/ncid/files/patch-Makefile
new file mode 100644
index 000000000000..dd045590c794
--- /dev/null
+++ b/comms/ncid/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Sat Jul 8 05:43:57 2006
++++ Makefile Wed Feb 7 19:23:00 2007
+@@ -172,8 +172,6 @@
+ @if ! test -d $(SBIN); then mkdir -p $(SBIN); fi
+ @if ! test -d $(ETC); then mkdir -p $(ETC); fi
+ @if ! test -d $(LOG); then mkdir -p $(LOG); fi
+- @if ! test -d $(ROTATE); then mkdir -p $(ROTATE); fi
+- @if ! test -d $(INIT); then mkdir -p $(INIT); fi
+ @if ! test -d $(SCRIPTDIR); then mkdir -p $(SCRIPTDIR); fi
+ @if ! test -d $(CONFDIR); then mkdir -p $(CONFDIR); fi
+
diff --git a/comms/ncid/files/patch-ncidd.c b/comms/ncid/files/patch-ncidd.c
deleted file mode 100644
index e427a2392ac6..000000000000
--- a/comms/ncid/files/patch-ncidd.c
+++ /dev/null
@@ -1,46 +0,0 @@
-*** ncidd.c Wed Nov 24 03:44:55 2004
---- ncidd.c Fri Jun 3 17:24:58 2005
-***************
-*** 359,376 ****
-
- strcat(strncpy(buf, ptr, BUFSIZ - 2), CR);
- if (write(ttyfd, buf, strlen(buf)) < 0) return -1;
-! do
- {
-! if ((num = read(ttyfd, buf + size, BUFSIZ - size - 1)) < 0) return -1;
-! size += num;
-! } while (num);
-
-! if (debug && size) write(STDOUT, buf, size);
-! buf[size] = 0;
-! if ((bufp = strrchr(buf, 'O')) != 0)
-! if (!strncmp(bufp, "OK", 2)) return 0;
-! if ((bufp = strrchr(buf, 'E')) != 0)
-! if (!strncmp(bufp, "ERROR", 5)) return 1;
-
- return 2;
- }
---- 359,381 ----
-
- strcat(strncpy(buf, ptr, BUFSIZ - 2), CR);
- if (write(ttyfd, buf, strlen(buf)) < 0) return -1;
-!
-! do
- {
-! do
-! {
-! if ((num = read(ttyfd, buf + size, BUFSIZ - size - 1)) < 0) return -1;
-! size += num;
-! } while (num);
-!
-! if (debug && size) write(STDOUT, buf, size);
-! buf[size] = 0;
-
-! if ((bufp = strrchr(buf, 'O')) != 0)
-! if (!strncmp(bufp, "OK", 2)) return 0;
-! if ((bufp = strrchr(buf, 'E')) != 0)
-! if (!strncmp(bufp, "ERROR", 5)) return 1;
-! } while(1);
-
- return 2;
- }
diff --git a/comms/ncid/files/patch-scripts_Makefile b/comms/ncid/files/patch-scripts_Makefile
deleted file mode 100644
index d830104ce863..000000000000
--- a/comms/ncid/files/patch-scripts_Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-*** scripts/Makefile.ori Mon Jun 6 16:05:09 2005
---- scripts/Makefile Mon Jun 6 16:05:29 2005
-***************
-*** 21,32 ****
- @if test ! -d $(SHARE); then mkdir $(SHARE); fi
- install -m 755 $(SCRIPTS) $(SHARE)
- install -m 644 README $(SHARE)/.
-- touch install-script
-
- install-man: $(MAN)
- cd $(MAN1); rm -f $(MANSRC)
- install -m 644 $(MANSRC) $(MAN1)
-- touch install-man
-
- clean:
-
---- 21,30 ----
diff --git a/comms/ncid/files/patch-tools_Makefile b/comms/ncid/files/patch-tools_Makefile
deleted file mode 100644
index 724479ed278d..000000000000
--- a/comms/ncid/files/patch-tools_Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-*** tools/Makefile.ori Mon Jun 6 16:04:37 2005
---- tools/Makefile Mon Jun 6 16:04:53 2005
-***************
-*** 31,42 ****
-
- install-script: $(SCRIPT)
- install -m 755 $(SCRIPT) $(BIN)
-- touch install-script
-
- install-man: $(MAN)
- cd $(MAN1); rm -f ncidtools.1
- install -m 644 ncidtools.1 $(MAN1)
-- touch install-man
-
- clean:
-
---- 31,40 ----
diff --git a/comms/ncid/pkg-descr b/comms/ncid/pkg-descr
index 927c32d3f0b7..03fd27473393 100644
--- a/comms/ncid/pkg-descr
+++ b/comms/ncid/pkg-descr
@@ -3,6 +3,3 @@ CID information from a modem, and a client to display the CID information on a
computer, TiVo, text pager, or cell phone. Multiple clients are permitted.
WWW: http://ncid.sourceforge.net
-
-- David
- <david@freshports.org>
diff --git a/comms/ncid/pkg-plist b/comms/ncid/pkg-plist
index 0cb8fba46858..c6a10f5cd95f 100644
--- a/comms/ncid/pkg-plist
+++ b/comms/ncid/pkg-plist
@@ -1,14 +1,24 @@
sbin/ncidd
+sbin/ncidsip
bin/ncid
bin/cidalias
-bin/cidlog
-bin/cidlogupd
-etc/ncidd.conf
+bin/cidcall
+bin/cidupdate
+etc/ncid/ncidd.alias
+etc/ncid/ncidd.conf
+etc/ncid/ncidrotate.conf
+etc/ncid/ncidscript.conf
+etc/ncid/ncidsip.conf
+etc/ncid/ncid.conf
etc/rc.d/ncidd.sh
etc/rc.d/ncid.sh
+etc/rc.d/ncidsip.sh
share/ncid/ncidrotate
+share/ncid/ncid-mythtv
share/ncid/ncid-page
share/ncid/ncid-samba
share/ncid/ncid-speak
+share/ncid/ncid-tivo
share/ncid/README
@dirrm share/ncid
+@dirrm etc/ncid