aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/lohit/Makefile55
-rw-r--r--x11-fonts/lohit/distinfo2
-rw-r--r--x11-fonts/lohit/files/pkg-message.in12
-rw-r--r--x11-fonts/lohit/pkg-descr13
5 files changed, 83 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 5dd784e4e6a3..c95153dc5e94 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -111,6 +111,7 @@
SUBDIR += linux-f10-fontconfig
SUBDIR += linuxlibertine
SUBDIR += linuxlibertine-g
+ SUBDIR += lohit
SUBDIR += manu-gothica
SUBDIR += mgopen
SUBDIR += mkbold
diff --git a/x11-fonts/lohit/Makefile b/x11-fonts/lohit/Makefile
new file mode 100644
index 000000000000..a8240d5cbebf
--- /dev/null
+++ b/x11-fonts/lohit/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= Lohit
+PORTVERSION= 20130612
+CATEGORIES= x11-fonts
+MASTER_SITES= https://fedorahosted.org/releases/l/o/lohit/
+DISTNAME= lohit-ttf-${PORTVERSION}
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= Lohit fonts
+
+LICENSE= OFL
+LICENSE_NAME= SIL Open Font License (OFL)
+LICENSE_FILE= ${WRKSRC}/OFL.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+EXTRACT_SUFX= .tar.gz
+XORG_CAT= font
+
+FONTLIBPATH= lib/X11/fonts
+FONTROOTDIR= ${PREFIX}/${FONTLIBPATH}
+INSTALLS_TTF= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:S,.orig,,:S,_,-,}
+
+PLIST_FILES= ${FONTLIBPATH}/${FONTDIR}/Lohit-Assamese.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Bengali.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Devanagari.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Gujarati.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Kannada.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Malayalam.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Marathi.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Nepali.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Oriya.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Punjabi.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Tamil-Classical.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Tamil.ttf \
+ ${FONTLIBPATH}/${FONTDIR}/Lohit-Telugu.ttf
+
+SUB_LIST= "FONTPATH=${FONTROOTDIR}/${FONTDIR}"
+SUB_FILES= pkg-message
+
+.include <bsd.port.options.mk>
+
+do-configure:
+ ${DO_NADA}
+
+do-install:
+ ${ECHO_MSG}
+ ${CAT} ${PKGMESSAGE}
+ ${ECHO_MSG}
+ ${MKDIR} ${FONTROOTDIR}/${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTROOTDIR}/${FONTDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/lohit/distinfo b/x11-fonts/lohit/distinfo
new file mode 100644
index 000000000000..4dd9fc0665de
--- /dev/null
+++ b/x11-fonts/lohit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xorg/font/lohit-ttf-20130612.tar.gz) = c68525b695e8492b29e19596f41670eb7c4fd4de991fa932454dfada793265db
+SIZE (xorg/font/lohit-ttf-20130612.tar.gz) = 538621
diff --git a/x11-fonts/lohit/files/pkg-message.in b/x11-fonts/lohit/files/pkg-message.in
new file mode 100644
index 000000000000..7117adce42d0
--- /dev/null
+++ b/x11-fonts/lohit/files/pkg-message.in
@@ -0,0 +1,12 @@
+To use these fonts, add the following line to the "Files" section of
+xorg.conf:
+
+ FontPath "%%FONTPATH%%/"
+
+Users of older versions of X may additionally have to make sure that
+the freetype module is loaded. Check /var/log/Xorg.0.log for error
+messages. If freetype is required, add the following line to the
+"Modules" section of xorg.conf:
+
+ Load "freetype"
+
diff --git a/x11-fonts/lohit/pkg-descr b/x11-fonts/lohit/pkg-descr
new file mode 100644
index 000000000000..673fa2e2b227
--- /dev/null
+++ b/x11-fonts/lohit/pkg-descr
@@ -0,0 +1,13 @@
+In 2004, Red Hat has released five Indian language fonts as open source
+licensed under the GPL. In 2011 Red Hat relicensed fonts under SIL OFL 1.1
+license. The fonts named Lohit which means Red in Sanskrit. Currently, the
+font family supports 21 Indian languages: Assamese, Bengali, Devanagari
+(Hindi, Kashmiri, Konkani, Maithili, Marathi, Nepali, Sindhi, Santali,
+Bodo, Dogri), Gujarati, Kannada, Malayalam, Manipuri, Oriya, Punjabi,
+Tamil, and Telugu. Now, Fedora Project and its contributors took the
+responsibility to consolidate the further efforts and improvements of
+the Lohit fonts.
+
+Lohit Fonts are Unicode 6.0 compatible.
+
+WWW: https://fedorahosted.org/lohit/