aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/snes9express/Makefile8
-rw-r--r--x11-fm/velocity/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index a877b5f22546..7c7effe55049 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -23,6 +23,12 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile
+.endif
+
post-configure:
@${REINPLACE_CMD} -e 's|lstat$$U.o||' ${WRKSRC}/Makefile
@@ -38,4 +44,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-fm/velocity/Makefile b/x11-fm/velocity/Makefile
index bab45304a560..559a2d3e7b99 100644
--- a/x11-fm/velocity/Makefile
+++ b/x11-fm/velocity/Makefile
@@ -20,8 +20,14 @@ USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= libgnomeui gnomedesktop librsvg2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>