aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-dnspython/Makefile2
-rw-r--r--dns/py3-dnspython/Makefile7
3 files changed, 9 insertions, 1 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 11f7882dc1d2..eb88cc0dbc77 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -179,6 +179,7 @@
SUBDIR += py-pywdns
SUBDIR += py-tldextract
SUBDIR += py-twistedNames
+ SUBDIR += py3-dnspython
SUBDIR += radns
SUBDIR += rbldnsd
SUBDIR += rbllookup
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index f475c77db6e2..ed3d16dc865a 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= rm@FreeBSD.org
COMMENT= DNS toolkit for Python
NO_ARCH= yes
-USES= python:2.7+
+USES?= python:2.7+
USE_PYTHON= autoplist distutils
OPTIONS_DEFINE= DOCS EXAMPLES PYCRYPTO
diff --git a/dns/py3-dnspython/Makefile b/dns/py3-dnspython/Makefile
new file mode 100644
index 000000000000..1e618eac7a8f
--- /dev/null
+++ b/dns/py3-dnspython/Makefile
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-dnspython
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"