aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--biology/Makefile1
-rw-r--r--biology/prodigal/Makefile25
-rw-r--r--biology/prodigal/distinfo3
-rw-r--r--biology/prodigal/pkg-descr22
4 files changed, 51 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index bf5f4af2c23c..75eb9e66c060 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -101,6 +101,7 @@
SUBDIR += phyml
SUBDIR += plinkseq
SUBDIR += primer3
+ SUBDIR += prodigal
SUBDIR += protomol
SUBDIR += psi88
SUBDIR += py-Genesis-PyAPI
diff --git a/biology/prodigal/Makefile b/biology/prodigal/Makefile
new file mode 100644
index 000000000000..c227b6a80f17
--- /dev/null
+++ b/biology/prodigal/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= prodigal
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6.3-2
+DISTVERSIONSUFFIX= -gfe80417
+CATEGORIES= biology
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Protein-coding gene prediction for prokaryotic genomes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= hyattpd
+GH_PROJECT= Prodigal
+
+BINARY_ALIAS= gcc=${CC}
+MAKE_ARGS= INSTALLDIR=${STAGEDIR}${PREFIX}/bin
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/biology/prodigal/distinfo b/biology/prodigal/distinfo
new file mode 100644
index 000000000000..f2c70fef6b3f
--- /dev/null
+++ b/biology/prodigal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549215427
+SHA256 (hyattpd-Prodigal-v2.6.3-2-gfe80417_GH0.tar.gz) = a8229a3ce38f7d6553730d5a5d3c46c619abd502de8527cb175e9af022c3b371
+SIZE (hyattpd-Prodigal-v2.6.3-2-gfe80417_GH0.tar.gz) = 611025
diff --git a/biology/prodigal/pkg-descr b/biology/prodigal/pkg-descr
new file mode 100644
index 000000000000..7d9eb1c4c855
--- /dev/null
+++ b/biology/prodigal/pkg-descr
@@ -0,0 +1,22 @@
+Fast, reliable protein-coding gene prediction for prokaryotic genomes.
+
+Features:
+* Predicts protein-coding genes: Prodigal provides fast, accurate protein-coding
+ gene predictions in GFF3, Genbank, or Sequin table format.
+* Handles draft genomes and metagenomes: Prodigal runs smoothly on finished
+ genomes, draft genomes, and metagenomes.
+* Runs quickly: Prodigal analyzes the E. coli K-12 genome in 10 seconds on a
+ modern MacBook Pro.
+* Runs unsupervised: Prodigal is an unsupervised machine learning algorithm. It
+ does not need to be provided with any training data, and instead automatically
+ learns the properties of the genome from the sequence itself, including RBS
+ motif usage, start codon usage, and coding statistics.
+* Handles gaps and partial genes: The user can specify if Prodigal should build
+ genes across runs of N's as well as how to handle genes at the edges of
+ contigs.
+* Identifies translation initiation sites: Prodigal predicts the correct
+ translation initiation site for most genes, and can output information about
+ every potential start site in the genome, including confidence score, RBS
+ motif, and much more.
+
+WWW: https://github.com/hyattpd/Prodigal