aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/gstreamermm/Makefile8
-rw-r--r--multimedia/mjpegtools/Makefile8
-rw-r--r--multimedia/py-gstreamer/Makefile9
-rw-r--r--multimedia/vcdimager/Makefile8
4 files changed, 11 insertions, 22 deletions
diff --git a/multimedia/gstreamermm/Makefile b/multimedia/gstreamermm/Makefile
index 0129814c66b1..02d05b141c5e 100644
--- a/multimedia/gstreamermm/Makefile
+++ b/multimedia/gstreamermm/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: gstreamermm
-# Date created: 2008-02-23
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/multimedia/gstreamermm/Makefile,v 1.6 2009/09/26 13:42:00 marcus Exp $
@@ -20,7 +17,8 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
USE_XZ= yes
USE_GMAKE= yes
USE_GSTREAMER= theora vorbis cdparanoia gio pango
-USE_GNOME= pkgconfig gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-documentation
USE_LDCONFIG= yes
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index af0781ffa2ef..7b61ff9e720b 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mjpegtools
-# Date created: Wed May 29 21:12:38 UTC 2002
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mjpegtools
PORTVERSION= 2.0.0
@@ -22,7 +18,7 @@ QUICKTIME_DESC= Enable libQuickTime support
CONFLICTS= mplex-[0-9]*
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_GMAKE= yes
USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
LIBTOOLIZE_ARGS=--force
diff --git a/multimedia/py-gstreamer/Makefile b/multimedia/py-gstreamer/Makefile
index 119da07a6edf..52163f6bf91d 100644
--- a/multimedia/py-gstreamer/Makefile
+++ b/multimedia/py-gstreamer/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gstreamer-python
-# Date created: Fri Apr 9 16:24:13 CEST 2004
-# Whom: Koop Mast <kwm@rainbow-runner.nl>
-#
+# Created by: Koop Mast <kwm@rainbow-runner.nl>
# $FreeBSD$
# $MCom: ports/multimedia/py-gstreamer/Makefile,v 1.20 2008/07/26 17:21:38 marcus Exp $
-#
PORTNAME= gstreamer
PORTVERSION= 0.10.22
@@ -26,7 +22,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
USE_PYTHON= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= pygobject gnomehack pkgconfig
+USE_GNOME= pygobject gnomehack
+USE_PKGCONFIG= build
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
PLIST_SUB= VERSION="${GST_VERSION}"
diff --git a/multimedia/vcdimager/Makefile b/multimedia/vcdimager/Makefile
index 810d6d0d2b8c..062c808d9216 100644
--- a/multimedia/vcdimager/Makefile
+++ b/multimedia/vcdimager/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: vcdimager
-# Date created: 16 April 2001
-# Whom: Harold Gutch <logix@foobar.franken.de>
-#
+# Created by: Harold Gutch <logix@foobar.franken.de>
# $FreeBSD$
PORTNAME= vcdimager
@@ -24,7 +21,8 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig lthack
+USE_PKGCONFIG= build
+USE_GNOME= gnomehack lthack
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib