aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-yesod-platform/Makefile63
-rw-r--r--www/hs-yesod-platform/distinfo2
-rw-r--r--www/hs-yesod-platform/files/patch-yesod-platform.cabal11
-rw-r--r--www/hs-yesod-platform/pkg-descr4
6 files changed, 82 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index e87a70bc6ad8..8b78cbce59cc 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -336,6 +336,7 @@ yesod-default_port= www/hs-yesod-default
yesod-form_port= www/hs-yesod-form
yesod-json_port= www/hs-yesod-json
yesod-persistent_port= www/hs-yesod-persistent
+yesod-platform_port= www/hs-yesod-platform
yesod-routes_port= www/hs-yesod-routes
yesod-static_port= www/hs-yesod-static
yesod-test_port= www/hs-yesod-test
diff --git a/www/Makefile b/www/Makefile
index 9a744f5aa3cb..7babeb587a7b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -327,6 +327,7 @@
SUBDIR += hs-yesod-json
SUBDIR += hs-yesod-persistent
SUBDIR += hs-yesod-routes
+ SUBDIR += hs-yesod-platform
SUBDIR += hs-yesod-static
SUBDIR += hs-yesod-test
SUBDIR += htdump
diff --git a/www/hs-yesod-platform/Makefile b/www/hs-yesod-platform/Makefile
new file mode 100644
index 000000000000..c1888a4573d1
--- /dev/null
+++ b/www/hs-yesod-platform/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: hs-yesod-platform
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yesod-platform
+PORTVERSION= 1.0.4.2
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Meta package for Yesod
+
+LICENSE= MIT
+
+USE_CABAL= aeson==0.6.0.2 ansi-terminal==0.5.5_3 asn1-data==0.6.1.3 \
+ attoparsec==0.10.2.0 attoparsec-conduit==0.4.0.1 \
+ attoparsec-enumerator==0.3_1 authenticate==1.2.1.1 \
+ base-unicode-symbols==0.2.2.3_1 base64-bytestring==0.1.1.1 \
+ blaze-builder==0.3.1.0_1 blaze-builder-conduit==0.4.0.2 \
+ blaze-html==0.4.3.4 blaze-markup==0.5.1.0 byteorder==1.0.3_1 \
+ case-insensitive==0.4.0.1_1 cereal==0.3.5.1_1 certificate==1.2.3 \
+ clientsession==0.7.5 conduit==0.4.2 cookie==0.4.0 \
+ cprng-aes==0.2.3_1 cpu==0.1.0 crypto-api==0.10.2 \
+ crypto-conduit==0.3.2 crypto-pubkey-types==0.1.1 \
+ cryptocipher==0.3.4 cryptohash==0.7.5 css-text==0.1.1_1 \
+ data-default==0.4.0 dlist==0.5_5 email-validate==0.2.8 \
+ entropy==0.2.1_1 enumerator==0.4.19 failure==0.2.0.1 \
+ fast-logger==0.0.2_1 file-embed==0.0.4.4 filesystem-conduit==0.4.0 \
+ hamlet==1.0.1.3 hashable==1.1.2.3 hjsmin==0.1.2 hspec==1.1.1 \
+ html-conduit==0.0.1 http-conduit==1.4.1.7 http-date==0.0.2 \
+ http-types==0.6.11 HUnit==1.2.4.2_1 hxt==9.2.2 \
+ hxt-charproperties==9.1.1_1 hxt-regex-xmlschema==9.0.4_1 \
+ hxt-unicode==9.0.2_1 language-javascript==0.5.4 largeword==1.0.1_1 \
+ lifted-base==0.1.1 mime-mail==0.4.1.1_1 monad-control==0.3.1.3 \
+ network-conduit==0.4.0.1 path-pieces==0.1.1 pem==0.1.1 \
+ persistent==0.9.0.4 persistent-template==0.9.0.2 \
+ pool-conduit==0.1.0.2 primitive==0.4.1_1 pureMD5==2.1.0.3_1 \
+ pwstore-fast==2.2_1 QuickCheck==2.4.2 ranges==0.2.4_1 \
+ regex-compat==0.95.1_1 resource-pool==0.2.1.0 resourcet==0.3.2.1 \
+ safe==0.3.3_1 semigroups==0.8.3.2 SHA==1.5.0.1 \
+ shakespeare==1.0.0.2 shakespeare-css==1.0.1.2 \
+ shakespeare-i18n==1.0.0.2 shakespeare-js==1.0.0.3 \
+ shakespeare-text==1.0.0.2 silently==1.1.5 simple-sendfile==0.2.3 \
+ skein==0.1.0.7 socks==0.4.1 stm==2.3 system-fileio==0.3.7 \
+ system-filepath==0.4.6 tagged==0.4.2.1 tagsoup==0.12.6_1 \
+ tagstream-conduit==0.3.2 tls==0.9.5 tls-extra==0.4.6 \
+ transformers-base==0.4.1_1 unix-compat==0.3.0.1 \
+ unordered-containers==0.2.1.0 utf8-light==0.4.0.1 \
+ utf8-string==0.3.7_1 vault==0.2.0.0 vector==0.9.1_1 \
+ void==0.5.5.1 wai==1.2.0.2 wai-app-static==1.2.0.3 \
+ wai-extra==1.2.0.4 wai-logger==0.1.4 wai-test==1.2.0.2 \
+ warp==1.2.1.1 xml-conduit==0.7.0.3 xml-types==0.3.1_1 \
+ xml2html==0.1.2.3 xss-sanitize==0.3.2 yaml==0.7.0.2 \
+ yesod==1.0.1.6 yesod-auth==1.0.2.1 yesod-core==1.0.1.2 \
+ yesod-default==1.0.1.1 yesod-form==1.0.0.4 yesod-json==1.0.0.1 \
+ yesod-persistent==1.0.0.1 yesod-routes==1.0.1.2 \
+ yesod-static==1.0.0.3 yesod-test==0.2.0.6 zlib==0.5.3.3 \
+ zlib-bindings==0.1.0.1 zlib-conduit==0.4.0.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-yesod-platform/distinfo b/www/hs-yesod-platform/distinfo
new file mode 100644
index 000000000000..b2729e1b7005
--- /dev/null
+++ b/www/hs-yesod-platform/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/yesod-platform-1.0.4.2.tar.gz) = cbd5dea872d3b88d257ee4801b65c86980cbc8d3f25a33893226fc519a0d6c9f
+SIZE (cabal/yesod-platform-1.0.4.2.tar.gz) = 2563
diff --git a/www/hs-yesod-platform/files/patch-yesod-platform.cabal b/www/hs-yesod-platform/files/patch-yesod-platform.cabal
new file mode 100644
index 000000000000..6741f29d012a
--- /dev/null
+++ b/www/hs-yesod-platform/files/patch-yesod-platform.cabal
@@ -0,0 +1,11 @@
+--- ./yesod-platform.cabal.orig 2012-06-01 05:50:37.000000000 +0200
++++ ./yesod-platform.cabal 2012-06-11 02:38:12.000000000 +0200
+@@ -29,7 +29,7 @@
+ , binary == 0.5.1.0
+ , blaze-builder == 0.3.1.0
+ , blaze-builder-conduit == 0.4.0.2
+- , blaze-html == 0.5.0.0
++ , blaze-html == 0.4.3.4
+ , blaze-markup == 0.5.1.0
+ , byteorder == 1.0.3
+ , case-insensitive == 0.4.0.1
diff --git a/www/hs-yesod-platform/pkg-descr b/www/hs-yesod-platform/pkg-descr
new file mode 100644
index 000000000000..6feddde6daee
--- /dev/null
+++ b/www/hs-yesod-platform/pkg-descr
@@ -0,0 +1,4 @@
+Instead of allowing version ranges of dependencies, this package requires
+specific versions to avoid dependency hell.
+
+WWW: http://www.yesodweb.com/