aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/p5-CDB_File-Generator/Makefile2
-rw-r--r--databases/p5-Class-DBI-DDL/Makefile2
-rw-r--r--databases/p5-DBD-Excel/Makefile8
-rw-r--r--databases/p5-DBIx-AnyDBD/Makefile2
-rw-r--r--databases/p5-DBIx-Password/Makefile2
-rw-r--r--databases/p5-DBIx-SQLEngine/Makefile8
-rw-r--r--databases/p5-DBIx-SQLite-Simple/Makefile4
-rw-r--r--databases/p5-Iterator-DBI/Makefile2
-rw-r--r--databases/p5-Metadata/Makefile2
-rw-r--r--databases/p5-T2/Makefile8
-rw-r--r--finance/p5-Business-OnlinePayment-OCV/Makefile4
-rw-r--r--finance/p5-Business-OnlinePayment-iAuthorizer/Makefile2
-rw-r--r--finance/p5-Business-WorldPay-Junior/Makefile6
-rw-r--r--mail/p5-FuzzyOcr/Makefile2
-rw-r--r--mail/p5-LMAP-CID2SPF/Makefile2
15 files changed, 28 insertions, 28 deletions
diff --git a/databases/p5-CDB_File-Generator/Makefile b/databases/p5-CDB_File-Generator/Makefile
index 660f2e5dbeff..7f82ed4f31b2 100644
--- a/databases/p5-CDB_File-Generator/Makefile
+++ b/databases/p5-CDB_File-Generator/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Generate massive sorted CDB files simply
BUILD_DEPENDS= ${LOCALBASE}/bin/cdbmake:${PORTSDIR}/databases/cdb \
- ${SITE_PERL}/${PERL_ARCH}/CDB_File.pm:${PORTSDIR}/databases/p5-CDB_File
+ p5-CDB_File>=0:${PORTSDIR}/databases/p5-CDB_File
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-DDL/Makefile b/databases/p5-Class-DBI-DDL/Makefile
index 2788ca3aefa5..99db065db8b0 100644
--- a/databases/p5-Class-DBI-DDL/Makefile
+++ b/databases/p5-Class-DBI-DDL/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= DDL for Class-DBI
-RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/databases/p5-DBD-Excel/Makefile b/databases/p5-DBD-Excel/Makefile
index fa6d4a37a04f..76544a4c08df 100644
--- a/databases/p5-DBD-Excel/Makefile
+++ b/databases/p5-DBD-Excel/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A class for DBI drivers that acts on Excel files
-BUILD_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
- ${SITE_PERL}/Spreadsheet/ParseExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
- ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-SQL-Statement>=0:${PORTSDIR}/databases/p5-SQL-Statement \
+ p5-Spreadsheet-ParseExcel>=0:${PORTSDIR}/textproc/p5-Spreadsheet-ParseExcel \
+ p5-Spreadsheet-WriteExcel>=0:${PORTSDIR}/textproc/p5-Spreadsheet-WriteExcel \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
EXAMPLESDIR?= ${PREFIX}/share/examples/${PORTNAME}
diff --git a/databases/p5-DBIx-AnyDBD/Makefile b/databases/p5-DBIx-AnyDBD/Makefile
index 757079f302d8..55987a769306 100644
--- a/databases/p5-DBIx-AnyDBD/Makefile
+++ b/databases/p5-DBIx-AnyDBD/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= DBD independent class
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBIx-Password/Makefile b/databases/p5-DBIx-Password/Makefile
index 0e41cd65bdb9..27d2e4ca5031 100644
--- a/databases/p5-DBIx-Password/Makefile
+++ b/databases/p5-DBIx-Password/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to create a global password file for DB passwords
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBIx-SQLEngine/Makefile b/databases/p5-DBIx-SQLEngine/Makefile
index 911e25211392..bb6bbafe3d83 100644
--- a/databases/p5-DBIx-SQLEngine/Makefile
+++ b/databases/p5-DBIx-SQLEngine/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Extends DBI with high-level operations
-BUILD_DEPENDS= ${SITE_PERL}/DBIx/AnyDBD.pm:${PORTSDIR}/databases/p5-DBIx-AnyDBD \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Class/MakeMethods.pm:${PORTSDIR}/devel/p5-Class-MakeMethods \
- ${SITE_PERL}/Class/MixinFactory.pm:${PORTSDIR}/devel/p5-Class-MixinFactory
+BUILD_DEPENDS= p5-DBIx-AnyDBD>=0:${PORTSDIR}/databases/p5-DBIx-AnyDBD \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Class-MakeMethods>=0:${PORTSDIR}/devel/p5-Class-MakeMethods \
+ p5-Class-MixinFactory>=0:${PORTSDIR}/devel/p5-Class-MixinFactory
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBIx-SQLite-Simple/Makefile b/databases/p5-DBIx-SQLite-Simple/Makefile
index c651423965b4..0c883b33242e 100644
--- a/databases/p5-DBIx-SQLite-Simple/Makefile
+++ b/databases/p5-DBIx-SQLite-Simple/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy access to SQLite databases using objects
-BUILD_DEPENDS= ${SITE_PERL}/Class/Gomor.pm:${PORTSDIR}/devel/p5-Class-Gomor \
- ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+BUILD_DEPENDS= p5-Class-Gomor>=0:${PORTSDIR}/devel/p5-Class-Gomor \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Iterator-DBI/Makefile b/databases/p5-Iterator-DBI/Makefile
index fb815c1a7855..db0023db467d 100644
--- a/databases/p5-Iterator-DBI/Makefile
+++ b/databases/p5-Iterator-DBI/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= An iterator for returning DBI query results
-BUILD_DEPENDS= ${SITE_PERL}/Iterator.pm:${PORTSDIR}/devel/p5-Iterator
+BUILD_DEPENDS= p5-Iterator>=0:${PORTSDIR}/devel/p5-Iterator
RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= Iterator::DBI.3
diff --git a/databases/p5-Metadata/Makefile b/databases/p5-Metadata/Makefile
index 64b6b1e3518f..6a5bb38d35b6 100644
--- a/databases/p5-Metadata/Makefile
+++ b/databases/p5-Metadata/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl implementation of Dublin Core compatible metadata
-BUILD_DEPENDS= ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate
+BUILD_DEPENDS= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-T2/Makefile b/databases/p5-T2/Makefile
index 211b3571dfe9..45b4ccecb3ef 100644
--- a/databases/p5-T2/Makefile
+++ b/databases/p5-T2/Makefile
@@ -16,10 +16,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Object Relational mapping system
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Set/Object.pm:${PORTSDIR}/devel/p5-Set-Object \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Tangram.pm:${PORTSDIR}/databases/p5-Tangram \
- ${SITE_PERL}/Class/Tangram.pm:${PORTSDIR}/devel/p5-Class-Tangram
+BUILD_DEPENDS= p5-Set-Object>=0:${PORTSDIR}/devel/p5-Set-Object \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Tangram>=0:${PORTSDIR}/databases/p5-Tangram \
+ p5-Class-Tangram>=0:${PORTSDIR}/devel/p5-Class-Tangram
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-OCV/Makefile b/finance/p5-Business-OnlinePayment-OCV/Makefile
index a84768f25ed9..ed28e9ab4801 100644
--- a/finance/p5-Business-OnlinePayment-OCV/Makefile
+++ b/finance/p5-Business-OnlinePayment-OCV/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for OCV
-BUILD_DEPENDS= ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/Business/OCV.pm:${PORTSDIR}/finance/p5-Business-OCV
+BUILD_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-Business-OCV>=0:${PORTSDIR}/finance/p5-Business-OCV
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/p5-Business-OnlinePayment-iAuthorizer/Makefile b/finance/p5-Business-OnlinePayment-iAuthorizer/Makefile
index bc1878cd2d2a..799cae84c315 100644
--- a/finance/p5-Business-OnlinePayment-iAuthorizer/Makefile
+++ b/finance/p5-Business-OnlinePayment-iAuthorizer/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A Business::OnlinePayment backend module for iAuthorizer
-BUILD_DEPENDS= ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment
+BUILD_DEPENDS= p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment
RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/finance/p5-Business-WorldPay-Junior/Makefile b/finance/p5-Business-WorldPay-Junior/Makefile
index 420e967703d6..f6eff9ab952e 100644
--- a/finance/p5-Business-WorldPay-Junior/Makefile
+++ b/finance/p5-Business-WorldPay-Junior/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module to handle WorldPay Junior for payment services
-BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/finance/p5-Business-CreditCard \
- ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/finance/p5-Business-OnlinePayment \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-Business-CreditCard>=0:${PORTSDIR}/finance/p5-Business-CreditCard \
+ p5-Business-OnlinePayment>=0:${PORTSDIR}/finance/p5-Business-OnlinePayment \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-FuzzyOcr/Makefile b/mail/p5-FuzzyOcr/Makefile
index 983942ea0c0e..9b986abc61e6 100644
--- a/mail/p5-FuzzyOcr/Makefile
+++ b/mail/p5-FuzzyOcr/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
gocr:${PORTSDIR}/graphics/gocr \
gif2ps:${PORTSDIR}/graphics/giflib \
spamassassin:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
- ${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx
+ p5-String-Approx>=0:${PORTSDIR}/devel/p5-String-Approx
CONFLICTS= p5-FuzzyOcr-devel-[0-9]*
diff --git a/mail/p5-LMAP-CID2SPF/Makefile b/mail/p5-LMAP-CID2SPF/Makefile
index ff2f4da8d66a..bbc059d62681 100644
--- a/mail/p5-LMAP-CID2SPF/Makefile
+++ b/mail/p5-LMAP-CID2SPF/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Module to convert between Microsoft's Caller-ID and SPF #'
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
PERL_CONFIGURE= yes
CONFIGURE_SCRIPT=Makefile.PL