aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/synfig/Makefile2
-rw-r--r--graphics/synfigstudio/Makefile1
-rw-r--r--multimedia/kdenlive-kde4/Makefile2
-rw-r--r--multimedia/kdenlive/Makefile2
-rw-r--r--multimedia/mlt-qt4/Makefile6
-rw-r--r--multimedia/mlt-qt5/Makefile3
-rw-r--r--multimedia/mlt/Makefile19
-rw-r--r--multimedia/mlt/distinfo6
-rw-r--r--multimedia/mlt/files/patch-git_0c0954428
-rw-r--r--multimedia/mlt/files/patch-git_541b083120
-rw-r--r--multimedia/mlt/files/patch-git_92bd4d229
-rw-r--r--multimedia/mlt/files/patch-git_9a95592260
-rw-r--r--multimedia/mlt/files/patch-git_9ec2ab953
-rw-r--r--multimedia/mlt/files/patch-git_d4feda934
-rw-r--r--multimedia/mlt/files/patch-git_d7a54ad_fc1e7fd72
-rw-r--r--multimedia/mlt/files/patch-src_modules_qt_configure36
-rw-r--r--multimedia/mlt/files/patch-src_modules_qt_consumer__qglsl.cpp20
-rw-r--r--multimedia/py-mlt/Makefile1
-rw-r--r--multimedia/webvfx-qt5/Makefile2
19 files changed, 26 insertions, 670 deletions
diff --git a/devel/synfig/Makefile b/devel/synfig/Makefile
index ca46fc23b6e8..c3bc6db832c0 100644
--- a/devel/synfig/Makefile
+++ b/devel/synfig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= synfig
PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel graphics multimedia
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/source
diff --git a/graphics/synfigstudio/Makefile b/graphics/synfigstudio/Makefile
index b07d5f4af2cf..75546c994a58 100644
--- a/graphics/synfigstudio/Makefile
+++ b/graphics/synfigstudio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= synfigstudio
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= graphics multimedia
MASTER_SITES= SF/synfig/releases/${PORTVERSION}/source
diff --git a/multimedia/kdenlive-kde4/Makefile b/multimedia/kdenlive-kde4/Makefile
index be4eb8f107bf..a785cdd7cacb 100644
--- a/multimedia/kdenlive-kde4/Makefile
+++ b/multimedia/kdenlive-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kdenlive
PORTVERSION= 0.9.10
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src/
PKGNAMESUFFIX= -kde4
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index c0dcb02f154a..cda675339e4e 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kdenlive
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/multimedia/mlt-qt4/Makefile b/multimedia/mlt-qt4/Makefile
index 4134a33f9b4c..6d8ce848b403 100644
--- a/multimedia/mlt-qt4/Makefile
+++ b/multimedia/mlt-qt4/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 0
CONFLICTS_INSTALL= ${PORTNAME}-qt5-*
@@ -10,12 +10,14 @@ SLAVEPORT= qt4
PLIST= ${MASTERDIR}-qt5/pkg-plist
+USE_XORG= x11
+
OPTIONS_DEFINE= KDE4
KDE4_DESC= Extra image formats
KDE4_CONFIGURE_ENV= PATH="${KDE_PREFIX}/bin:$$PATH"
KDE4_CONFIGURE_WITH= kde
KDE4_USES= kde:4
-KDE4_USE= KDE=kdelibs
+KDE4_USE= KDE=kdelibs
.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/mlt-qt5/Makefile b/multimedia/mlt-qt5/Makefile
index aa916ed24bcc..77acbb9e4ce4 100644
--- a/multimedia/mlt-qt5/Makefile
+++ b/multimedia/mlt-qt5/Makefile
@@ -1,11 +1,12 @@
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 0
CONFLICTS_INSTALL= ${PORTNAME}-qt4-*
USE_CXXSTD= c++11
USE_QT5= core gui svg widgets xml
+USE_XORG= x11
MASTERDIR= ${.CURDIR:H}/mlt
SLAVEPORT= qt5
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index 4c8b731b1ef9..7709d06e5704 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -1,20 +1,22 @@
# $FreeBSD$
PORTNAME= mlt
-PORTVERSION= 6.4.1
-PORTREVISION?= 8
+DISTVERSIONPREFIX= v
+DISTVERSION= 6.6.0
+PORTREVISION?= 0
CATEGORIES?= multimedia
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
-MAINTAINER?= avilla@FreeBSD.org
+MAINTAINER= avilla@FreeBSD.org
COMMENT?= Multimedia framework for TV broadcasting
LICENSE?= GPLv2 GPLv3 LGPL21
LICENSE_COMB?= multi
-USES+= alias eigen:3 gmake pkgconfig
+USES+= alias eigen:3 gmake localbase pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-gpl --enable-gpl3 --target-os=FreeBSD
+USE_GITHUB= yes
+GH_ACCOUNT= mltframework
.ifndef(WITH_DEBUG)
CONFIGURE_ARGS+=--disable-debug
@@ -31,6 +33,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3
BROKEN_sparc64= does not compile on sparc64 (invokes i386 asm)
+USE_GL= gl
USE_GNOME= libxml2
USE_SDL= image
USE_XORG= x11
@@ -61,7 +64,8 @@ FFMPEG_CONFIGURE_ON= --avformat-suffix="${FFMPEG_SUFX}"
FREI0R_BUILD_DEPENDS= ${LOCALBASE}/include/frei0r.h:graphics/frei0r
FREI0R_CONFIGURE_ENABLE=frei0r
-GTK2_LIB_DEPENDS= libexif.so:graphics/libexif
+GTK2_LIB_DEPENDS= libexif.so:graphics/libexif \
+ libfontconfig.so:x11-fonts/fontconfig
GTK2_USE= GNOME=gdkpixbuf2,gtk20,pango
GTK2_CONFIGURE_ENABLE= gtk2
@@ -74,7 +78,8 @@ JACK_USE= GNOME=glib20
CONFIGURE_ARGS+= --disable-opencv
OPENCV_CONFIGURE_ENABLE=opencv
-OPENGL_LIB_DEPENDS= libmovit.so:graphics/movit
+OPENGL_LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libmovit.so:graphics/movit
OPENGL_USE= GL=gl
OPENGL_CONFIGURE_ENABLE=opengl
diff --git a/multimedia/mlt/distinfo b/multimedia/mlt/distinfo
index 988739d430a1..15b891d46772 100644
--- a/multimedia/mlt/distinfo
+++ b/multimedia/mlt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482224942
-SHA256 (mlt-6.4.1.tar.gz) = d3a992f3e67463e68630cb0b455d408a2a12f4da7a19e46807fa08a79f09b2b6
-SIZE (mlt-6.4.1.tar.gz) = 1344030
+TIMESTAMP = 1522500982
+SHA256 (mltframework-mlt-v6.6.0_GH0.tar.gz) = 11515546516b3c54719b6b402cacf46e8d5172450d6e9fe2655b237582490315
+SIZE (mltframework-mlt-v6.6.0_GH0.tar.gz) = 1365768
diff --git a/multimedia/mlt/files/patch-git_0c09544 b/multimedia/mlt/files/patch-git_0c09544
deleted file mode 100644
index 68fec46e877d..000000000000
--- a/multimedia/mlt/files/patch-git_0c09544
+++ /dev/null
@@ -1,28 +0,0 @@
-From 0c09544aafdd01477326fea971881a01834f93af Mon Sep 17 00:00:00 2001
-From: Alberto Villa <avilla@FreeBSD.org>
-Date: Fri, 23 Dec 2016 03:13:55 +0100
-Subject: [PATCH] Use Movit CFLAGS even when building *.c files
-
----
- src/modules/opengl/Makefile | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/modules/opengl/Makefile b/src/modules/opengl/Makefile
-index 09e403f7..ffe542b1 100644
---- ./src/modules/opengl/Makefile
-+++ ./src/modules/opengl/Makefile
-@@ -29,8 +29,9 @@ CPPOBJS += transition_movit_luma.o
- CPPOBJS += transition_movit_mix.o
- CPPOBJS += transition_movit_overlay.o
-
--CXXFLAGS := -Wno-deprecated $(CFLAGS) $(CXXFLAGS)
--CXXFLAGS += $(shell pkg-config --cflags movit 2> /dev/null)
-+CFLAGS += -Wno-deprecated
-+CFLAGS += $(shell pkg-config --cflags movit 2> /dev/null)
-+CXXFLAGS += $(CFLAGS)
-
- SHADERDIR = $(shell pkg-config --variable=shaderdir movit)
- CXXFLAGS += -DSHADERDIR=\"$(SHADERDIR)\"
---
-2.11.0
-
diff --git a/multimedia/mlt/files/patch-git_541b083 b/multimedia/mlt/files/patch-git_541b083
deleted file mode 100644
index 0578c5f8cb7b..000000000000
--- a/multimedia/mlt/files/patch-git_541b083
+++ /dev/null
@@ -1,120 +0,0 @@
-From 541b083252c85a4990851c76321fac0cca50f283 Mon Sep 17 00:00:00 2001
-From: Dan Dennedy <dan@dennedy.org>
-Date: Sun, 26 Mar 2017 19:01:11 -0700
-Subject: [PATCH] Prefer the "AV" namespaced CODEC flags.
-
-Fixes build against libav master, which has removed the old flags.
----
- src/modules/avformat/consumer_avformat.c | 33 +++++++++++++++---------
- 1 file changed, 21 insertions(+), 12 deletions(-)
-
-diff --git src/modules/avformat/consumer_avformat.c src/modules/avformat/consumer_avformat.c
-index 43d4e44e..8414f18a 100644
---- src/modules/avformat/consumer_avformat.c
-+++ src/modules/avformat/consumer_avformat.c
-@@ -1,6 +1,6 @@
- /*
- * consumer_avformat.c -- an encoder based on avformat
-- * Copyright (C) 2003-2015 Meltytech, LLC
-+ * Copyright (C) 2003-2017 Meltytech, LLC
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
-@@ -55,6 +55,15 @@
- #define AV_CODEC_ID_MJPEG CODEC_ID_MJPEG
- #endif
-
-+#ifndef AV_CODEC_FLAG_GLOBAL_HEADER
-+#define AV_CODEC_FLAG_GLOBAL_HEADER CODEC_FLAG_GLOBAL_HEADER
-+#define AV_CODEC_FLAG_QSCALE CODEC_FLAG_QSCALE
-+#define AV_CODEC_FLAG_INTERLACED_DCT CODEC_FLAG_INTERLACED_DCT
-+#define AV_CODEC_FLAG_INTERLACED_ME CODEC_FLAG_INTERLACED_ME
-+#define AV_CODEC_FLAG_PASS1 CODEC_FLAG_PASS1
-+#define AV_CODEC_FLAG_PASS2 CODEC_FLAG_PASS2
-+#endif
-+
- #define MAX_AUDIO_STREAMS (8)
- #define AUDIO_ENCODE_BUFFER_SIZE (48000 * 2 * MAX_AUDIO_STREAMS)
- #define AUDIO_BUFFER_SIZE (1024 * 42)
-@@ -585,7 +594,7 @@ static AVStream *add_audio_stream( mlt_consumer consumer, AVFormatContext *oc, A
- #endif
-
- if (oc->oformat->flags & AVFMT_GLOBALHEADER)
-- c->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
-
- // Allow the user to override the audio fourcc
- if ( mlt_properties_get( properties, "atag" ) )
-@@ -611,7 +620,7 @@ static AVStream *add_audio_stream( mlt_consumer consumer, AVFormatContext *oc, A
- int audio_qscale = mlt_properties_get_int( properties, "aq" );
- if ( audio_qscale > QSCALE_NONE )
- {
-- c->flags |= CODEC_FLAG_QSCALE;
-+ c->flags |= AV_CODEC_FLAG_QSCALE;
- c->global_quality = FF_QP2LAMBDA * audio_qscale;
- }
-
-@@ -710,7 +719,7 @@ static int open_audio( mlt_properties properties, AVFormatContext *oc, AVStream
- if ( !strcmp( oc->oformat->name, "mp4" ) ||
- !strcmp( oc->oformat->name, "mov" ) ||
- !strcmp( oc->oformat->name, "3gp" ) )
-- c->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
- }
- else
- {
-@@ -842,7 +851,7 @@ static AVStream *add_video_stream( mlt_consumer consumer, AVFormatContext *oc, A
-
- if ( mlt_properties_get_double( properties, "qscale" ) > 0 )
- {
-- c->flags |= CODEC_FLAG_QSCALE;
-+ c->flags |= AV_CODEC_FLAG_QSCALE;
- c->global_quality = FF_QP2LAMBDA * mlt_properties_get_double( properties, "qscale" );
- }
-
-@@ -859,16 +868,16 @@ static AVStream *add_video_stream( mlt_consumer consumer, AVFormatContext *oc, A
-
- // Some formats want stream headers to be seperate
- if ( oc->oformat->flags & AVFMT_GLOBALHEADER )
-- c->flags |= CODEC_FLAG_GLOBAL_HEADER;
-+ c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
-
- // Translate these standard mlt consumer properties to ffmpeg
- if ( mlt_properties_get_int( properties, "progressive" ) == 0 &&
- mlt_properties_get_int( properties, "deinterlace" ) == 0 )
- {
- if ( ! mlt_properties_get( properties, "ildct" ) || mlt_properties_get_int( properties, "ildct" ) )
-- c->flags |= CODEC_FLAG_INTERLACED_DCT;
-+ c->flags |= AV_CODEC_FLAG_INTERLACED_DCT;
- if ( ! mlt_properties_get( properties, "ilme" ) || mlt_properties_get_int( properties, "ilme" ) )
-- c->flags |= CODEC_FLAG_INTERLACED_ME;
-+ c->flags |= AV_CODEC_FLAG_INTERLACED_ME;
- }
-
- // parse the ratecontrol override string
-@@ -905,13 +914,13 @@ static AVStream *add_video_stream( mlt_consumer consumer, AVFormatContext *oc, A
- // Setup dual-pass
- i = mlt_properties_get_int( properties, "pass" );
- if ( i == 1 )
-- c->flags |= CODEC_FLAG_PASS1;
-+ c->flags |= AV_CODEC_FLAG_PASS1;
- else if ( i == 2 )
-- c->flags |= CODEC_FLAG_PASS2;
-+ c->flags |= AV_CODEC_FLAG_PASS2;
- #ifdef AV_CODEC_ID_H265
- if ( codec->id != AV_CODEC_ID_H265 )
- #endif
-- if ( codec->id != AV_CODEC_ID_H264 && ( c->flags & ( CODEC_FLAG_PASS1 | CODEC_FLAG_PASS2 ) ) )
-+ if ( codec->id != AV_CODEC_ID_H264 && ( c->flags & ( AV_CODEC_FLAG_PASS1 | AV_CODEC_FLAG_PASS2 ) ) )
- {
- FILE *f;
- int size;
-@@ -926,7 +935,7 @@ static AVStream *add_video_stream( mlt_consumer consumer, AVFormatContext *oc, A
- mlt_properties_from_utf8( properties, "_passlogfile", "_logfilename" );
- }
- const char *filename = mlt_properties_get( properties, "_logfilename" );
-- if ( c->flags & CODEC_FLAG_PASS1 )
-+ if ( c->flags & AV_CODEC_FLAG_PASS1 )
- {
- f = fopen( filename, "w" );
- if ( !f )
diff --git a/multimedia/mlt/files/patch-git_92bd4d2 b/multimedia/mlt/files/patch-git_92bd4d2
deleted file mode 100644
index ab0bb457ed20..000000000000
--- a/multimedia/mlt/files/patch-git_92bd4d2
+++ /dev/null
@@ -1,29 +0,0 @@
-From 92bd4d2f83827c49b8d826d47b11c63f51e0c67e Mon Sep 17 00:00:00 2001
-From: Alberto Villa <avilla@FreeBSD.org>
-Date: Tue, 20 Dec 2016 15:15:52 +0100
-Subject: [PATCH] Use Vid.Stab CFLAGS even when building *.c files
-
-common.c build is failing as it requires a header from Vid.Stab.
----
- src/modules/vid.stab/Makefile | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/modules/vid.stab/Makefile b/src/modules/vid.stab/Makefile
-index 7f829f84..0a9e0063 100644
---- ./src/modules/vid.stab/Makefile
-+++ ./src/modules/vid.stab/Makefile
-@@ -12,8 +12,9 @@ OBJS = factory.o \
- CPPOBJS = filter_deshake.o
- CPPOBJS += filter_vidstab.o
-
--CXXFLAGS += -Wno-deprecated $(CFLAGS)
--CXXFLAGS += $(shell pkg-config --cflags vidstab)
-+CFLAGS += -Wno-deprecated
-+CFLAGS += $(shell pkg-config --cflags vidstab)
-+CXXFLAGS += $(CFLAGS)
-
- LDFLAGS += -L../../mlt++ -lmlt++
- LDFLAGS += $(shell pkg-config --libs vidstab)
---
-2.11.0
-
diff --git a/multimedia/mlt/files/patch-git_9a95592 b/multimedia/mlt/files/patch-git_9a95592
deleted file mode 100644
index e264a356da0d..000000000000
--- a/multimedia/mlt/files/patch-git_9a95592
+++ /dev/null
@@ -1,260 +0,0 @@
-From 9a955928355788e12054a22f1731a31e1a4cce34 Mon Sep 17 00:00:00 2001
-From: Dan Dennedy <dan@dennedy.org>
-Date: Mon, 23 Oct 2017 20:17:40 -0700
-Subject: [PATCH] Remove filter_avresample - dropped by FFmpeg.
-
----
- src/modules/avformat/Makefile | 1 -
- src/modules/avformat/factory.c | 10 +-
- src/modules/avformat/filter_avresample.c | 175 -----------------------
- src/modules/core/loader.ini | 2 +-
- 4 files changed, 2 insertions(+), 186 deletions(-)
- delete mode 100644 src/modules/avformat/filter_avresample.c
-
-diff --git src/modules/avformat/Makefile src/modules/avformat/Makefile
-index 5d0e0e26..21bbe4cb 100644
---- src/modules/avformat/Makefile
-+++ src/modules/avformat/Makefile
-@@ -16,7 +16,6 @@ OBJS = factory.o
-
- ifdef FILTERS
- OBJS += filter_avcolour_space.o \
-- filter_avresample.o \
- filter_avdeinterlace.o \
- filter_swscale.o
- CFLAGS += -DFILTERS
-diff --git src/modules/avformat/factory.c src/modules/avformat/factory.c
-index 7485a87a..785a6fe5 100644
---- src/modules/avformat/factory.c
-+++ src/modules/avformat/factory.c
-@@ -1,6 +1,6 @@
- /*
- * factory.c -- the factory method interfaces
-- * Copyright (C) 2003-2016 Meltytech, LLC
-+ * Copyright (C) 2003-2017 Meltytech, LLC
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
-@@ -27,7 +27,6 @@
- extern mlt_consumer consumer_avformat_init( mlt_profile profile, char *file );
- extern mlt_filter filter_avcolour_space_init( void *arg );
- extern mlt_filter filter_avdeinterlace_init( void *arg );
--extern mlt_filter filter_avresample_init( char *arg );
- extern mlt_filter filter_swscale_init( mlt_profile profile, char *arg );
- extern mlt_producer producer_avformat_init( mlt_profile profile, const char *service, char *file );
- extern mlt_filter filter_avfilter_init( mlt_profile, mlt_service_type, const char*, char* );
-@@ -125,10 +124,6 @@ static void *create_service( mlt_profile profile, mlt_service_type type, const c
- return filter_avcolour_space_init( arg );
- if ( !strcmp( id, "avdeinterlace" ) )
- return filter_avdeinterlace_init( arg );
--#if defined(FFUDIV)
-- if ( !strcmp( id, "avresample" ) )
-- return filter_avresample_init( arg );
--#endif
- if ( !strcmp( id, "swscale" ) )
- return filter_swscale_init( profile, arg );
- #endif
-@@ -409,9 +404,6 @@ MLT_REPOSITORY
- MLT_REGISTER( filter_type, "avcolour_space", create_service );
- MLT_REGISTER( filter_type, "avcolor_space", create_service );
- MLT_REGISTER( filter_type, "avdeinterlace", create_service );
--#if defined(FFUDIV)
-- MLT_REGISTER( filter_type, "avresample", create_service );
--#endif
- MLT_REGISTER( filter_type, "swscale", create_service );
-
- #ifdef AVFILTER
-diff --git src/modules/avformat/filter_avresample.c src/modules/avformat/filter_avresample.c
-deleted file mode 100644
-index 80f45128..00000000
---- src/modules/avformat/filter_avresample.c
-+++ /dev/null
-@@ -1,175 +0,0 @@
--/*
-- * filter_avresample.c -- adjust audio sample frequency
-- * Copyright (C) 2003-2014 Meltytech, LLC
-- *
-- * This library is free software; you can redistribute it and/or
-- * modify it under the terms of the GNU Lesser General Public
-- * License as published by the Free Software Foundation; either
-- * version 2.1 of the License, or (at your option) any later version.
-- *
-- * This library is distributed in the hope that it will be useful,
-- * but WITHOUT ANY WARRANTY; without even the implied warranty of
-- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-- * Lesser General Public License for more details.
-- *
-- * You should have received a copy of the GNU Lesser General Public
-- * License along with this library; if not, write to the Free Software
-- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-- */
--
--#include <framework/mlt_filter.h>
--#include <framework/mlt_frame.h>
--#include <framework/mlt_log.h>
--
--#include <stdio.h>
--#include <stdlib.h>
--#include <string.h>
--
--// ffmpeg Header files
--#include <libavformat/avformat.h>
--#include <libavutil/samplefmt.h>
--
--#if defined(FFUDIV)
--
--#define MAX_AUDIO_FRAME_SIZE (192000) // 1 second of 48khz 32bit audio
--
--
--/** Get the audio.
--*/
--
--static int resample_get_audio( mlt_frame frame, void **buffer, mlt_audio_format *format, int *frequency, int *channels, int *samples )
--{
-- // Get the filter service
-- mlt_filter filter = mlt_frame_pop_audio( frame );
--
-- // Get the filter properties
-- mlt_properties filter_properties = MLT_FILTER_PROPERTIES( filter );
--
-- mlt_service_lock( MLT_FILTER_SERVICE( filter ) );
--
-- // Get the resample information
-- int output_rate = mlt_properties_get_int( filter_properties, "frequency" );
-- int16_t *sample_buffer = mlt_properties_get_data( filter_properties, "buffer", NULL );
--
-- // Obtain the resample context if it exists
-- ReSampleContext *resample = mlt_properties_get_data( filter_properties, "audio_resample", NULL );
--
-- // If no resample frequency is specified, default to requested value
-- if ( output_rate == 0 )
-- output_rate = *frequency;
--
-- // Get the producer's audio
-- int error = mlt_frame_get_audio( frame, buffer, format, frequency, channels, samples );
-- if ( error ) return error;
--
-- // Return now if no work to do
-- if ( output_rate != *frequency )
-- {
-- // Will store number of samples created
-- int used = 0;
--
-- mlt_log_debug( MLT_FILTER_SERVICE(filter), "channels %d samples %d frequency %d -> %d\n",
-- *channels, *samples, *frequency, output_rate );
--
-- // Do not convert to s16 unless we need to change the rate
-- if ( *format != mlt_audio_s16 )
-- {
-- *format = mlt_audio_s16;
-- mlt_frame_get_audio( frame, buffer, format, frequency, channels, samples );
-- }
--
-- // Create a resampler if nececessary
-- if ( resample == NULL || *frequency != mlt_properties_get_int( filter_properties, "last_frequency" ) )
-- {
-- // Create the resampler
-- resample = av_audio_resample_init( *channels, *channels, output_rate, *frequency,
-- AV_SAMPLE_FMT_S16, AV_SAMPLE_FMT_S16, 16, 10, 0, 0.8 );
--
-- // And store it on properties
-- mlt_properties_set_data( filter_properties, "audio_resample", resample, 0, ( mlt_destructor )audio_resample_close, NULL );
--
-- // And remember what it was created for
-- mlt_properties_set_int( filter_properties, "last_frequency", *frequency );
-- }
--
-- mlt_service_unlock( MLT_FILTER_SERVICE( filter ) );
--
-- // Resample the audio
-- used = audio_resample( resample, sample_buffer, *buffer, *samples );
-- int size = used * *channels * sizeof( int16_t );
--
-- // Resize if necessary
-- if ( used > *samples )
-- {
-- *buffer = mlt_pool_realloc( *buffer, size );
-- mlt_frame_set_audio( frame, *buffer, *format, size, mlt_pool_release );
-- }
--
-- // Copy samples
-- memcpy( *buffer, sample_buffer, size );
--
-- // Update output variables
-- *samples = used;
-- *frequency = output_rate;
-- }
-- else
-- {
-- mlt_service_unlock( MLT_FILTER_SERVICE( filter ) );
-- }
--
-- return error;
--}
--
--/** Filter processing.
--*/
--
--static mlt_frame filter_process( mlt_filter filter, mlt_frame frame )
--{
-- // Only call this if we have a means to get audio
-- if ( mlt_frame_is_test_audio( frame ) == 0 )
-- {
-- // Push the filter on to the stack
-- mlt_frame_push_audio( frame, filter );
--
-- // Assign our get_audio method
-- mlt_frame_push_audio( frame, resample_get_audio );
-- }
--
-- return frame;
--}
--
--/** Constructor for the filter.
--*/
--
--mlt_filter filter_avresample_init( char *arg )
--{
-- // Create a filter
-- mlt_filter filter = mlt_filter_new( );
--
-- // Initialise if successful
-- if ( filter != NULL )
-- {
-- // Calculate size of the buffer
-- int size = MAX_AUDIO_FRAME_SIZE * sizeof( int16_t );
--
-- // Allocate the buffer
-- int16_t *buffer = mlt_pool_alloc( size );
--
-- // Assign the process method
-- filter->process = filter_process;
--
-- // Deal with argument
-- if ( arg != NULL )
-- mlt_properties_set( MLT_FILTER_PROPERTIES( filter ), "frequency", arg );
--
-- // Default to 2 channel output
-- mlt_properties_set_int( MLT_FILTER_PROPERTIES( filter ), "channels", 2 );
--
-- // Store the buffer
-- mlt_properties_set_data( MLT_FILTER_PROPERTIES( filter ), "buffer", buffer, size, mlt_pool_release, NULL );
-- }
--
-- return filter;
--}
--
--#endif // defined(FFUDIV)
-diff --git src/modules/core/loader.ini src/modules/core/loader.ini
-index c586a176..b3a5653d 100644
---- src/modules/core/loader.ini
-+++ src/modules/core/loader.ini
-@@ -15,7 +15,7 @@ resizer=movit.resize,resize
-
- # audio filters
- channels=audiochannels
--resampler=resample,avresample
-+resampler=resample
-
- # metadata filters
- data=data_feed:attr_check
diff --git a/multimedia/mlt/files/patch-git_9ec2ab9 b/multimedia/mlt/files/patch-git_9ec2ab9
deleted file mode 100644
index 578175e051cb..000000000000
--- a/multimedia/mlt/files/patch-git_9ec2ab9
+++ /dev/null
@@ -1,53 +0,0 @@
-From 9ec2ab9780282412e42a39d14dced7deade201eb Mon Sep 17 00:00:00 2001
-From: Dan Dennedy <dan@dennedy.org>
-Date: Mon, 23 Oct 2017 20:19:12 -0700
-Subject: [PATCH] Fix FFmpeg master removed AVFMT_RAWPICTURE.
-
----
- .gitignore | 3 +++
- src/modules/avformat/consumer_avformat.c | 6 ++++++
- 2 files changed, 9 insertions(+)
-
-diff --git .gitignore .gitignore
-index 01284bf3..3564a00f 100644
---- .gitignore
-+++ .gitignore
-@@ -31,3 +31,6 @@ mlt-config
- packages.dat
- make.inc
- src/examples/play
-+*.dot
-+*.rej
-+
-diff --git src/modules/avformat/consumer_avformat.c src/modules/avformat/consumer_avformat.c
-index b18b8752..49872225 100644
---- src/modules/avformat/consumer_avformat.c
-+++ src/modules/avformat/consumer_avformat.c
-@@ -1817,6 +1817,7 @@ static void *consumer_thread( void *arg )
- }
- }
-
-+#ifdef AVFMT_RAWPICTURE
- if (oc->oformat->flags & AVFMT_RAWPICTURE)
- {
- // raw video case. The API will change slightly in the near future for that
-@@ -1836,6 +1837,7 @@ static void *consumer_thread( void *arg )
- ret = av_write_frame(oc, &pkt);
- }
- else
-+#endif
- {
- AVPacket pkt;
- av_init_packet( &pkt );
-@@ -2029,7 +2031,11 @@ static void *consumer_thread( void *arg )
- }
-
- // Flush video
-+#ifdef AVFMT_RAWPICTURE
- if ( video_st && !( oc->oformat->flags & AVFMT_RAWPICTURE ) ) for (;;)
-+#else
-+ if ( video_st ) for (;;)
-+#endif
- {
- AVCodecContext *c = video_st->codec;
- AVPacket pkt;
diff --git a/multimedia/mlt/files/patch-git_d4feda9 b/multimedia/mlt/files/patch-git_d4feda9
deleted file mode 100644
index 42cc3b74b1d0..000000000000
--- a/multimedia/mlt/files/patch-git_d4feda9
+++ /dev/null
@@ -1,34 +0,0 @@
-From d4feda920a9ea43ba5fcea4de9cb1e48cf08af90 Mon Sep 17 00:00:00 2001
-From: Alberto Villa <avilla@FreeBSD.org>
-Date: Tue, 20 Dec 2016 15:06:48 +0100
-Subject: [PATCH] Fix FreeType header inclusion
-
-As stated in freetype.h:
-
- Please always use macros to include FreeType header files.
- Example:
- #include <ft2build.h>
- #include FT_FREETYPE_H
-
-This also fixes the build on FreeBSD.
----
- src/modules/gtk2/producer_pango.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/modules/gtk2/producer_pango.c b/src/modules/gtk2/producer_pango.c
-index 7c5d8d2a..ef6f1a28 100644
---- ./src/modules/gtk2/producer_pango.c
-+++ ./src/modules/gtk2/producer_pango.c
-@@ -25,7 +25,8 @@
- #include <string.h>
- #include <gdk-pixbuf/gdk-pixbuf.h>
- #include <pango/pangoft2.h>
--#include <freetype.h>
-+#include <ft2build.h>
-+#include FT_FREETYPE_H
- #include <iconv.h>
- #include <pthread.h>
- #include <ctype.h>
---
-2.11.0
-
diff --git a/multimedia/mlt/files/patch-git_d7a54ad_fc1e7fd b/multimedia/mlt/files/patch-git_d7a54ad_fc1e7fd
deleted file mode 100644
index 37517466fa36..000000000000
--- a/multimedia/mlt/files/patch-git_d7a54ad_fc1e7fd
+++ /dev/null
@@ -1,72 +0,0 @@
-From d7a54ad53cd3bc1d50bf09a7cab682ed7aa0534b Mon Sep 17 00:00:00 2001
-From: Alberto Villa <avilla@FreeBSD.org>
-Date: Tue, 20 Dec 2016 14:33:42 +0100
-Subject: [PATCH 1/2] Ensure KDE 4 code is built when requested
-
-This fixes commit 6f8293d, which was incomplete.
----
- src/modules/qt/configure | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/modules/qt/configure b/src/modules/qt/configure
-index 1070bb19..57340182 100755
---- ./src/modules/qt/configure
-+++ ./src/modules/qt/configure
-@@ -195,9 +195,9 @@ else
- if [ -d "$kde_includedir" ] && [ -d "$kde_libdir" ]
- then
- echo "- KDE version 4.x detected, will enable extra image formats"
-- echo "#define USE_KDE4" >> config.h
- echo "USE_KDE4=1" >> config.mak
- echo KDECXXFLAGS=-I$kde_includedir >> config.mak
-+ echo KDECXXFLAGS += -DUSE_KDE4 >> config.mak
- # the -L with kde4/devel is for Fedora
- echo KDELIBS=-L$kde_libdir -L${kde_libdir}/kde4/devel -lkdecore >> config.mak
- fi
---
-2.11.0
-
-From fc1e7fd095ac8607aa970e65e1060073d025e782 Mon Sep 17 00:00:00 2001
-From: Alberto Villa <avilla@FreeBSD.org>
-Date: Tue, 20 Dec 2016 14:55:55 +0100
-Subject: [PATCH 2/2] Properly make KDE code depend on Qt 4
-
-qt4_found was removed in 51b5668. Checking for it always returns
-false, thus disabling KDE code in every build. Just copy the logic
-from above.
----
- src/modules/qt/configure | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/modules/qt/configure b/src/modules/qt/configure
-index 57340182..24803baf 100755
---- ./src/modules/qt/configure
-+++ ./src/modules/qt/configure
-@@ -148,6 +148,7 @@ else
- if [ $? -eq 0 ]
- then
- echo "- Qt version 5.x detected"
-+ without_kde=true
- echo QTCXXFLAGS=$(pkg-config --cflags Qt5Core Qt5Gui Qt5Xml Qt5Svg Qt5Widgets) >> config.mak
- echo QTLIBS=$(pkg-config --libs Qt5Core Qt5Gui Qt5Xml Qt5Svg Qt5Widgets) >> config.mak
- pkg-config --exists 'Qt5OpenGL'
-@@ -169,6 +170,7 @@ else
- else
- echo "- Qt not found - disabling"
- touch ../disable-qt
-+ exit 0
- fi
- fi
- fi
-@@ -181,7 +183,7 @@ else
- if [ "$without_kde" = "" ]
- then
- kde4-config
-- if [ $? -eq 0 ] && [ "$qt4_found" != "" ]
-+ if [ $? -eq 0 ]
- then
- # test if we have KDE4, required on some systems to get Qt extra formats (xcf, ...)
- if [ "$kde_includedir" = "" ]
---
-2.11.0
-
diff --git a/multimedia/mlt/files/patch-src_modules_qt_configure b/multimedia/mlt/files/patch-src_modules_qt_configure
deleted file mode 100644
index 73605e576442..000000000000
--- a/multimedia/mlt/files/patch-src_modules_qt_configure
+++ /dev/null
@@ -1,36 +0,0 @@
- src/modules/qt/configure | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- src/modules/qt/configure.orig 2016-12-20 14:22:22 UTC
-+++ src/modules/qt/configure
-@@ -107,14 +107,6 @@ else
- then
- echo QTCXXFLAGS=-I$qt_includedir -I$qt_includedir/QtCore -I$qt_includedir/QtGui -I$qt_includedir/QtXml -I$qt_includedir/QtSvg -I$qt_includedir/QtWidgets >> config.mak
- echo QTLIBS=-Wl,-rpath-link,"$qt_libdir" -L"$qt_libdir" -lQt5Core -lQt5Gui -lQt5Xml -lQt5Svg -lQt5Widgets >> config.mak
-- if [ -f "$qt_libdir/libQt5OpenGL.so" ] || [ -f "$qt_libdir/libQt5OpenGL.a" ]
-- then
-- echo QTCXXFLAGS+=-I$qt_includedir/QtOpenGL >> config.mak
-- echo QTLIBS+=-lQt5OpenGL >> config.mak
-- else
-- echo "- Qt5OpenGL not found: disabling"
-- without_opengl=true
-- fi
- # Qt5 on OS X
- elif [ -d "$qt_libdir/QtWidgets.framework" ]
- then
-@@ -151,15 +143,6 @@ else
- without_kde=true
- echo QTCXXFLAGS=$(pkg-config --cflags Qt5Core Qt5Gui Qt5Xml Qt5Svg Qt5Widgets) >> config.mak
- echo QTLIBS=$(pkg-config --libs Qt5Core Qt5Gui Qt5Xml Qt5Svg Qt5Widgets) >> config.mak
-- pkg-config --exists 'Qt5OpenGL'
-- if [ $? -eq 0 ]
-- then
-- echo QTCXXFLAGS+=$(pkg-config --cflags Qt5OpenGL) >> config.mak
-- echo QTLIBS+=$(pkg-config --libs Qt5OpenGL) >> config.mak
-- else
-- echo "- Qt5OpenGL not found: disabling"
-- without_opengl=true
-- fi
- else
- pkg-config --exists 'QtGui >= 4'
- if [ $? -eq 0 ]
diff --git a/multimedia/mlt/files/patch-src_modules_qt_consumer__qglsl.cpp b/multimedia/mlt/files/patch-src_modules_qt_consumer__qglsl.cpp
deleted file mode 100644
index 49fbad325ca2..000000000000
--- a/multimedia/mlt/files/patch-src_modules_qt_consumer__qglsl.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/modules/qt/consumer_qglsl.cpp.orig 2016-11-16 06:53:11 UTC
-+++ src/modules/qt/consumer_qglsl.cpp
-@@ -20,13 +20,14 @@
- #include "common.h"
- #include <framework/mlt.h>
- #include <QApplication>
--#include <QGLWidget>
--#include <QMutex>
--#include <QWaitCondition>
- #include <QtGlobal>
-
- #if QT_VERSION < QT_VERSION_CHECK(5, 0, 0)
-
-+#include <QGLWidget>
-+#include <QMutex>
-+#include <QWaitCondition>
-+
- class GLWidget : public QGLWidget
- {
- private:
diff --git a/multimedia/py-mlt/Makefile b/multimedia/py-mlt/Makefile
index de31dafb15ac..82e771e2eac7 100644
--- a/multimedia/py-mlt/Makefile
+++ b/multimedia/py-mlt/Makefile
@@ -1,7 +1,6 @@
# Created by: Charlie Kester <corky1951@comcast.net>
# $FreeBSD$
-PORTREVISION= 2
CATEGORIES= multimedia python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/multimedia/webvfx-qt5/Makefile b/multimedia/webvfx-qt5/Makefile
index 8b0ddc1ae31a..8969e0a1ada7 100644
--- a/multimedia/webvfx-qt5/Makefile
+++ b/multimedia/webvfx-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= webvfx
DISTVERSION= 0.4.4-20160823
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
PKGNAMESUFFIX= -qt5